Rajz animálási probléma Impress-ben

Bemutatókészítő

Rajz animálási probléma Impress-ben

HozzászólásSzerző: be-or » 2019. március 13., szerda 11:06

Tanácsot kérnék arra problémámra, hogy nem tudok semmilyen
formában rajzot animálni az Impress-ben.
Nem régen álltam át Win10-re és ezzel egy időben LO6.2-re is.
A Help-et hiába bújom, és hiába járom végig a kijelölt utat,
nem jelenik meg semmilyen eredmény.
A korábbi LO verziókban még csak-csak sikerült valamilyen
animációt előállítani, de most nem. (Már a Help-ben sem pontos
az Menű szerinti elérés, de az még kezelhető).
Ha valaki szintén megnézné, hogy mondjuk: Két karcsú, egymást
90 fokban metsző (kereszt) téglalapot hogyan lehet megforgatni
és ezt megmutatná, nagyon megköszönném.

Péter
libreoffice 6.1.5.2; Windows 10
be-or
 
Hozzászólások: 16
Csatlakozott: 2018. december 27., csütörtök 19:29

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: Zizi64 » 2019. március 13., szerda 14:08

Én úgy szoktam (igen ritkán, de egynél már azért többször csináltam), hogy Drawban rajzolom meg és hozom létre (ez esetben lépésenkénti forgatással) fázisokat és azokat emelem át egyenként az Impress funkciójába. Az eredmény egy animált GIF lesz.
Oda kell figyelni az objektum-határokra (valami apró ponttal kijelölni azt) mert különben a LO hajlandó az objektum aktuális befoglaló méretét az animált kép alapméretéhez illeszteni, azaz "zoomolni" a fázisokat.

De majd megnézem LO6.2.1 Fresh-ben, amit csak most raktam még fel, és csak hordozható változatban. Egyébként is a Still verzió (most: LO6.1.5) használata javallott éles munkához.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.2.5, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3438
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: Zizi64 » 2019. március 13., szerda 17:46

Nem régen álltam át Win10-re és ezzel egy időben LO6.2-re is.

Akkor légy szíves, frissítsd majd az itteni aláírásodat is.
Felhasználói vezérlőpult - Profil (fül) - Aláírás szerkesztése (al-fül)
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.2.5, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3438
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: be-or » 2019. március 13., szerda 19:44

Röviden leírom azt, hogyan próbálkozom.

Lerajzolok egy karcsú "kereszt" idomot (1. kép)
Ezt az idomot - az előzőre - másolom, majd 45 fokkal elforgatom (2. kép)
Majd előhívom: Menű - Berszúrás - Média - Animált kép
Megjelenik az Animáció nevű ablak.
Rákattintok az első idomra (1. képre)
Az Animáció ablakban rákattintok a Bitkép objektumra, utána a Kép (nyíl) ikonra, utána beállítom a Hossz (2 sec) Ismétlések száma (5) értéket, utána rákattintok a Létrehozás gombra.
Az Elölnézet ablakban nem jelenik meg semmi. (Mintha, itt korábban megjelent volna a az 1. kép ???)
Rákattintok a második idomra (2. képre)
Az Animáció ablakban rákattintok a Bitkép objektumra, utána a Kép (nyíl) ikonra, utána beállítom a Hossz (2 sec) Ismétlések száma (5) értéket, utána rákattintok a Létrehozás gombra.
Az Elölnézet ablakban nem jelenik meg semmi. (Mintha, itt korábban megjelent volna a a 2. kép is ???)
Rákattintok a Lejátszás gombra.
Alul megjelenik egy zöld futósáv, mint amikor a mentés művelete zajlik, de semmi nem történik. Sem az Animációs ablakban, sem a Dián.

Ugyan ez van akkor is, ha az idomok nem egymáson vannak, hanem egymás mellett.
Itt tartok.....

Péter
libreoffice 6.1.5.2; Windows 10
be-or
 
Hozzászólások: 16
Csatlakozott: 2018. december 27., csütörtök 19:29

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: Zizi64 » 2019. március 14., csütörtök 8:04

Az Impress - tudtommal - csak összeállítani tudja az animált kép objektumot a máshogyan, előre megrajzolt fázisok menedzselésével. Bár most, hogy mondod, lehet, hogy hoztam már létre olyan animációt, amikor a fázisok létrehozását is a programcsomagra bíztam: mondjuk egy piros kör átmegy kék négyzet alakba.
Ezt is meg kell majd néznem - ha lesz rá időm -, mert nem emlékszem, hogy hogyan is csináltam, ráadásul még nem a 6-os verzióval tettem mindezt.


(Már a Help-ben sem pontos az Menű szerinti elérés, de az még kezelhető).

Könnyen lehet, hogy a Help-ben a menürendszer és eszköztár rendszer durva átszervezése előtti állapotra utaló szöveg maradt: ezt jelentened kellene a fejlesztők felé a magyar, vagy az angol hibabejelentő oldalakon.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.2.5, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3438
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: Zizi64 » 2019. március 14., csütörtök 11:03

No:

A dolog működik nekem LO6.2.1-ben is: Bitmap jellegű fázisokkal.
- A Bitmap fázisokat a Draw "Átúsztatás" funkciójával hozom létre, az átúsztatás eredménye egy vektorgrafikus kép-csoport lesz,
- amit szétrobbantok, és a fázis-képeket egyenként Bitmap képpé alakítom.
- Ezeket a különálló képeket átemelem Impressbe, és ott az animált kép készítő komponenssel létrehozom az animált képet.
- Az animált kép készítő funkcióban a "Bitkép objektum" rádiógombot választom.
- Az első fázis beemelésekor beállítom a fázis megjelenési idejét, aztán már csak egyenként kattintani kell a fázisokra a slide-on, és a hozzáadás gombra a funkción belül.

Ahogy jeleztem is fentebb, ügyelni kell a "háttér" színére, és arra, hogy a fázisképek mindenképpen középre igazítódnak az animáció ablakán belül - vízszintesen és függőlegesen is. Ezért ha a képtartalomnak aszimmetrikus elhelyezkedésűnek kell lennie az ablakhoz képest, akkor pozicionáló objektumokat kell alkalmaznod (apró, alig látható pontokat például a kép "sarkaiban", és azzal együtt bitképpé alakítani a fázisokat.

A "Csoportobjektum" opciót nem sikerült működésre bírni sem a 4.4.7 sem a 6.2.1 verzióban - sem most, sem régebben -, pedig szerintem pont arra szolgálna, hogy egy csoportosított objektum elemeit ne egyenként kelljen bevinni az animációba... De erről nincs több tudásom...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.2.5, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3438
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: be-or » 2019. március 14., csütörtök 13:39

Attól félek, hogy nagyon elölről kell kezdenem, az ismereteim hiányosságai miatt.

Ha Draw-ban mondjuk megrajzolok egy keresztet (Egyszerű alakzatok ikon), akkor ez egy vektorgrafikus kép lesz-e?
Mert amikor ezt az ábrát megrajzolom és kiválasztom, az Átúsztatást funkciót (bár halványan ott van a menüben) nem tudom kiválasztani.
Vajon ez a funkció hozná létre azt a slide-ot, amelynek a fázisait animálni kellene?

Eddig a fázisokat új rajzok előállításával hoztam létre. Ezek, akár egymáson, akár egymás mellett lehetnek. (Mint egy rajzfilm kockái)
Ez lenne az animáció két fázisa. A méretük pici (30 x 30 mm).
(De ezeket a rajzolásokat az Impress-ben is el tudom végezni.) Vajon jó-e így?

Átmásolom a két rajzot (kereszteket) az Impress-be.
Egyenként kijelölöm őket és mindegyikhez a "Bitkép objektum" rádiógombot választom.
Idő és egyéb megadva. De, az Animációs ablakban nem jelenik meg a kijelölt fázisrajz. A létrehozás gomb benyomása után sem látni az Animációs ablakban semmit.

Ha lejátszás gombot megnyomom, akkor a zöld sávon kívül semmi. Ráadásul, az Impress-ben a rajzokat már nem lehet újból kijelölni-törölni, a diát sem lehet fejleszteni-törölni. Csak az Impress-ből történő kilépés segít.

Valamit nagyon nem jól csinálok. Nehogy, mint a múltkor is volt, újra kelljen telepíteni a LibbreOffice-t.

Péter
libreoffice 6.1.5.2; Windows 10
be-or
 
Hozzászólások: 16
Csatlakozott: 2018. december 27., csütörtök 19:29

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: Zizi64 » 2019. március 14., csütörtök 16:48

Ha Draw-ban mondjuk megrajzolok egy keresztet (Egyszerű alakzatok ikon), akkor ez egy vektorgrafikus kép lesz-e?

Minden rajzobjektum, amit a LO bármely alkalmazásával RAJZOLSZ, a eredendően vektorgrafikus lesz. Azaz: minőségromlás nélkül átméretezhető vonalak, alakzatok, színnel kitöltések vannak csak bennük.
Bitképeket csakis a konvertáló funkcióval lehet létrehozni, vagy a programokon kívülről, "kész" bitképet beimportálni lehet még.


Mert amikor ezt az ábrát megrajzolom és kiválasztom, az Átúsztatást funkciót (bár halványan ott van a menüben) nem tudom kiválasztani.
Vajon ez a funkció hozná létre azt a slide-ot, amelynek a fázisait animálni kellene?

KETTŐ alakzatot kell egyszerre kiválasztanod, amik között az "Átúsztatást" (azaz a köztes fázisokat a megadott lépésközökben képes) kiszámítani és megrajzolni a Draw. Lehet az átúsztatás célja a pozíció más objektumokhoz viszonyítva, lehetnek azok elforgatási fázisok, és lehetnek két teljesen eltérő alakú és színű objektumnak az "átváltozási" fázisai.
Utóbbira példa: Így sikerül néhány lépésben keresztből gyűrűt varázsolni...

Átúsztatás.png


A mellékelt .odg fájlban az átúsztatás előtti állapot van. Töltsd le, nyisd meg, bekeretezéssel jelöld ki mindkét elemet, és akkor az Átúsztatás funkció használhatóvá válik.

Átúsztatás.odg
(8.76 KiB) 22 alkalommal.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.2.5, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3438
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: Zizi64 » 2019. március 14., csütörtök 16:55

Eddig a fázisokat új rajzok előállításával hoztam létre. Ezek, akár egymáson, akár egymás mellett lehetnek. (Mint egy rajzfilm kockái)
Ez lenne az animáció két fázisa. A méretük pici (30 x 30 mm).
(De ezeket a rajzolásokat az Impress-ben is el tudom végezni.) Vajon jó-e így?

Persze, kézzel is létrehozhatod a fázisokat, nem muszáj automatizmust használni hozzá. De az automatizmus (az Átúsztatás) csak a Draw-ban működik. De a kettő képkocka, kettő fázis az kevés lesz. Az csak ugrást fog eredményezni az egyik állapotból a másikba, és nem mozgást.
Manuálisan egyetlen objektum is elég: azt az egyet elforgatod pár fokkal minden beillesztés előtt. (Az animációkészítő ablakába történő beillesztés előtt)

https://help.libreoffice.org/6.2/hu/tex ... ading.html

és itt az Impress funkciójának a leírása:
https://help.libreoffice.org/6.2/hu/tex ... _id3153188
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.2.5, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3438
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: Zizi64 » 2019. március 14., csütörtök 17:00

De van egy másik fajta animáció is az Impressben, az említett GIF-es, és a slide-ok átmeneti (váltási) animációján kívül is: amikor egy rajzobjektumot késleltetve úsztatsz be a slide-ba. De erre sem emlékszem már hogy hogyan is kell csinálni...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.2.5, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3438
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: be-or » 2019. március 14., csütörtök 21:39

Nagyon köszönöm az eddigi segítségedet.

Az Átúsztatást most értettem meg. Ismét tanultam valamit.
Szorgalmasan tanulmányozom a leírásokat. És csak akkor
zavarok ismét, ha sikerült megoldanom ezt a problémámat (is).

Péter
libreoffice 6.1.5.2; Windows 10
be-or
 
Hozzászólások: 16
Csatlakozott: 2018. december 27., csütörtök 19:29

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: be-or » 2019. március 28., csütörtök 22:46

Időközben, bár eddig igazából időm nem sok volt, sikerült tovább lépnem.
1. Az LO 6.1 verziójára cseréltem az LO 6.2-t.
2. Rájöttem, hogy az Animáció ablakban a Létrehozás gombot csak akkor nyomom meg, ha már minden rajzi fázis felkerült.
3. Ahogyan javasoltad, előbb egy Draw-ban megrajzoltam a fázis rajzokat.
4. Minden fázisrajzot, mivel több részletből álltak, az Alakzat-Összevonás utasítással egyesítettem.
5. Átmásoltam őket az Impress-be és egyesével az Animáció ablakba az Objektum alkalmazása gombbal betettem.
6. Az animáció működött.
De...
A Draw-ban a különböző színű elemekből az Alakzat-Összevonás utasítással egyesített rajz elvesztette a színeit, pedig ez kellene. Az egyesített rajz újra színezhető, de csak azonos színnel.
A rajz átalakítása az Alakzat-Átalakítás-Bitképpé utasításra, a rajz kontúrvonalai közül több eltűnt.

Ha, tudnál (tudnátok) a gondokon segíteni, nagyon megköszönném.

Péter

U.I. Tudom, módosítanom kell az LO verzíó számomat.
libreoffice 6.1.5.2; Windows 10
be-or
 
Hozzászólások: 16
Csatlakozott: 2018. december 27., csütörtök 19:29

Re: Rajz animálási probléma Impress-ben

HozzászólásSzerző: Zizi64 » 2019. március 28., csütörtök 22:58

Az Összevonás és a Csoportosítás két különböző dolog. Melyiket is akartad alkalmazni valójában?

A Draw és Impress mintafájljaidat töltsd fel ide, hogy pontosan láthassuk, miről is van szó...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.2.5, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3438
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest


Vissza: Impress

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 0 vendég