Formulaires : taille police anormalement grande

Discussions sur le module de base de données Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est dédiée au module Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.
Pour accélérer les réponses, vous pouvez mettre en ligne votre base en joignant un fichier ODB : comment faire.

Formulaires : taille police anormalement grande

Messagepar yves30 » 20 Nov 2018 18:39


La modération a écrit:Titre : Ajout de la balise [Résolu] et adaptation de la longueur (60 caractères maxi)

Bonjour

Depuis hier, l'anomalie suivante se produit sur tous mes fichiers de Base, mais uniquement sur les formulaires (les tables, les requêtes et les rapports, ne sont a priori pas contaminés).

Lorsque le formulaire s'ouvre (que ce soit en lecture ou en édition), tout s'affiche plus gros à l'écran, tout spécialement les caractères (environ 40 % de plus que la taille habituelle), comme si j'avais utilisé le zoom (ce qui n'est évidemment pas le cas). J'ajoute que je n'ai rien fait de spécial au moment où ce grossissement est apparu (pas de plantage, ni de réinstallation...)

Dorénavant, dans les formulaires, seules les barres d'outils conservent leur taille et leur aspect habituel.

J'ai construit mes formulaires (taille des caractères, taille des contrôles...) de manière à ce que tout soit affiché sur mon écran... Or, depuis hier, ce grossissement non voulu, m'oblige à continuellement utiliser les ascenseurs, ce qui est très gênant...

J'ai cherché sur le forum si cette bizarrerie était répertoriée par d'autres utilisateurs (dans la fenêtre "Rechercher", j'ai tapé "anomalie", "affichage", "formulaire", etc.), mais n'ai rien trouvé.

Quelqu'un a-t-il une idée sur ce qui a bien pu provoquer ce dysfonctionnement, et surtout... comment le corriger ? Est-ce qu'un membre de la communauté peut reproduire cette anomalie sur le fichier ci-joint ? Je précise que, avant l'anomalie, la taille des polices utilisées dans mes formulaires était sensiblement identique à celle des menus ; actuellement, la taille a pratiquement doublé.

Yves30 - Disques.odb
(63.59 Kio) Téléchargé 25 fois


Merci d'avance pour vos lumières.
Dernière édition par yves30 le 22 Nov 2018 09:31, édité 1 fois.
LibreOffice 6.0.7.3, Mint Cinnamon 19, noyau : 4.15.0-29-generic, PC Bureau Pentium dualcore G4400, 64 bits, 8 Go
Avatar de l’utilisateur
yves30
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 139
Inscrit le : 18 Nov 2006 19:43
Localisation : France - Nîmes (Gard)

Re: Formulaires : taille de l'affichage anormalement grande

Messagepar HRk2o » 20 Nov 2018 23:12

Bonsoir,

Tous les formulaires s'affichent normalement sur mon écran 27", à part celui du" ModifGenreMusical " légèrement grossi.
Mais un réajustement à l'aide du zoom et l'affichage est ensuite fixé.

note: je n'ai pas agrandi les formulaires à la taille max. de l'écran; ils conservent donc les dimensions originales.

@+
pour test:
Yves30 - Disques1.odb
(63.43 Kio) Téléchargé 17 fois
AOO 4.15 et LO 4.37 sous OsX El Capitan ;AOo 4.15 sous OsX Sierra + Windows 7 sous AOO 4.15 et LibO 4.4.6
HRk2o
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 243
Inscrit le : 29 Mai 2009 09:51
Localisation : Guyane

Re: Formulaires : taille de l'affichage anormalement grande

Messagepar tintin » 20 Nov 2018 23:24

Bonjour,
yves30 a écrit:les caractères (environ 40 % de plus que la taille habituelle
HRk2o a écrit:Tous les formulaires s'affichent normalement
Chez moi aussi.

Capture d’écran 2018-11-20 à 23.21.42.png
AOO 4.1.6 / macOS 10.14.6 Mojave
Java-8u221 / Firefox / Safari / Thunderbird / Time Machine
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6160
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Formulaires : taille de l'affichage anormalement grande

Messagepar OOotremer971 » 21 Nov 2018 01:05

Bonjour,

Chez moi z'aussi tous les formulaires s'ouvrent normalement (Ubuntu 18.04 noyau 4.15.0-39-generic x86_64)

@+
Pièces jointes
Yves30.png
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Ubuntu
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
HédOOniste
HédOOniste
 
Message(s) : 2048
Inscrit le : 16 Avr 2010 14:31

Re: Formulaires : taille de l'affichage anormalement grande

Messagepar yves30 » 21 Nov 2018 11:07

Bonjour,

Merci, HRk2o, tintin et OOotremer971, d'avoir accepté d'effectuer ces tests.

Je suis un peu découragé : j'ai la désagréable impression que je me heurte une nouvelle fois à un problème non reproductible.

Je publie ci-dessous une nouvelle capture d'écran (la même page que celle publiée par tintin). Dans le formulaire "AgeCompositeur", étiquette "NomCompositeur", vous pouvez observer la différence de taille d'affichage des caractères : chez tintin, le mot est affiché en entier, chez moi, ce même mot est tronqué ! Après vérification, je précise que la taille des polices utilisée (Noto sans, taille 9), ainsi que la taille des contrôles de l'ensemble de mes BD n'ont pas été modifiées par ce phénomène : seul l'affichage (ce que je vois à l'écran) présente cette anomalie.

J'ajoute, à toutes fins utiles, que le zoom est toujours réglé sur 100 % (et je ne l'utilise jamais). Et d'ailleurs, si je tente de l'utiliser pour corriger ce désagrément (par exemple, en choisissant un zoom de 90 %), cela ne règle pas le problème : en effet, tout s'affiche alors en plus petit (c'est donc plus difficile à lire), mais de manière proportionnelle, ce qui fait que les éléments tronqués, restent malheureusement tronqués.

Bien entendu, dans tous les formulaires de toutes mes bases de données (sans exception), j'avais choisi une taille de police et une dimension des contrôles adaptées à mon écran, et tout s'affichait correctement... du moins, jusqu'à avant-hier.

Capture du 2018-11-21 10-23-46.png
Capture de la même page que celle affichée par tintin


Suite aux vérifications que vous avez effectuées, je suppose que je peux conclure que cela ne vient pas de LO ?... Et pourtant, je le répète, cela ne concerne que les formulaire des BD de LO... Est-ce que quelqu'un pourrait me suggérer une piste pour corriger ce symptôme ?
LibreOffice 6.0.7.3, Mint Cinnamon 19, noyau : 4.15.0-29-generic, PC Bureau Pentium dualcore G4400, 64 bits, 8 Go
Avatar de l’utilisateur
yves30
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 139
Inscrit le : 18 Nov 2006 19:43
Localisation : France - Nîmes (Gard)

Re: Formulaires : taille de l'affichage anormalement grande

Messagepar OOotremer971 » 21 Nov 2018 13:07

Bonjour,

Suite à tes dernières explications, je constate effectivement qu'une partie de l'affichage de certains contrôles est tronquée (mais pas de grossissement comme tu le précises dans ton premier message) :
yves30_1.png

ensuite en mode édition du formulaire je constate que la police utilisée pour le nom du contrôle est définie "Par défaut" :
yves30_2.png

La police par défaut, chez moi est Ubuntu 11.

Alors je n'ai aucune idée de la raison de ce changement brutal, puisque tu dis avoir utilisé une police Noto sans, taille 9 et que je la trouve dans la liste des polices d'Ubuntu, mais je me souviens que dans un précédent sujet, tu précisais que tes bases sont stockées sur une partition pivot afin qu'elles puissent être ouvertes soit sous Windows soit Linux.
Si tes bases ont récemment été ouvertes sous Windows, et que la police Noto sans, taille 9 n'existe pas dans cet environnement, alors je ne vois qu'une explication : une police de substitution (par défaut) à été imposée sous Windows et du coup tous tes contrôles s"en trouvent impactés.

Je dis ça parce que c'est la première chose qui me vient à l'esprit mais le problème peut bien sur être ailleurs et là c'est une autre histoire...

@+
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Ubuntu
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
HédOOniste
HédOOniste
 
Message(s) : 2048
Inscrit le : 16 Avr 2010 14:31

Re: Formulaires : taille de l'affichage anormalement grande

Messagepar yves30 » 21 Nov 2018 15:51

Bonjour, OOotremer971.

Merci pour ton aide.

mais je me souviens que dans un précédent sujet, tu précisais que tes bases sont stockées sur une partition pivot afin qu'elles puissent être ouvertes soit sous Windows soit Linux.


Non, depuis plus de deux ans, je n'utilise plus Windows. Et depuis mai 2018, je suis exclusivement sous Mint-Cinnamon 19, comme indiqué dans ma signature.

Mais ton hypothèse de "police de substitution" qui aurait été modifiée est intéressante. C'est peut-être une piste. Cependant, je t'informe tout d'abord que je n'ai rien modifié dans le domaine des polices, surtout depuis l'apparition de cette anomalie inattendue.

Effectivement, lorsque je crée un contrôle dans mes formulaires, je laisse habituellement le réglage de la police sur "par défaut", et me contente de choisir la taille. J'ai constaté hier que la police en question était nommée "Noto Sans", mais sans y attacher plus d'importance que ça...

Il semble qu'il s'agisse d'un problème d'affichage de police, qui n'intervienne que dans les formulaires de LO...

Pourrais-tu me préciser où je peux choisir (ou modifier) le nom de la "police par défaut", STP ?
- Est-ce au niveau de LO ? Je n'ai rien trouvé dans Outils/Options/LibreOffice/Polices (excepté la possibilité de substituer des polices)...
- Est-ce au niveau du système ? Dans Mint, il y a bien FontManager, mais je n'ai trouvé aucune commande permettant de sélectionner la police par défaut.
LibreOffice 6.0.7.3, Mint Cinnamon 19, noyau : 4.15.0-29-generic, PC Bureau Pentium dualcore G4400, 64 bits, 8 Go
Avatar de l’utilisateur
yves30
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 139
Inscrit le : 18 Nov 2006 19:43
Localisation : France - Nîmes (Gard)

Re: Formulaires : taille de l'affichage anormalement grande

Messagepar OOotremer971 » 21 Nov 2018 16:22

yves30 a écrit:Pourrais-tu me préciser où je peux choisir (ou modifier) le nom de la "police par défaut", STP ?

Je ne sais pas !
yves30 a écrit:Est-ce au niveau du système ?

A mon avis ce serait plus de ce coté là qu'il faudrait fouiller. Juste pour indication, j'ai subi un comportement similaire suite à l'installation de Wine (application qui permet de faire fonctionner sous Linux des utilitaires qui ne fonctionnent que sous Windows) qui a eut pour effet de modifier toutes les polices définies par défaut dans certaines application. Donc si tu as installé récemment une application ce sera probablement une piste à creuser.

@+
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Ubuntu
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
HédOOniste
HédOOniste
 
Message(s) : 2048
Inscrit le : 16 Avr 2010 14:31

Re: Formulaires : taille de l'affichage anormalement grande

Messagepar yves30 » 22 Nov 2018 09:28

Merci pour ces précisions, OOotremer971

Je précise avant toute chose que je n'ai ajouté, ni supprimé, quoi que ce soit sur mon système ces jours derniers qui pourrait expliquer l'origine de ce symptôme (logiciels, drivers, etc.) Mais bien sûr, il y a aussi les différentes mises à jour de Mint...

Par ailleurs, avant d'ouvrir ce fil de discussion, j'ai plusieurs fois relancé le système pour tenter d'éliminer ce désagrément. Mais en vain.

Je résume. Cette aberration d'affichage ne concerne que les polices, et seulement celles utilisées dans LibreOffice (les autres applications, que j'utilise quotidiennement, affichent normalement leurs polices). Par ailleurs, dans LO, l'anomalie se manifeste uniquement dans Base (les fichiers de Writer et de Calc ne sont pas impactés par ce phénomène), et exclusivement dans les formulaires (lesquels utilisent la police par défaut).

Tout ceci m'a amené à soupçonner qu'il s'agissait plutôt d'un réglage relatif à LO. J'ai donc à nouveau cherché de ce côté-là. J'ai ouvert la fenêtre /Outil/Options/LibreOffice/Polices, et j'ai tenté l'expérience suivante.

1) Sous Table de remplacement, j'ai coché Appliquer la table de remplacement, puis, en haut, j'ai ajouté une police à remplacer ("Arial" à remplacer par "Noto Sans") ;
2) Sous Paramétrages de polices pour les sources HTML, Basic et SQL, j'ai décoché Polices non proportionnelles uniquement ; puis j'ai réglé le champ Police sur Automatique, et le champ Taille sur 9.

J'ai enregistré les modifications, j'ai fermé LO, puis je l'ai relancé (sans même relancer le système), et, en ouvrant mes fichiers de BD, puis les formulaires associés, j'ai constaté avec surprise et satisfaction que l'anomalie avait miraculeusement disparu !

Ne me demandez pas quels étaient les réglages de cette fenêtre avant l'incident : jusqu'à ces derniers jours, je n'avais jamais mis mon nez dans ces commandes (je suppose qu'il s'agissait des réglages par défaut). Ne me demandez pas non plus lequel de mes différents bidouillages (1 ou 2) a été décisif pour corriger l'anomalie.

Conclusion : l'anomalie provenait bien de LO. Cependant, j'ignore totalement la raison pour laquelle elle s'est déclenchée brutalement il y a quelques jours, et comment elle a disparu ce matin. Pour moi, cela reste un mystère. Aussi, si un membre de la communauté dispose de plus d'informations à ce sujet, je l'invite à ajouter toutes précisions utiles pour les utilisateurs qui, à l'avenir, pourraient être confrontés à ce phénomène désagréable.

Dans cette attente, je clôture ce fil de discussion,

Merci pour votre aide et vos suggestions.

Cordialement
LibreOffice 6.0.7.3, Mint Cinnamon 19, noyau : 4.15.0-29-generic, PC Bureau Pentium dualcore G4400, 64 bits, 8 Go
Avatar de l’utilisateur
yves30
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 139
Inscrit le : 18 Nov 2006 19:43
Localisation : France - Nîmes (Gard)

Formulaires : taille police anormalement grande [2]

Messagepar yves30 » 05 Déc 2018 15:54

Bonjour,

Je reviens vers vous avec le même problème de taille de police à l'affichage des formulaires, qui avait fait l'objet d'un fil en date du 20 novembre 2018, que j'ai clôturé un peu hâtivement : je croyais avoir résolu le problème, mais, hélas, je me trompais.

Je précise que, depuis cette date, et à plusieurs reprises, le phénomène a réapparu, et disparu tout aussi mystérieusement. Par conséquent, dans l'intervalle (au moment où l'anomalie n'était pas présente), j'ai fait des captures d'écran du formulaire "Compositeurs" (cf. ci-dessous), dans la perspective de revenir vers vous, pour mieux décrire le phénomène.

1) Cette anomalie apparaît et disparaît de manière intempestive : je n'ai ajouté, ni supprimé aucun programme, ni aucun pilote ; je n'ai effectué aucune mise-à-jour... C'est vraiment incompréhensible.

2) Ce phénomène, aussi étrange qu'agaçant, se produit :
- uniquement dans LO (mes autres logiciels affichent les polices de manière tout à fait habituelle).
- uniquement dans les BD de LO : les fichiers Write et Calc, que j'utilise régulièrement, ne sont pas impactés par ce problème (je vérifie chaque fois) ;
- uniquement dans les formulaires des BD de LO (et, dans tous les formulaires, sans exception : j'ai également vérifié). En revanche, l'anomalie ne se produit jamais dans les tables, les requêtes et les rapports.

3) Par exemple, ce matin j'ai travaillé environ deux heures sur une de mes bases de données. J'ai fait uniquement de la saisie, à partir de formulaires, sans toucher à leur structure (je suis donc resté en mode "édition"). Puis, vers 12h00, j'ai refermé mon fichier en laissant mon PC activé. Cet après-midi, au moment d'ouvrir à nouveau le fichier en question, je constate que l'anomalie est de retour ! Je précise qu'entre-temps (de 12h00 à 14h00) je n'ai reçu aucune mise à jour système (qui pourrait expliquer l'apparition d'un conflit quelconque)...

1 Compositeurs - Capture du 2018-11-28 19-09-24.png
Formulaire Compositeur, affichage normal

1 Compositeurs - Capture du 2018-12-05 14-22-35.png
Formulaire Compositeur, avec l'anomalie

Yves30_Disques_2.odb
BD d'où sont tirées les captures d'écran
(82.88 Kio) Téléchargé 19 fois


4) Je décris à nouveau le phénomène : la taille des polices affichées à l'écran a augmenté d'environ 30 à 40 %.

Pour pouvoir comparer efficacement les deux captures ci-dessus, je recommande de les ouvrir côte à côte :
- Dans la capture "affichage normal", on peut constater que la taille de la police utilisée est à peu près la même que celle des titres de la barre des menus, en haut de la fenêtre (Fichier, Édition, Affichage, Insertion, etc.)
- Dans la capture "avec l'anomalie", on peut constater, à l'oeil nu, que la taille de la police utilisée est bien supérieure à celle des titres de la même barre des menus (qui, elle, n'a pas été modifiée par le phénomène).

Voyez également le mot enregistrement, en bas à gauche de la grille secondaire, dans la capture "avec l'anomalie" : il prend une place disproportionnée dans le rectangle qui lui est attribué, alors que dans la capture "avec l'anomalie", sa taille est sensiblement inférieure à celle des autres éléments !...

5) J'ajoute qu'en mode "Edition", si je modifie la police de l'un ou l'autre des contrôles de ce formulaire, cela ne change rien. J'ai essayé "par défaut", Arial, DejaVu, Noto Sans, etc., sans plus de succès...

6) Par ailleurs, le fait de relancer LO ou de relancer mon PC (ce que j'ai fait x fois) ne produit aucune effet.

7) J'ai construit la plupart mes formulaires en attribuant à mes contrôles une dimension autorisant un affichage complet à l'écran, ceci, afin d'éviter d'utiliser les ascenseurs (horizontal et vertical).

Or, pendant la durée de l'anomalie, les différents contrôles affichés prennent également plus de place sur l'écran, de sorte que certaines parties sont masquées (soit à droite, soit en bas). Dans ce cas, l'ascenseur vertical est bien présent (permettant d'afficher les zones inférieures). Malheureusement, aucun ascenseur horizontal ne s'affiche, de sorte que toute la partie située à droite reste indisponible pendant toute la durée de l'anomalie. Ce qui, on le devine, n'est pas très pratique pour travailler.

9) Et le plus étrange, c'est que, dans quelques heures ou quelques jours, l'anomalie va disparaître d'elle-même, aussi brutalement qu'elle est apparue !..., et tout va rentrer dans l'ordre !...

Merci d'avance pour vos suggestions.
LibreOffice 6.0.7.3, Mint Cinnamon 19, noyau : 4.15.0-29-generic, PC Bureau Pentium dualcore G4400, 64 bits, 8 Go
Avatar de l’utilisateur
yves30
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 139
Inscrit le : 18 Nov 2006 19:43
Localisation : France - Nîmes (Gard)


Retour vers Base de données

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)