[Solved] User experience: OpenOffice 4.1.7 on MacOS 10.14.6

Issues installing under the Mac OSX - X11 - Aqua

[Solved] User experience: OpenOffice 4.1.7 on MacOS 10.14.6

Postby MrProgrammer » Sat Nov 02, 2019 9:34 pm

I recently upgraded hardware, and the new machine came with MacOS 10.14 (Mojave) installed. Following the OpenOffice installation instructions, I downloaded and installed AOO 4.1.7 on this machine with no difficulty. Following Oracle's Java installation instructions, I downloaded and installed JRE 1.8.0 with no difficulty. OpenOffice can find and use Java. This took about 20 minutes, excluding download time. (A summary of installation procedures is located in [Tutorial] Mac FAQ Q03/A03, Q05/A05, and Q06/A06.) I copied my documents from the old machine to the new one using an external drive. I can open documents, including password-protected ones, on the new machine with no difficulty. I did not need to make any of the adjustments discussed in Q15/A15 or Q39/A39. No documents are in read-only status (Q16/A16).

I am waiting and reviewing reports in the forum of experience with MacOS 10.15 (Catalina) before installing it because Catalina was released on 2019-10-07 which is after OpenOffice 4.1.7, dated 2019-09-21. I think it is wise to wait for at least one OpenOffice release after a MacOS release before installing the MacOS release. I do not use LibreOffice.
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 4035
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: User experience: OpenOffice 4.1.7 on MacOS 10.14.6

Postby RoryOF » Sat Nov 02, 2019 9:41 pm

From memory: One report is of difficulty pasting filenames into the Catalina File dialogs when used in OO; the OO dialogs took the paste OK.
Apache OpenOffice 4.1.10 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32665
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: User experience: OpenOffice 4.1.7 on MacOS 10.14.6

Postby MrProgrammer » Sun Nov 03, 2019 11:54 pm

RoryOF wrote:From memory: One report is of difficulty pasting filenames into the Catalina File dialogs when used in OO; the OO dialogs took the paste OK.
I was the volunteer who suggested trying the OpenOffice Save dialog instead of the MacOS dialog (Mac FAQ Q37/A37) on Catalina. However, testing Mac OS 10.11 (El Capitan, released 2015), the MacOS dialog does not accept the full path/file name (and the OpenOffice dialog does) so it's worked this way for some time, and I would guess at least ten years.

I believe the operation of the MacOS dialog is not a change with Catalina, though I can't test to see how it works there. And I wouldn't classify it as a problem; it's just the way MacOS Save dialogs are designed. In the MacOS dialog, one must select the directory by using the Where box in the dialog; the box at the top of the dialog is only for the file name, not the path. I did discover today a lesser-known feature of the dialog which does allow one to paste the path into the MacOS dialog: the ⇧⌘G shortcut. The shortcut is documented for Finder (the Mac's file management application) but also works in the Open/Save dialogs though Apple doesn't seem to tell people they can use it there.
Screen Shot 2019-11-03 at 15.57.24.png
The MacOS Save/SaveAs dialog
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 4035
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: [Solved] User experience: OpenOffice 4.1.7 on MacOS 10.1

Postby MrProgrammer » Thu Dec 03, 2020 11:11 pm

Apple recently offered an update to Safari 14.0.1 and unfortunately I installed it. This update will break uploads in Safari on MacOS 10.14.6. This includes, for this forum, the Upload Attachment function in PostReply. It also affects, for example, attempts to attach documents to online email systems. Many people have reported the issue to Apple.

Workarounds:
• Reinstall MacOS 10.14.6, then Security Update 2020-006, but skip the offer of Safari 14.0.1 that will appear. For questions about this process, ask in an Apple forum.
• Use another browser like Firefox until Apple corrects the upload problem. For questions about this process, ask in a Firefox forum.

Some have speculated that Apple does not intend to fix this issue as a way to drive people running MacOS 10.14 to MacOS 10.15 or MacOS 11.0, since the issue does not seem to affect the more recent MacOS versions. I regard this as purely a Safari issue, not a MacOS issue, since uploads work fine with MacOS 10.14.6 and Safari 14.0. The problem has been reported to Apple, but they don't seem to be very helpful with their responses. Personally, I'm not interested in upgrading to either of the later MacOS versions.
 Edit: Safari 14.0.2 does not fix the upload problem. 
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 4035
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 3 guests