[Issue] Print set-up shows portrait but prints landscape

Issues installing under the Mac OSX - X11 - Aqua

[Issue] Print set-up shows portrait but prints landscape

Postby Silvertree01 » Wed Jan 02, 2013 8:50 pm

I am new to OO and this problem is driving me crazy.
My doc. documents display on screen in Portrait format, but print in Landscape format using Print command from File menu. However, when I print directly from Print icon on toolbar, they print in Portrait format.
I checked File Menu - Page Preview - which shows document in Portrait format.
I also checked View Menu - Page Layout - which shows document in Landscape format.
What's going on?
Last edited by Hagar Delest on Thu Jan 10, 2013 5:11 pm, edited 1 time in total.
Reason: tagged the thread as Issue (link to a bug report).
OpenOffice 3.3.0 on MacOS 10.8.2
Silvertree01
 
Posts: 1
Joined: Wed Jan 02, 2013 8:21 pm

Re: Print set-up shows portrait but prints landscape

Postby thomasjk » Thu Jan 03, 2013 3:08 am

Try resetting the user profile viewtopic.php?f=74&t=12426
Tom K.
Windows 10 Home version 1803 17134.165
LibreOffice 5.4.7.2
thomasjk
Volunteer
 
Posts: 4431
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: Print set-up shows portrait but prints landscape

Postby Rosette » Thu Jan 10, 2013 10:25 am

Hi, I am having the same problem, have you fixed it and if so HOW? I am a novice, please reply using basic language! Thanks,
Open Office.org 3.1
Apple Mac
Rosette
 
Posts: 3
Joined: Thu Jan 10, 2013 10:18 am

Re: Print set-up shows portrait but prints landscape

Postby Hagar Delest » Thu Jan 10, 2013 10:58 am

Have you at least tried to reset the profile as explained in the link above?
LO 6.4.6 on Xubuntu 20.04 and Windows 10.
User avatar
Hagar Delest
Moderator
 
Posts: 29064
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Print set-up shows portrait but prints landscape

Postby acknak » Thu Jan 10, 2013 4:42 pm

I don't know if this is related, but I've been having this problem with the new AOO on Linux. Too many things have been upgraded recently for me to be sure it's OOo's fault; I've just been exporting to pdf and printing from that (I'm finding I do less and less paper printing these days).

 Edit: PS: 
Here's a bug report for it:
Issue 121080: printing on PDF format or Preview by print panel ignores page orientation
You can register there and add your vote (up to two) or comment.

The report is almost 4 months old and still unconfirmed; that doesn't seem too encouraging.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Print set-up shows portrait but prints landscape

Postby RoryOF » Thu Jan 10, 2013 4:48 pm

I haven't had any Portrait printing as Landscape problems with A003.4.x on Ubuntu printing from several computers to several different brands of printer.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31700
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Print set-up shows portrait but prints landscape

Postby Rosette » Thu Jan 10, 2013 5:14 pm

I tried to do the reset the profile but to be honest I didn't really understand it, as I say I am a novice on this and I have an apple mac OSX - Mountain Lion if this helps?
Could you give me step by step instructions for an idiot :-)
Open Office.org 3.1
Apple Mac
Rosette
 
Posts: 3
Joined: Thu Jan 10, 2013 10:18 am

Re: [Issue] Print set-up shows portrait but prints landscape

Postby Hagar Delest » Thu Jan 10, 2013 5:20 pm

Have you really read the posts? They were written with some level of details and step by step instructions.
LO 6.4.6 on Xubuntu 20.04 and Windows 10.
User avatar
Hagar Delest
Moderator
 
Posts: 29064
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Issue] Print set-up shows portrait but prints landscape

Postby kabing » Fri Jan 11, 2013 7:08 pm

I can see how the instructions would not be all that clear for a novice or even a "basic" Mac user. Here are some step-by-step instructions:

-Make sure that OpenOffice is closed
-Go to the Finder (click the blue face icon on the dock)
-Hold down the option key while choosing the "Go" menu
-Select "Library" from the list that appears; a new Finder window will open
-in that window, find the "Application Support" folder and open it
-Find the OpenOffice.org folder and open it
-Find the 3 folder and open it
-Inside the 3 folder, is a folder called "user" you want to either move this folder to the desktop, or rename it

Now restart OpenOffice, and see if that resolves the problem.
NeoOffice (app store version) OpenOffice.org 4.1 and LibreOffice 4.3 on Mac OS X El Capitan
OpenOffice.org 4.1.2 on Windows 10 (Previously on Vista)
User avatar
kabing
Volunteer
 
Posts: 678
Joined: Fri Nov 23, 2007 12:05 am
Location: Midwest, USA

Re: [Issue] Print set-up shows portrait but prints landscape

Postby Rosette » Tue Jan 22, 2013 6:20 pm

Thank you so much kabing! Yes it has worked! I have been trying for ages. What do I do with the user folder that I now have on the desk top? Shall I leave it there?
Thanks again, you are a diamond!
Open Office.org 3.1
Apple Mac
Rosette
 
Posts: 3
Joined: Thu Jan 10, 2013 10:18 am

Re: [Issue] Print set-up shows portrait but prints landscape

Postby kabing » Tue Jan 22, 2013 7:11 pm

If you haven't created templates, autotexts, or customized keyboard shortcuts and the like, you can just throw the "user" folder on the desk top away (drag it to the trash).

I you have created templates, autotexts, customized keyboard shortcuts or the like, you will need to decide how much work you are willing to go through to try to salvage them. It is possible to go through a process of elimination to find the specific preference file that is corrupt, in order to save the other files. It's a bit time consuming and fiddly, though.
NeoOffice (app store version) OpenOffice.org 4.1 and LibreOffice 4.3 on Mac OS X El Capitan
OpenOffice.org 4.1.2 on Windows 10 (Previously on Vista)
User avatar
kabing
Volunteer
 
Posts: 678
Joined: Fri Nov 23, 2007 12:05 am
Location: Midwest, USA

Re: [Issue] Print set-up shows portrait but prints landscape

Postby jmarcd2 » Wed Jul 31, 2013 12:13 am

I hope i'm not too late ... i've feedback on this issue of Portrait vs Landscape.

I was using a old computer for labelling running Windows XP/SP2/512M+20G and OpenOffice 2.0 (Yes you readit correctly)

This computer as never been updated since is installation with One SATO and One Epson Printer for shipping label.
Off-course this computer i'm talking about this because a HDD malfunction cause the computer to crash.

So ok, i,ve put a new hdd and re install the machine using Windows XPSP2 and the Latest OpenOffice3 (at the time) and give the computer back to the shipper.
After couple of fast test that all printer work... Phone ring in the middle of the day the girl using that machine tell me something wrong.
All hers label print side-wise ? Ask my self what are you talking about ... I've not play with your label folder and the printer driver are the same.

Imagine the problem of Portrait vs Landscape is starting ... after couple of hours, i decide the try to restore hers old HDD with clone ignoring bad sector and reboot.
Magic .. problem of Portrait vs Landscape gone. She looking at here label on the screen and ask to OpenOffice2 to print landscape no problem.

It's return to OpenOffice2 and no problem ... is this can help your diagnostic of printer what you see should be what you want. I've been printing Landscape with MSWord for longtime and i've to return to MS office when i'm doing Label no choice.

Thank you for reading ..

PS. Yes I've try all the trick found on all the forums reset the profile, changes drivers .. so all my friend who thing no body understand ... welcome to our world of no Landscape.
OpenOffice 2 / OpenOffice 3 / OpenOffice 4 on Windows XP /7 /8 or OsX 10.6.8 or CentOS5 or Ubuntu 10
jmarcd2
 
Posts: 2
Joined: Tue Jul 30, 2013 11:54 pm

Re: [Issue] Print set-up shows portrait but prints landscape

Postby wydrzyk » Sun Sep 01, 2013 11:36 pm

Hi, I`m having the same problem, I tried to reset the profile - that did not help.
I used hints of jmarcd2 too - nothing...
I don`t know what to do. I use a pretty new computer (DELL), with Win7, and OO version 3.3.0. What can I do more?... Please, help me, I must to print a lot.
OpenOffice 3.3.0, Win7, [url=http://www.kraktour.com]wieliczka salt mine[/url], [url=http://ortho-med.pl/]stomatolog wrocław[/url], [url=http://www.carter.pl/]części toyota gdańsk[/url], [url=http://www.kolumnapark.pl//]hotel łódź[/url], [url=http://sdm-myszkowski.com/]sdm[/url],
User avatar
wydrzyk
Banned
 
Posts: 3
Joined: Sun Sep 01, 2013 9:47 pm

Re: [Issue] Print set-up shows portrait but prints landscape

Postby acknak » Mon Sep 02, 2013 5:42 pm

The most helpful workaround for printing issues is to export to pdf, then print from that. The pdf viewer software is generally more robust.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [Issue] Print set-up shows portrait but prints landscape

Postby RoryOF » Mon Sep 02, 2013 5:59 pm

Check your settings under /Format /Page and when you have selected a printer check Properties in /File /Print

One workaround is to set up two printers on the same port, one set to Landscape, one set to Portrait. Then just print to the appropriate printer.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31700
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Issue] Print set-up shows portrait but prints landscape

Postby jmarcd2 » Wed Nov 27, 2013 5:12 pm

I found a solutions about the landscape/portrait problem.

Well, actually i did not found-it because have notice this since the begin...

Setting two printer on the same ports... one on portrait second on landscape ...
well this for some reason not allways working....

THE solution allways working for me, since i have a dedicated station for label etc...

Roll back to version 2.0.2 of openoffice ... work perfectly well


what did you change when passing to OO 3.xx no clue but 2.0 work as expected.

good luck
OpenOffice 2 / OpenOffice 3 / OpenOffice 4 on Windows XP /7 /8 or OsX 10.6.8 or CentOS5 or Ubuntu 10
jmarcd2
 
Posts: 2
Joined: Tue Jul 30, 2013 11:54 pm

Re: [Issue] Print set-up shows portrait but prints landscape

Postby acknak » Wed Nov 27, 2013 5:28 pm

I never had any problem with page orientation until the last few releases--maybe 3.3 and following.

Apparently the workaround for this problem is to switch OO from pdf to postscript format for sending data to the print system: look under the printer properties and change the "Printer language type" to Postscript. That fixes the orientation problems for me.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 4 guests