[Solved] Text invisible in Help panel

Issues installing under the Mac OSX - X11 - Aqua

[Solved] Text invisible in Help panel

Postby randallbsmith » Sat Mar 06, 2010 1:22 am

I am running Mac OS 10.6.2 using OpenOffice 3.2.0.

When I select the menu item Help > OpenOffice.org Help, a large window appears with the help index or contents listed nicely down the left side, but the right side panel does not work: Any particular topic I select from the contents or index only displays any icons (such as a push pins) and/or horizontal separating bars -- but never any text!

The text really is in there -- I can select this invisible text and paste it into a text editor, in which case I can read it as plain text. So it is as though the font being used by the help panel is white, or transparent, or otherwise more deeply screwed up.

Help?
Last edited by Hagar Delest on Thu Mar 25, 2010 9:24 am, edited 1 time in total.
Reason: tagged [Solved].
Open Office 3.2.0 build 9483 with Mac OS 10.6.1
randallbsmith
 
Posts: 7
Joined: Sat Mar 06, 2010 1:04 am

Re: Text invisible in Help panel

Postby Hagar Delest » Sat Mar 06, 2010 1:18 pm

Hi and welcome to the forum!

I've split your post from the initial topic (viewtopic.php?f=7&t=28070) because it's not really the same problem (nor the same OS I think).

Can you upload a screenshot? (see: How to attach a document here)?

As a first try, you can reset your OOo user profile. But during the welcome process (if you had 2.x before), don't transfer your personal data, former configuration files might corrupt the new profile.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28543
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Text invisible in Help panel

Postby fhalasz » Tue Mar 09, 2010 6:08 am

I have exactly the same problem using Calc. Running Mac OSX 10.6.2 and OOo 3.2. Also, nothing shows in the spreadsheet boxes but it does show on the entry line (formula box). In Writer, the text displays correctly in the document but the help function works the same as in Calc, i.e. displays icons like push pins but no text. I have tried resetting the user profile per your instructions with no change.
Open Office 3.1 on MacOS 10.4; Open Office 3.2 on MacOS 10.6
fhalasz
 
Posts: 3
Joined: Tue Mar 09, 2010 5:25 am

Re: Text invisible in Help panel

Postby fhalasz » Tue Mar 09, 2010 7:04 am

invisibletext.png

invisiblehelp.jpg
Here are the screenshots. Sorry about the jpeg, but the other formats were too big.
FYI, cell A1 contained the number 12 and B1 contained 14. I presume C1 would show 26 if it showed anything. Again, this was OOo3.2 on an iMac running OSX 10.6.
Open Office 3.1 on MacOS 10.4; Open Office 3.2 on MacOS 10.6
fhalasz
 
Posts: 3
Joined: Tue Mar 09, 2010 5:25 am

Re: Text invisible in Help panel

Postby randallbsmith » Thu Mar 18, 2010 12:40 am

Thanks for your reply. I will try resetting the profile as you suggest in a moment, but first, for the record:

Here is the screen snapshot of the Help window showing (so to speak) invisible text.

--Randy
Attachments
InvisoText.jpg
Open Office 3.2.0 build 9483 with Mac OS 10.6.1
randallbsmith
 
Posts: 7
Joined: Sat Mar 06, 2010 1:04 am

Re: Text invisible in Help panel

Postby randallbsmith » Thu Mar 18, 2010 12:52 am

Sorry to say, resetting the user profile had no effect for me either.

Here is another screen shot just to enrich the graphical variety of life... :-)

--Randy
Attachments
invisoText2.jpg
Open Office 3.2.0 build 9483 with Mac OS 10.6.1
randallbsmith
 
Posts: 7
Joined: Sat Mar 06, 2010 1:04 am

Re: Text invisible in Help panel

Postby randallbsmith » Thu Mar 18, 2010 10:25 pm

BTW: If someone can tell me the exact font being used in the help panel, maybe I can see if it is on my system.
Open Office 3.2.0 build 9483 with Mac OS 10.6.1
randallbsmith
 
Posts: 7
Joined: Sat Mar 06, 2010 1:04 am

Re: Text invisible in Help panel

Postby randallbsmith » Thu Mar 25, 2010 12:52 am

Okay I found a solution! There is a "font cache corruption problem" on Mac OS. The solution is to clear the font cache. There are several ways to do this. I used Font Finagler, a version late enough to work with my Snow Leopard.
Open Office 3.2.0 build 9483 with Mac OS 10.6.1
randallbsmith
 
Posts: 7
Joined: Sat Mar 06, 2010 1:04 am

Re: Text invisible in Help panel

Postby Hagar Delest » Thu Mar 25, 2010 9:24 am

Thanks for the follow-up!
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28543
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Text invisible in Help panel

Postby Whitehand » Thu Dec 16, 2010 5:11 pm

Can someone be a bit more specific about how to solve this? I have the same issue and have no idea what "font finagler" is and what needs to be done to fix the issue. Thanks.
Mac Snow Leopard OS Intel
Openoffice.org for Mac 3.2.1
Whitehand
 
Posts: 2
Joined: Thu Dec 16, 2010 5:06 pm

Re: [Solved] Text invisible in Help panel

Postby randallbsmith » Thu Dec 16, 2010 6:43 pm

Well, when I google "font finagler" I get this.

http://homepage.mac.com/mdouma46/fontfinagler/

The free version I have expired long long ago, and I can't recall how I used Font Finagler to "clear the font cache" but since I managed to figure it out, it's probably pretty easy.(?)

--Randy
Open Office 3.2.0 build 9483 with Mac OS 10.6.1
randallbsmith
 
Posts: 7
Joined: Sat Mar 06, 2010 1:04 am

Re: [Solved] Text invisible in Help panel

Postby kabing » Thu Dec 16, 2010 8:13 pm

There are several utilities that can clear the font caches for you. Font Finagler is one. Onyx is another. FontNuke and Cocktail are two more.

I've only used Onyx, so I can't tell you how to use Font Finagler. But any of these apps should provide instructions for clearing font caches.

kabing
NeoOffice (app store version) OpenOffice.org 4.1 and LibreOffice 4.3 on Mac OS X El Capitan
OpenOffice.org 4.1.2 on Windows 10 (Previously on Vista)
User avatar
kabing
Volunteer
 
Posts: 678
Joined: Fri Nov 23, 2007 12:05 am
Location: Midwest, USA

Re: [Solved] Text invisible in Help panel

Postby MrProgrammer » Sat Dec 18, 2010 6:03 am

Another possibility is to temporarily start the Mac in "safe mode". See Finder, Help, Search = safe for instructions. Information that I've read suggests that safe mode will purge the font cache. Then shut down the system and reboot normally (since you don't want to operate the system in safe mode). If this works for you, it has the advantage that no extra software needs to be installed.
Mr. Programmer
AOO 4.1.5 Build 9789 on MacOS 10.11.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 3815
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: [Solved] Text invisible in Help panel

Postby Whitehand » Sat Dec 18, 2010 3:29 pm

I did a google search and found you can used the Terminal command "atsutil databases -removeUser" to clear the cache, worked like magic!! Thanks everyone!
Mac Snow Leopard OS Intel
Openoffice.org for Mac 3.2.1
Whitehand
 
Posts: 2
Joined: Thu Dec 16, 2010 5:06 pm


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 2 guests