[Solved+Issue] Pictures dragged appears as links

Discuss the presentation application

[Solved+Issue] Pictures dragged appears as links

Postby johnlim » Sun Feb 01, 2009 4:15 pm

Welcome beginner. What is your question or comment?
Please try to briefly and clearly tell us: What you want, What you tried, and What happened.
-----------------------------------------------------------------------------------------------------------
when i created an Impress presentation and dragged photos from a photo directory into the presentation, Impress seem to create a link instead of actually copying the photo into the presentation. Consequently the presentation slides cannot be viewed on another pc where the photo folder is not located. When i open the Impress file on another PC, i see only links (please see screen capture of attached pdf file). How can I make the photos reside in the Impress file itself, so that i can view the slides from any other PC?
Attachments
openoffice impress picture error.pdf
(103.24 KiB) Downloaded 552 times
Last edited by Hagar Delest on Sat Oct 16, 2010 10:51 am, edited 2 times in total.
Reason: tagged [Issue] (link to a bug report).
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: pictures dragged onto impress presentation file

Postby Hagar Delest » Sun Feb 01, 2009 5:15 pm

Does it help: [Solved + Issue] Drag & drop images linked: how to embed?

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.

NB: please upload your screenshot as .png instead of embedding it in a PDF (or any other) file format so that it can be directly viewed in the forum.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Pictures dragged onto impress presentation file

Postby johnlim » Mon Feb 02, 2009 2:48 am

png format exceeds file size limit of 128Kb,so attching as jpg file
Attachments
openoffice impress picture error.jpg
OOo 2.4.X on Ms Windows XP
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: Pictures dragged onto impress presentation file

Postby Hagar Delest » Mon Feb 02, 2009 9:07 am

Are the pics still on the machine at the location specified when you've embedded them? Have you checked the thread linked above?
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Pictures dragged onto impress presentation file

Postby johnlim » Mon Feb 02, 2009 2:26 pm

Thanks for responding. I am not sure if i understood your clarifications. The pictures are in a folder in the pc that i created the Impress presentation. When i send the presentation to another machine, I get those links shown in the screen capture.

What i like to achieve is to have the picture embedded into the Impress file, so that they can be opened on any pc and remain visible. I remember in the past, i simply drag the picture from Windows Explorer onto the Impress slide and the picture is copied onto the Impress file. This time it is not the case. Did i do anything that accidentally triggered off some setting resulting in a drag-n-drop action creating a link instead of pasting the picture directly into the Impress slide?
OOo 2.4.X on Ms Windows XP
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: Pictures dragged onto impress presentation file

Postby Hagar Delest » Mon Feb 02, 2009 2:30 pm

Please read the thread I've linked above.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Pictures dragged onto impress presentation file

Postby johnlim » Mon Feb 02, 2009 2:52 pm

I'm sorry Hagar, but I cannot find the link to the thread you mentioned.
OOo 2.4.X on Ms Windows XP
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: pictures dragged onto impress presentation file

Postby Hagar Delest » Mon Feb 02, 2009 3:03 pm

AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Pictures dragged onto impress presentation file

Postby johnlim » Mon Feb 02, 2009 4:37 pm

Hagar, thank you for your prompt responses.
I followed the link you sent, and that prompted me to run the minimizer tool on the problem file, sent it to another PC which does not have the photos resident, and am now able to see all the pictures. So it seems the size of the pictures trigger off this problem. Each of my picture was at least 2.5mb, and had about 15 photos.

By the way, another problem i did not report was that the size and quantity of the photos seem to also cause Impress to crash occasionally triggering the report problem wizard to show up. For example when i get into slide sorter mode, Impress crash on a few occasions. I now suspect it is related to the first problem.
OOo 2.4.X on Ms Windows XP
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: [solved] Pictures dragged onto impress file appears as links

Postby Hagar Delest » Mon Feb 02, 2009 4:48 pm

In fact, the point was to embed the pics with Edit>Links>Break link.

For the size of the pics, personally, I use a picture manager to optimize them (crop, resize and best format - png/jpg). Note that if you drag and drop a pic to your presentation, OOo will save it as a .png (even if it's a jpeg), see the bug report in the other thread. Therefore, you increase hugely the file size (once the pics are embedded) whereas if you insert the pic with the Insert>File menu, it keeps the original format. Another reason why I never use anything else than the Insert>File menu.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Pictures dragged onto impress file appears as links

Postby johnlim » Mon Feb 02, 2009 5:18 pm

I did not understand this: Edit>Links>Break link.

Regarding the bug that convert Jpg to PNG format, is there some place where i can see the bug on the bug fix schedule? I actually recommend openoffice to the all the parents in my son's school parent forum. i can't imagine the primary school kids wanting to go beyond drag-and-drop. In fact, I found the picture cropping function within the slide editing in 3.0 extremely helpful, instead of having to go to another photo editor.
OOo 2.4.X on Ms Windows XP
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: [Solved] Pictures dragged onto impress file appears as links

Postby Hagar Delest » Mon Feb 02, 2009 5:43 pm

When you drag and drop a pic to your presentation, it doesn't embed the pic in the presentation, it creates a link to the pic. When you load the presentation, OOo looks for the pic and display it. So if you open the presentation on a machine that has not the pic, OOo cannot display it.

To embed the pic, you have to break the link. Then OOo will embed the pic in the file (as a .png).

There is a special button at bottom of the Impress window to insert a pic. They just have to click that button and select the file (that can be displayed as thumbnail in the dialog BTW). Honestly, I find that way easier than resizing my browser window to drag and drop the pic in the file.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Pictures dragged onto impress file appears as links

Postby johnlim » Tue Feb 03, 2009 2:26 am

Thanks. I tried it out.
OOo 2.4.X on Ms Windows XP
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: [Solved] Pictures dragged onto impress file appears as links

Postby acknak » Tue Feb 03, 2009 3:44 am

Copy/Paste from Firefox into Impress seems to avoid linking, but it still converts the image to PNG, with the accompanying size inflation.

Dragging an image from Firefox into Impress does not work at all for me: all I get is the html <img ... > tag as text.

If I use the "Insert Picture from File" feature, and paste the URL for the image, copied from the browser, then Impress loads the image from the Internet, and embeds it in the correct format.

Obviously, that's not a good workaround for kids to use ;-)

Here's a really surprising and interesting thing: if I copy/paste a jpeg image into Impress, it gets embedded in the file as a png image. If I then insert the same picture by the paste URL method, it not only embeds it as a jpeg, but Impress throws out the png version of the image and uses the jpeg version for both.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [Solved] Pictures dragged onto impress file appears as links

Postby johnlim » Tue Feb 03, 2009 4:20 am

As someone who is quite competent with the pc, all these findings that Hagar and Acknak pointed out wouldn't come naturally to me without spending a fair bit of time tinkering around. Most of us would not have time to do this. Coupled wth the fact that Powerpoint is the dominant tool, these does not help faster adoption. Initially I introduced my kid to Impress for his school assignment and he was actually resistant to Impress as his teacher uses Powerpoint - afraid that he is not in compliance. That is the obstacle Impress/OOo faces in broadening adoption. If there are fun and easy to use functions in Impress it would help kids adopt it and pass it around in schools. My kid discovered the in-slide cropping function and found it very handy.

Perhaps these observations are not appropriate here though.
OOo 2.4.X on Ms Windows XP
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: [Solved] Pictures dragged onto impress file appears as links

Postby Hagar Delest » Tue Feb 03, 2009 9:14 am

When your kid will be able to buy a car, I'm not sure he will chose the same as his father's/teacher's/...! However, the buttons won't be at the same place, engine may be different, color also and so on.

Got the picture?
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Pictures dragged onto impress file appears as links

Postby shanc » Sun Jun 28, 2009 2:54 pm

I can't believe this issue still exists, it has been posted in different places for years.

It is NOT intuitive to have to break links for photos that a copied and/or inserted from a file.
I have had the same issue whether the copied photo was 100kb or 400kb, they all appear as links in the slide and subsequently as errors whenever an impress .ppt file is emailed.

It is silly to have to come to this forum to search for a solution to a problem that has been reported many times and doesn't even make sense in the first place.
for example, this thread:
viewtopic.php?f=10&t=2392
OOo 2.3.X on MS Windows Vista
shanc
 
Posts: 2
Joined: Sun Jun 28, 2009 2:15 pm

Re: [Solved] Pictures dragged onto impress file appears as links

Postby TheGurkha » Sun Jun 28, 2009 3:31 pm

If you use the Insert > Picture > From file method and make sure you do not have the 'as link' checkbox selected they are embedded with the document.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: [Solved] Pictures dragged onto impress file appears as links

Postby johnlim » Mon Jun 29, 2009 2:30 am

Thanks Gurkha. I tried using Gurkha's last post and it worked. But I am quite sure when I reported the problem the last time, I did not checked the 'link' box, knowing that I want to pass the file to another machine later, and this box is not checked by Impress by default.
OOo 2.4.X on Ms Windows XP
johnlim
 
Posts: 14
Joined: Mon Aug 11, 2008 6:36 am
Location: Singapore, China

Re: [Solved] Pictures dragged onto impress file appears as links

Postby Work4crown » Thu Dec 24, 2009 10:35 pm

I've got to agree that it is much more intuitive for drag and drop to embed the image file in it's native format instead of as a png. I would love to see that changed.
Work4crown
 
Posts: 5
Joined: Sun Dec 13, 2009 5:17 am

Re: [Solved] Pictures dragged onto impress file appears as links

Postby Hagar Delest » Fri Dec 25, 2009 12:53 pm

Then vote for the issue 15508.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Pictures dragged onto impress file appears as l

Postby kozmoz » Sat Oct 16, 2010 1:19 am

I know this is an old thread, but I was experiencing the same issue as described above.

I think this a serious usability issue. Drag and dropping an image, the user expects the image to be in the document. It is just weird to discover afterward that the images are not there when the presentation is opened at another computer. It just doesn't make sense.

I have searched the bug database, but cannot find any related issues. I do not want to add a duplicate bug report, does anyone know if such an issue is reported before? I would like to vote for it.
OpenOffice 3.2.1 on Mac OS X 10.6.4
kozmoz
 
Posts: 2
Joined: Sat Oct 16, 2010 1:03 am

Re: [Solved] Pictures dragged onto impress file appears as l

Postby Hagar Delest » Sat Oct 16, 2010 10:51 am

AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28593
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved+Issue] Pictures dragged appears as links

Postby kozmoz » Sat Oct 16, 2010 3:21 pm

BTW, apparently both of the issues mentioned above (About drag-n-drop and embedding as PNG) are fixed in LibreOffice 3.3.0 Beta 2.
OpenOffice 3.2.1 on Mac OS X 10.6.4
kozmoz
 
Posts: 2
Joined: Sat Oct 16, 2010 1:03 am


Return to Impress

Who is online

Users browsing this forum: No registered users and 3 guests