[Solved] Spell Checker Not Working

Writing a book, Automating Document Production - Discuss your special needs here

[Solved] Spell Checker Not Working

Postby leolavertu » Fri Feb 26, 2016 5:41 pm

Hello:

My spell checker does not work properly. When I type any word it underlines it in red as if it is misspelled. If I check an existing document then the whole document is underlined in red. I have gone through all the settings and as far as I can tell all the language settings are in US English. I do have several dictionaries installed. Now this part will probably astonish you. I even went so far as to completely remove Open Office from my hard drive then reinstalled it. I still have the same problem. Thanks for any help and suggestions. :D
Last edited by RoryOF on Fri Feb 26, 2016 8:17 pm, edited 1 time in total.
Reason: Added [Solved] and green tick [RoryOF, Moderator]
Open Office 4.1.2 - Windows 7 Home Premium
leolavertu
 
Posts: 3
Joined: Fri Feb 26, 2016 5:28 pm

Re: Spell Checker Not Working

Postby RoryOF » Fri Feb 26, 2016 5:51 pm

Delete or rename your OpenOffice user profile. As you are using Windows do this by:

Close OpenOffice and the Quickstarter. Open File Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer Address Bar and press Enter. Delete or Rename the "user" folder. Start OpenOffice.

This cures most spellcheck problems.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29053
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell Checker Not Working

Postby leolavertu » Fri Feb 26, 2016 8:14 pm

WOW! That worked great, Thanks :)
Open Office 4.1.2 - Windows 7 Home Premium
leolavertu
 
Posts: 3
Joined: Fri Feb 26, 2016 5:28 pm

Re: [Solved] Spell Checker Not Working

Postby estellem123 » Wed Jan 11, 2017 2:44 pm

hello
please help. i have used OO on windows for many years with no problem. however in the last month the spell checker is not working properly. it is underlining every work as if it is mis spelt. i have recently down loaded the 4.1.3 version i dont know if that is the probelm. i have tried downloading extention dictionaries and changing user names and been unsucessful on both fronts. please help i have a 12000 masters dissertation to write and will go crazy if this tells me every word is spelt wrong.
many thanks in advance
Estelle
open office 4.1.3 windows
estellem123
 
Posts: 1
Joined: Wed Jan 11, 2017 2:15 pm

Re: [Solved] Spell Checker Not Working

Postby leolavertu » Wed Jan 11, 2017 6:43 pm

Delete or rename your OpenOffice user profile. As you are using Windows do this by:

Close OpenOffice and the Quickstarter. Open File Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer Address Bar and press Enter. Delete or Rename the "user" folder. Start OpenOffice.

This cures most spellcheck problems.
Open Office 4.1.2 - Windows 7 Home Premium
leolavertu
 
Posts: 3
Joined: Fri Feb 26, 2016 5:28 pm

Re: [Solved] Spell Checker Not Working

Postby RoryOF » Wed Jan 11, 2017 7:09 pm

And in addition, Save your file regularly under another (suggest timestamped file).
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29053
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Checker Not Working

Postby ndmyers » Sun Aug 27, 2017 5:34 pm

Hi Folks,

I have used OpenOffice for years. I've written five books and thousands of pages of text with the program, and my version also developed the underlining problem: Every document, every word underlined as if misspelled. A WP program is pretty much useless with a malfunction like this.

I too uninstalled and re-installed the program. No change.

But the above fix worked!! :D I simply deleted the user file that appeared, following the instructions above. What a relief!

Can anybody tell me why this worked, and why this bug appeared spontaneously after years of trouble free operation after years of using the program through many computers and OpenOffice versions?

I'm not especially techie, so simple explanations, if possible, are appreciated.

Thanks in advance
OpenOffice 4.1.3 on Windows 7 Professional
ndmyers
 
Posts: 4
Joined: Sun Aug 27, 2017 5:20 pm

Re: [Solved] Spell Checker Not Working

Postby RoryOF » Sun Aug 27, 2017 7:39 pm

It is likely that this problem occurs because you are over-hasty in your close down of the computer after closing OO. Its internal housekeeping takes a few seconds and the housekeeping files may still be cached in either the software or hardware buffers. One should always use the formal computer close down procedure and wait a few seconds (10 should be enough) after the OK to power off message before switching the power off or snapping a laptop lid shut.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29053
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Checker Not Working

Postby ndmyers » Sun Aug 27, 2017 9:05 pm

I'm not sure how I can do that. I always close Open Office, then shut down. Do you have any evidence for your hypothesis? Also, why would this problem occur after so many years of using the program? Also, even if true, how exactly can the cacheing of files cause a malfunction in the spell checker? I'm still confused!
OpenOffice 4.1.3 on Windows 7 Professional
ndmyers
 
Posts: 4
Joined: Sun Aug 27, 2017 5:20 pm

Re: [Solved] Spell Checker Not Working

Postby RoryOF » Sun Aug 27, 2017 9:16 pm

It can only take a moment's inattention to power off over speedily. Modern hard drives buffer the information internally and can sort it so that they write the buffered chunks of data in order as the heads scan across the platters. When it is closing down, OpenOffice rewrites detailed configuration information into a file called registrymodifications.xcu; this is the last file it writes and if damaged one may lose the spellcheck information.

I'm not saying this problem will never happen again - there may be other reasons, but a leisurely power off seems to solve the problem for most people. Of course, you don't have to do this - it's up to you.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29053
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Checker Not Working

Postby ndmyers » Sun Aug 27, 2017 10:10 pm

OK. But I'm still unsure how I can slow it down. I close programs, then I choose the shut down command, the computer does the rest!
OpenOffice 4.1.3 on Windows 7 Professional
ndmyers
 
Posts: 4
Joined: Sun Aug 27, 2017 5:20 pm

Re: [Solved] Spell Checker Not Working

Postby RusselB » Sun Aug 27, 2017 11:37 pm

The simplest method, is to wait for 10-15 seconds after you close the program, before using the shut down command.
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 5176
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: [Solved] Spell Checker Not Working

Postby ndmyers » Mon Aug 28, 2017 3:48 pm

OK I'l make sure I follow that procedure from now onward. Thanks for your help!
OpenOffice 4.1.3 on Windows 7 Professional
ndmyers
 
Posts: 4
Joined: Sun Aug 27, 2017 5:20 pm

Re: [Solved] Spell Checker Not Working

Postby Rorympb » Mon Oct 09, 2017 8:44 pm

Wow that worked for me as well! I was having the same issues with spell checker but only on 1 laptop.
My other laptop it was fine. I thought it was due to a recent upgrade. Thank you for your help! :bravo:
Open Office 4.1.3 on Windows 10
Rorympb
 
Posts: 1
Joined: Mon Oct 09, 2017 8:41 pm

Re: [Solved] Spell Checker Not Working

Postby BigAppleLuver » Sat Nov 18, 2017 7:02 pm

Another happy camper. Deleted the user file and all is well! :bravo:
OpenOffice 4.1.2 on Windows 10
BigAppleLuver
 
Posts: 1
Joined: Sat Nov 18, 2017 7:00 pm


Return to Advanced Uses

Who is online

Users browsing this forum: No registered users and 0 guests