[Solved] Saving as unknown file?

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] Saving as unknown file?

Postby francophile » Mon Dec 10, 2007 7:17 pm

After many months of problem free use I now have a problem in that whatever format I select for saving OO saves the documents as unknown files which will not then open automatically in OO. :?:

Thanks now solved, so easy really
Last edited by Hagar Delest on Tue Aug 05, 2008 5:02 pm, edited 2 times in total.
Reason: tagged the thread as Solved.
francophile
 
Posts: 4
Joined: Mon Dec 10, 2007 7:14 pm

Re: Saving

Postby floris v » Mon Dec 10, 2007 7:24 pm

Have you checked the Automatic file name extension check box?
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4168
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Saving

Postby TerryE » Mon Dec 10, 2007 8:54 pm

go into Calc or Writer and select from the file menu, "recent documents". Can you open the ones who that you still have? What extensions are you using: ODT PDS or DOC and XLS. You can set up your options to load and save in MSOffice compatible format, but there is also an install option which asks you whether you want to associate these extensions with OOo. You may have said No to this Q.

Usually you should stick to the OOo native types (ODS etc) unless you want to interchange files with an MSOffice user. Anyway you should associate the extension that you want to use with OOo with it. You can do this manually in XP by right clicking on the file and doing an "open with" then browsing to pick the relevant exe from (typically) "C:\Program Files\OpenOffice.org 2.3\program\" and checkingthe "always open this file type with this application" option.
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
Volunteer
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: Saving

Postby Hagar Delest » Tue Dec 11, 2007 12:18 am

floris v wrote:Have you checked the Automatic file name extension check box?

It should fix the issue.

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.

NB: moved your thread to the Setup & Troubleshouting forum.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28590
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Saving

Postby francophile » Tue Dec 11, 2007 11:12 am

Existing docs open fine. No matter what format I select result is the same. I don't think I've altered any settings. Shall I reinstall d'ya think?
francophile
 
Posts: 4
Joined: Mon Dec 10, 2007 7:14 pm

Re: Saving

Postby francophile » Tue Dec 11, 2007 12:16 pm

floris v wrote:Have you checked the Automatic file name extension check box?
I can't find it. :oops:
francophile
 
Posts: 4
Joined: Mon Dec 10, 2007 7:14 pm

Re: Saving

Postby TerryE » Tue Dec 11, 2007 12:30 pm

Open an existing file that you can't open by clicking on it. Click File -> Properties and copy the full name then paste it into a reply here, so I can see the name and extension.

Also tell me whether you managed to do the "open with" dialogue as I described.
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
Volunteer
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: Saving

Postby francophile » Tue Dec 11, 2007 3:35 pm

xmas message

That's it no file extension shown. Documents created previously have an odt extension like this( round robin.odt.) I can open all documents but the ones I create now do not show as the usual OOo logo and have no file extension so they will not open auomatically as previously. Not a terrible problem for me but I want to email some stuff to Word users and I can't tell if the document is readable to them or not.

Thanks for you help.
francophile
 
Posts: 4
Joined: Mon Dec 10, 2007 7:14 pm

Re: Saving

Postby RonIA » Tue Dec 11, 2007 4:05 pm

So, did you find the "Automatic File Extension" box? It is on the File - Save As Dialog box (under where you put in the file name and file type, etc.)

For those files without a file extension you have previously saved, you should be able to go into your file manager (MS Windows Explorer for MS Windows) and right click on the file and select Rename, then you can add the appropriate extension (ODT). However, please note, in your last post you said you want people who have MS Word to be able to open the files.

Microsoft in its arrogance will not read / write ODT files, so make sure you save the file in a format MS Word can read/write (.doc or .rtf are two that should work).

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.
Ron from Iowa, USA
RonIA
Volunteer
 
Posts: 139
Joined: Mon Oct 08, 2007 1:34 am
Location: Iowa USA

Re: Saving

Postby Hagar Delest » Tue Dec 11, 2007 10:42 pm

Here it is when you open a Save As dialog :
Automatic file name.png
Automatic file name.png (10.63 KiB) Viewed 7206 times
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28590
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests