[Solved] How to disable edit mode

Discuss the database features

[Solved] How to disable edit mode

Postby jenny143 » Thu Oct 20, 2011 5:35 am

how to disabled edit?

since i use standalone forms
viewtopic.php?f=83&t=40493

all i want is that no editing for design forms??
like forms in base
Last edited by jenny143 on Tue Oct 25, 2011 3:32 am, edited 2 times in total.
Windows XP and Open Office 3.3
User avatar
jenny143
 
Posts: 82
Joined: Wed Oct 19, 2011 1:40 am

Re: How to disable edit mode

Postby probe1 » Fri Oct 21, 2011 2:34 pm

With OOo 3.2.1 I have an option "Always open in read-only mode" (Tools>Options...>OpenOffice.org>Security tab), which does the trick
Cheers
Winfried

DateTime2 extension: insert date, time or timestamp, formatted to your needs
User avatar
probe1
Volunteer
 
Posts: 277
Joined: Mon Oct 08, 2007 1:34 am
Location: Chonburi Thailand

Re: How to disable edit mode

Postby Villeroy » Fri Oct 21, 2011 3:47 pm

probe1 wrote:With OOo 3.2.1 I have an option "Always open in read-only mode" (Tools>Options...>OpenOffice.org>Security tab), which does the trick

This option is hidden in the save-as dialog. When I check "save with password". Then I'm prompted for a password to open the file and/or another password to make the document read-only.

Revoking the edit permission on file system level it is easier while having the same effect, under Linux at least where file system permissions are a matter of course.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27382
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: How to disable edit mode

Postby jenny143 » Sat Oct 22, 2011 2:34 am

so that's for the setting of the server?

where is it

permission then??

it is possible to do that for Microsoft server (Temporarily?) ??
Windows XP and Open Office 3.3
User avatar
jenny143
 
Posts: 82
Joined: Wed Oct 19, 2011 1:40 am

Re: How to disable edit mode

Postby mary jhane » Sat Oct 22, 2011 7:01 am

i have no "save with password" in my open office 3.3 where is that option
Attachments
wewwow.JPG
OpenOffice 3.3 on Windows XP
User avatar
mary jhane
 
Posts: 73
Joined: Sat Oct 22, 2011 6:27 am

Re: How to disable edit mode

Postby RoryOF » Sat Oct 22, 2011 7:03 am

mary jhane wrote:i have no "save with password" in my open office 3.3 where is that option


/ File / Save As has a password checkbox.

 Edit: My advice is that, unless essential, you should stay away from passwords in OpenOffice. They are effectively unbreakable, so if you forget or muff your password the file is lost. 
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29899
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to disable edit mode

Postby mary jhane » Sat Oct 22, 2011 7:56 am

No save password in file-save as
only check box automatic file name extension
zz i cant find it, :oops:

there is other recovery password if i forgot it sir??
Attachments
NoSavewithpassword.JPG
OpenOffice 3.3 on Windows XP
User avatar
mary jhane
 
Posts: 73
Joined: Sat Oct 22, 2011 6:27 am

Re: How to disable edit mode

Postby RoryOF » Sat Oct 22, 2011 8:05 am

You may need to set
/ Tools / Options / OpenOffice.org / General : Use OpenOffice.org Dialogue boxes. Then restart OpenOffice including Quickstarter (easiest way is to restart your computer completely).

In OpenOffice, if you forget your password there is effectively no recovery. This is the purpose of a password, to prevent unauthorised access to a file.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29899
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to disable edit mode

Postby floris v » Sat Oct 22, 2011 8:57 am

I just checked but you can't password protect a database file, not with the standard dialog boxes and not with OOo's dialog boxes.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4177
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: How to disable edit mode

Postby Villeroy » Sat Oct 22, 2011 9:12 am

floris v wrote:I just checked but you can't password protect a database file, not with the standard dialog boxes and not with OOo's dialog boxes.

It's about a stand alone form document
jenny143 wrote:since i use standalone forms
viewtopic.php?f=83&t=40493
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27382
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: How to disable edit mode

Postby floris v » Sat Oct 22, 2011 9:14 am

:oops: My bad.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4177
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: How to disable edit mode

Postby jenny143 » Sat Oct 22, 2011 11:43 am

there's no other way to set document to read only mode??
Windows XP and Open Office 3.3
User avatar
jenny143
 
Posts: 82
Joined: Wed Oct 19, 2011 1:40 am

Re: How to disable edit mode

Postby DACM » Sat Oct 22, 2011 8:40 pm

I may be missing something here...but I thought we covered this in the referenced tutorial. These steps are accomplished upon saving the Form within Writer only. The options don't exist during the export process from Base, nor among the global settings.
[Tutorial] Standalone Forms / Switchboard wrote:(O) And finally, File > Save As... > Save with password (checkbox) > Save (button, opens the Set Password dialog box, but skip to...) > More Options... (button) > Open file read-only (checkbox).
    Note: Do not specify a password to open, but after clicking More Options... you'll see the option to Enter password to allow editing which can be useful (if you as the developer don't forget the password!).
    Note: To regain the ability to edit the Writer-Form document after saving "read-only" simply Save As... another copy without selecting the "read-only" attribute.

I understand the confusion because the tutorial presumes the creation of an associated switchboard Form, which presumes the Forms will be opened with a Push Button, which offers to open the 'URL' read-only. Thus, step (8) does not password-protect the individual Forms because it doesn't seem necessary when opened "read-only" by the switchboard buttons. So the only step (O) that suggests password-protection applies to the switchboard Form alone. However, that step can be applied to the individual Forms, as needed.
[Tutorial] Standalone Forms / Switchboard wrote:(8 ) When you're satisfied with each standalone Writer Form, click File > Save
    Note: there's no need to save each Form "read-only" when using a Push Button to open the Form due to the associated "read-only" option of the URL. However, this option still allows the user to enter 'Design Mode' using the appropriate toolbar, so it may be best to save a more permanent "read-only" version. File > Save As... > Save with password (checkbox) > More Options... (button) > Open file read-only (checkbox). Do not specify a password. To regain the ability to edit the Writer-Form document after saving "read-only" simply Save As... another copy without the "read-only" attribute.

And while it's not clear in the context (even as I read it at now), I think we can presume that a password-protected, read-only attribute effectively foils the ability to 'save as' another copy for editing. So don't forget the password if you want to edit the Form!
AOO 4.1.x; LO 4.2.x; Windows 7/8 64-bit
Warning: Avoid embedded databases --> Solution: Adopt a portable 'split database' folder
Soli Deo gloria
User avatar
DACM
Volunteer
 
Posts: 1138
Joined: Tue Nov 03, 2009 7:24 am

Re: How to disable edit mode

Postby mary jhane » Mon Oct 24, 2011 6:22 am

where is More Options...???
OpenOffice 3.3 on Windows XP
User avatar
mary jhane
 
Posts: 73
Joined: Sat Oct 22, 2011 6:27 am

Re: How to disable edit mode

Postby DACM » Mon Oct 24, 2011 8:14 pm

Do you have the Form open in Writer?

DACM wrote:These steps are accomplished upon saving the Form within Writer only. The options don't exist during the export process from Base, nor among the global settings.
[Tutorial] Standalone Forms / Switchboard wrote:(O) And finally, File
> Save As...
> Save with password
(checkbox)
> Save
(button, opens the Set Password dialog box, but skip to...)
> More Options... (button)
> Open file read-only (checkbox).
    Note: Do not specify a password to open, but after clicking More Options... you'll see the option to Enter password to allow editing which can be useful (if you as the developer don't forget the password!).
    Note: To regain the ability to edit the Writer-Form document after saving "read-only" simply Save As... another copy without selecting the "read-only" attribute.

SaveAs_with_password.jpg
File > Save As... > Save with password (checkbox) > Save (button)

SaveAs_with_password_More_Options.jpg
(opens the Set Password dialog box , but skip to...) > More Options... (button)
SaveAs_with_password_More_Options.jpg (22.76 KiB) Viewed 15946 times

SaveAs_with_password_Fewer_Options.jpg
> Open file read-only (checkbox)
AOO 4.1.x; LO 4.2.x; Windows 7/8 64-bit
Warning: Avoid embedded databases --> Solution: Adopt a portable 'split database' folder
Soli Deo gloria
User avatar
DACM
Volunteer
 
Posts: 1138
Joined: Tue Nov 03, 2009 7:24 am

Re: How to disable edit mode

Postby Villeroy » Mon Oct 24, 2011 9:40 pm

Or right-click the file in the Win Explorer, choose "Properties" and check the read-only flag.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27382
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: How to disable edit mode

Postby mary jhane » Tue Oct 25, 2011 3:15 am

nice... :D
Thank you
More Powers
OpenOffice 3.3 on Windows XP
User avatar
mary jhane
 
Posts: 73
Joined: Sat Oct 22, 2011 6:27 am

Re: How to disable edit mode

Postby jenny143 » Tue Oct 25, 2011 3:24 am

Thanks DACM and VILLEROY
Windows XP and Open Office 3.3
User avatar
jenny143
 
Posts: 82
Joined: Wed Oct 19, 2011 1:40 am

Re: How to disable edit mode

Postby jenny143 » Tue Oct 25, 2011 3:27 am

Thanks DACM and VILLEROY
Windows XP and Open Office 3.3
User avatar
jenny143
 
Posts: 82
Joined: Wed Oct 19, 2011 1:40 am


Return to Base

Who is online

Users browsing this forum: No registered users and 4 guests