Page 1 of 1

[Solved] Gap for SI numbers (thousands separator)

PostPosted: Tue Jan 21, 2020 4:28 am
by Dr. Barber
Hi all.
When writing numbers in the SI system the digits of numerical values having more than four digits on either side of the decimal marker are separated into groups of three using a thin, fixed space counting from both the left and right of the decimal marker. Commas are not used to separate digits into groups of three. For example:15 739.012 53

I find that the gap provided by grave (') is too wide for this. Is there a way to make the gap smaller than that provided by grave?

Thanks

Re: gap for SI numbers

PostPosted: Tue Jan 21, 2020 4:53 am
by FJCC
You can go to the menu Format -> Spacing, set the Category to Spacing and shrink the spacing setting. I think that decreases all spacing but it might get you what you want.

Re: gap for SI numbers

PostPosted: Tue Jan 21, 2020 8:57 am
by Zizi64
Please upload your sample Math file here.

Re: Gap for SI numbers (thousands separator)

PostPosted: Tue Jan 21, 2020 10:26 am
by keme
Have you tried to use just a plain space character?

Enclose the number in curly braces to make it count as one element. The space counts as a token separator.
Code: Select all   Expand viewCollapse view
{123 456 789}
gives tighter spacing on my system than the "small space"
Code: Select all   Expand viewCollapse view
123`456`789

Re: Gap for SI numbers (thousands separator)

PostPosted: Tue Jan 21, 2020 7:45 pm
by Dr. Barber
keme wrote:Have you tried to use just a plain space character?

Enclose the number in curly braces to make it count as one element. The space counts as a token separator.
Code: Select all   Expand viewCollapse view
{123 456 789}
gives tighter spacing on my system than the "small space"
Code: Select all   Expand viewCollapse view
123`456`789



Thanks!
I had not tried that. This works well!