Zawijanie formatów

Użytkowanie arkusza kalkulacyjnego

Zawijanie formatów

Postprzez zombiehug » N wrz 08, 2019 11:54 am

Witam.

Chciałbym móc zawijać format daty.
Np. NNNND.MM "godz." HH:MM
Wyświetli mi: sobota 08.09 godz. 12:00

Problem pojawia się, gdy chcę, aby komórka była wąska, ale wysoka:
sobota
08.09
godz. 12:00

Czy mogę dopisać coś do kodu formatowania?

Dziękuję?
OpenOffice 4.1.6 na Windows 10
zombiehug
 
Posty: 2
Dołączył(a): N wrz 08, 2019 11:50 am

Re: Zawijanie formatów

Postprzez Jermor » N wrz 08, 2019 1:33 pm

Dodaj do zasad formatowania zawijanie tekstu. Okienko formatowania -> Wyrównanie -> Właściwości -> Zawijaj tekst.
Tyle, że zaczniesz się wozić z datami. Najkrótsza nazwa dnia tygodnia to "środa" najdłuższa to "poniedziałek". Gdy dopasujesz się z szerokością kolumny do poniedziałku, to w środę w tym wierszu pojawią się cyfry dnia i miesiąca, bo w wolnej przestrzeni zmieści się i nazwa dnia tygodnia i cyfry. W samym kodzie formatowania nie możesz dodać kodu "przejdź do nowej linii".
Potrzebny efekt możesz jednak uzyskać przy pomocy formuły. Gdy data i godzina znajdują się np w A1 to w A2 można utworzyć następującą formułę:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=TEKST(A1;"NNNN")&ZNAK(10)&TEKST(A1;"DD.MM")&ZNAK(10)&"godz. "&TEKST(A1;"hh:mm")
AOO 4.1.6, LO 6.2.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że ktoś podał rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 768
Dołączył(a): So paź 12, 2013 11:09 am

Re: Zawijanie formatów

Postprzez zombiehug » N wrz 08, 2019 5:21 pm

Jest to jakieś rozwiązanie, jednak będę potrzebował użyć tego kilkaset razy :)

Mogę ukryć daty z godzinami, które się nie mieszczą i użyfćww. formuł do komórek, które będą już zawijane.

Poczekam jeszcze chwilkę zanim oznaczę temat jako [solved].
Może ktoś coś jeszcze wymyśli? :)
OpenOffice 4.1.6 na Windows 10
zombiehug
 
Posty: 2
Dołączył(a): N wrz 08, 2019 11:50 am


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości