Podzial na kolumny ostatnie slowo.

Użytkowanie arkusza kalkulacyjnego

Podzial na kolumny ostatnie slowo.

Postprzez Dawidek990 » Cz sty 10, 2019 6:31 pm

Witam, mam pytanie, czy da sie zrobic cos takiego ze przy podziale na kolumny podzieli mi tylko i wylacznie ostatnie slowo? liczac od ostatniej spacji poprostu?
ew jakas formula na to?
np: APENINO ANTRACYT LAPPATO 29,7X59,7
odziela tylko 29,7X59,7

pozdrawiam ;]
OpenOffice 4.1.6 Windows 10
Dawidek990
 
Posty: 30
Dołączył(a): Cz gru 13, 2018 12:15 am

Re: Podzial na kolumny ostatnie slowo.

Postprzez Jan_J » Cz sty 10, 2019 8:50 pm

W poście viewtopic.php?f=9&t=4738&p=19543#p19543 opisany jest sposób dołączenia funkcji, która rozbija tekstową zawartość komórki wg wskazanego znaku albo frazy.

Jak już tę funkcję StrSplit zainstalujemy, wystarczy po jej użyciu pobrać ostatni wyraz jej wyniku.
Ja bym to zrobił tak: jeżeli fraza, dajmy na to
APENINO ANTRACYT LAPPATO 29,7X59,7
jest wpisana w A1, to funkcja StrSplit(A1; " ") da nam tablicę/obszar ("APENINO", "ANTRACYT", "LAPPATO", "29,7X59,7")
który możemy zapytać o liczbę elementów funkcją ILE.NIEPUSTYCH i pobrać element o tym właśnie numerze -- tzn. jej element ostatni.
Wszystko razem
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=INDEKS(StrSplit(A1; " "); ILE.NIEPUSTYCH(StrSplit(A1; " ")))
Sprawdzałem, działa. Ale najpierw zbuduj funkcję StrSplit według opisu.

Jeżeli już użyłeś podziału komórki na kolumny, to możesz zastosować pomysł z indeks i ile.niepustych wiersz po wierszu na obszarze wynikowym. Coś w stylu
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=INDEKS(B1:H1; ILE.NIEPUSTYCH(B1:H1))
przy czym obszar musi być co najmniej tak szeroki, by zmieścić wszystkie słowa po podziale komórki.
JJ
LO (6.1|6.2) ∙ AOO 4.1.6 ∙ Python (3.7|2.7) ∙ Unicode 11 ∙ LATEX 2ε ∙ XML ∙ Unix tools ∙ Linux (Fedora|CentOS|SUSE)
Jan_J
 
Posty: 3845
Dołączył(a): Pt maja 22, 2009 1:20 pm
Lokalizacja: Wrocław


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 7 gości