sumowanie wystąpienia daty

Użytkowanie arkusza kalkulacyjnego

sumowanie wystąpienia daty

Postprzez dropzonet » Śr cze 06, 2018 12:52 am

Witam, proszę o pomoc :)
Co zrobić by zliczało daty (ile razy wystąpiła) wg kryterium jak w podglądzie
np 26.05.2018 godz. 7-19 ---- powinno wyliczyć 3
np 26.05.2018 godz 19-7 (czyli 26.05 od 19:00 do godziny 24:00 + 27.05 do godziny 7:00)
Help :)
Załączniki
ile dat.ods
(9.71 KiB) Pobrane 8 razy
Bez tytułu.png
Libre Office 6.0.0.3 x64 windows 10
dropzonet
 
Posty: 2
Dołączył(a): Śr cze 06, 2018 12:05 am

Re: sumowanie wystąpienia daty

Postprzez Jan_J » Śr cze 06, 2018 11:53 am

Przeorganizowałbym zapis kolumny Przedział godzinowy, bo w obecnej chwili jest tekstem, z którego trudno wyciągnąć cokolwiek.
Proponuję
Data Od_godziny Do_godziny Liczba
tak by godziny były liczbami sformatowanymi jako czas tj. [HH]:MM

Wtedy do zliczenia da się użyć składni tablicowej, czegoś w rodzaju
=suma((Dane>=data+do_godziny)*(Dane<=data+do_godziny))
zastępując Dane adresem obszaru, a pozostałe adresem komórek; np. dla odp. w D2, dla pierwszej daty/godziny
=suma((E$2:E$1000>=A2+B2)*(E$2:E$1000<=A2+C2))
Formuła tablicowa, więc zatwierdzana przez <Ctrl+Shift+Enter>

Uwaga formalna: "nocka" od 19 do 7 kończy się innego dnia niż się zaczęła; ale skoro używamy poprawnie + do sumowania czasu, nie ma to znaczenia. Operując na tekstach zamiast na liczbowych reprezentacjach dat, mielibyśmy z tym poważny kłopot.

Można też wprowadzić własne oznaczenia dla obszarów; będzie łatwiej zarządzać; np. nazwać E2:E1000 słowem Dane.
JJ
LO (6.0|6.1) ∙ AOO 4.1.5 ∙ Python (3.7|2.7) ∙ Unicode 11 ∙ LATEX 2ε ∙ XML ∙ Unix tools ∙ Linux (Fedora|CentOS|SUSE)
Jan_J
 
Posty: 3733
Dołączył(a): Pt maja 22, 2009 1:20 pm
Lokalizacja: Wrocław

Re: sumowanie wystąpienia daty

Postprzez dropzonet » Śr cze 13, 2018 11:08 am

Super działa !!!
dodałem warunek jeżeli w przypadku "nocki" i jest git
=JEŻELI(B16=19/24;SUMA((E$2:E$1000>=A16+B16)*(E$2:E$1000<=(A16+1)+C16));SUMA((E$2:E$1000>=A16+B16)*(E$2:E$1000<=A16+C16))) i <Ctrl+Shift+Enter>
Załączniki
ile dat.ods
(12 KiB) Pobrane 10 razy
111.png
Libre Office 6.0.0.3 x64 windows 10
dropzonet
 
Posty: 2
Dołączył(a): Śr cze 06, 2018 12:05 am

Re: sumowanie wystąpienia daty

Postprzez Jan_J » Śr cze 13, 2018 11:22 pm

dropzonet napisał(a):Super działa !!!
Łaski nie robi, tak ma być. Nech sa páči.
JJ
LO (6.0|6.1) ∙ AOO 4.1.5 ∙ Python (3.7|2.7) ∙ Unicode 11 ∙ LATEX 2ε ∙ XML ∙ Unix tools ∙ Linux (Fedora|CentOS|SUSE)
Jan_J
 
Posty: 3733
Dołączył(a): Pt maja 22, 2009 1:20 pm
Lokalizacja: Wrocław


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość