suma kwot do dnia dzisiejszego

Użytkowanie arkusza kalkulacyjnego

suma kwot do dnia dzisiejszego

Postprzez dentopolis » Cz maja 21, 2020 10:57 pm

w pierwszym wierszu mam daty (mm.yy), w drugim kwoty. jak wyświetlić kwotę zarobioną do dnia dzisiejszego?
=SUMA.JEŻELI(a1:Z1;<DZIŚ();B2:Z2)
to nie działa
LibreOffice 6.4
dentopolis
 
Posty: 159
Dołączył(a): Pn wrz 23, 2013 2:48 pm

Re: suma kwot do dnia dzisiejszego

Postprzez Rafkus » Cz maja 21, 2020 11:22 pm

Kod: Zaznacz cały   Rozszerz widokZwiń widok
=SUMA.JEŻELI(A1:Z1;  "<" & DZIŚ();  B2:Z2)

kryterium musi być tekstem
OpenOffice 4.1.6. oraz LibreOffice 6.4 Widows 10
Libre 4.2.5.2 Windows XP
Avatar użytkownika
Rafkus
 
Posty: 136
Dołączył(a): Cz kwi 12, 2018 10:26 pm

Re: suma kwot do dnia dzisiejszego

Postprzez Jermor » Pt maja 22, 2020 1:07 pm

I co to znaczy mam daty? Zapis w postaci np 05.20 (maj 2020) albo 12.98 (grudzień 1998)? Bo jeśli tak, to ta formuła i tak nie pomoże.
AOO 4.1.7, LO 6.3.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że ktoś podał rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 1155
Dołączył(a): So paź 12, 2013 11:09 am

Re: suma kwot do dnia dzisiejszego

Postprzez dentopolis » Pt maja 22, 2020 1:24 pm

przesyłam plik. 1 wiersz zawiera daty.faktycznie nie działa powyższa formuła mimo że próbowałem zamienić format daty na tekst.
Załączniki
Bez tytułu 1.ods
(17.73 KiB) Pobrane 10 razy
LibreOffice 6.4
dentopolis
 
Posty: 159
Dołączył(a): Pn wrz 23, 2013 2:48 pm

Re: suma kwot do dnia dzisiejszego

Postprzez Rafkus » Pt maja 22, 2020 1:38 pm

Pobrałem plik testowy - według mnie działa. Co prawda pierwszy wiesz wyświetla tylko rok i miesiąc, ale komórki przechowują całą poprawną datę czyli pierwszy dzień miesiąca . Sumuje wartości od 1 stycznia do dzisiejszego maja (więc 1 maj też). Czerwca jeszcze nie ma, więc go nie liczy.
OpenOffice 4.1.6. oraz LibreOffice 6.4 Widows 10
Libre 4.2.5.2 Windows XP
Avatar użytkownika
Rafkus
 
Posty: 136
Dołączył(a): Cz kwi 12, 2018 10:26 pm

Re: suma kwot do dnia dzisiejszego

Postprzez Jermor » Pt maja 22, 2020 2:05 pm

Sumowanie będzie zależało od daty wpisanej do pierwszego wiersza. Wiersz wyświetla zgodnie z formatem miesiąc i rok, ale tak naprawdę zawiera liczbę daty wynikającą z pełnej daty. Jeżeli w pierwszym wierszu wpisywana będzie data ostatniego dnia miesiąca, to sumowanie nie obejmie miesiąca wynikającego z DZIŚ(). Warunek data w nagłówku < DZIŚ() spełniony zostanie dopiero w następnym miesiącu.
Jeśli do pierwszego wiersza wpisane będą daty pierwszego dnia miesiąca, to sumowanie nie obejmie miesiąca wynikającego z DZIŚ() w pierwszym dniu tego miesiąca. Chyba, że formuła zostanie zmieniona na
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=SUMA.JEŻELI(A1:Z1;  "<=" & DZIŚ();  B2:Z2)

Pierwsza data, B1, to 31 styczeń, pozostałe to już pierwsze dni kolejnych miesięcy.
AOO 4.1.7, LO 6.3.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że ktoś podał rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 1155
Dołączył(a): So paź 12, 2013 11:09 am

Re: suma kwot do dnia dzisiejszego

Postprzez dentopolis » Pt maja 22, 2020 4:03 pm

bardzo dziękuję za pomoc!
LibreOffice 6.4
dentopolis
 
Posty: 159
Dołączył(a): Pn wrz 23, 2013 2:48 pm


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość

cron