WYSZUKAJ.PIONOWO fragment tekstu

Użytkowanie arkusza kalkulacyjnego

WYSZUKAJ.PIONOWO fragment tekstu

Postprzez roki9 » Cz gru 05, 2019 2:56 pm

Witajcie,

mam problem następujący:

w kolumnie A mam określone wyrażenie
w kolumnie B kod liczbowy przypisany do wyrażenia z kol. A
w kolumnie D mam listę zawierającą fragment wyrażenia z kol. A

Chciałbym, żeby kolumna E dopasowała mi kod liczbowy (kol. B) jeśli w kol. D występuje wyrażenie z kol. A. Czyli w podanym przykładzie w E powinno pojawić się "100".

Obrazek

A B C D E
ALA MAKOTA 100 Costam ALA MAKOTA sostamcostam #N/D
KOT MAALE 200
MAKOT ALA 300

Znalazłem wygodny patent w Excelu: https://www.youtube.com/watch?v=KBlbwB-wyqA , który w moim przypadku wyglądałby tak:
=WYSZUKAJ.PIONOWO("*"&D2&"*";A2:B4;2;0)

...ale niestety nie działa w Calcu :(
LibreOffice 6.2.3.2, Windows 10.0
roki9
 
Posty: 6
Dołączył(a): Pn maja 20, 2019 6:58 pm

Re: WYSZUKAJ.PIONOWO fragment tekstu

Postprzez Jermor » Cz gru 05, 2019 4:41 pm

W LibreOffice funkcjonują dwa różniące się pojęcia maskowania znaków.
  1. Od początku istniejące w projekcie OpenOffice "Wyrażenia regularne".
  2. Dodane do pakietu LibreOffice - "Symbole wieloznaczne", zgodne ze specyfikacja MS Office. (Niedostępne w Apache OpenOffice).
To, który system będzie stosowany ustala się w: "Narzędzia -> Opcje -> LibreOffice Calc -> Oblicz" wybierając "Włącz symbole wieloznaczne w formułach" albo "Włącz wyrażenia regularne w formułach". Jak się należy domyślać ustawiony jest ten drugi sposób, dlatego twój zapis nie zadziałał.
Dla wyrażeń regularnych zapis powinien byc taki:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=WYSZUKAJ.PIONOWO(".*"&D2&".*";A2:B4;2;0)

Ze względu na ewentualną wymienność plików między programami Calc w wersjach LibreOffice i Apache OpenOffice należałoby trzymać się wyrażeń regularnych (tak sądzę).
AOO 4.1.7, LO 6.4.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że istnieje jego rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 1209
Dołączył(a): So paź 12, 2013 11:09 am

Re: WYSZUKAJ.PIONOWO fragment tekstu

Postprzez roki9 » Cz gru 05, 2019 6:42 pm

Testowałem już wcześniej ale niestety nie działa :(
Może coś przeoczyłem... na wszelki wypadek załączam screena:

Obrazek
LibreOffice 6.2.3.2, Windows 10.0
roki9
 
Posty: 6
Dołączył(a): Pn maja 20, 2019 6:58 pm

Re: WYSZUKAJ.PIONOWO fragment tekstu

Postprzez Jermor » Cz gru 05, 2019 8:46 pm

Wydaje mi się, że źle wyszukujesz. W twojej formule wyszukujesz ciąg zawarty w komórce D2 poprzedzony i ewentualnie zakończony zerową lub dowolna liczbą innych znaków i ten ciąg ma zostać znaleziony w komórce A2, która zawiera akurat tekst dużo krótszy.
To chyba w kolumnie A powinno być to co jest wpisane w kolumnie D a to co jest w A powinno być w kolumnie D.
Zatem to raczej "ALA MAKOTA" ma zostać odnalezione w "Costam ALA MAKOTA sostamcostam".
AOO 4.1.7, LO 6.4.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że istnieje jego rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 1209
Dołączył(a): So paź 12, 2013 11:09 am

Re: WYSZUKAJ.PIONOWO fragment tekstu

Postprzez roki9 » Cz gru 05, 2019 11:12 pm

Faktycznie, to nie zadziała w tę stronę. Trzeba wykombinować to w inny sposób, chociaż na razie skończyły mi się pomysły... :(
LibreOffice 6.2.3.2, Windows 10.0
roki9
 
Posty: 6
Dołączył(a): Pn maja 20, 2019 6:58 pm


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Google [Bot] i 0 gości