Kilka problemów z funkcjami [SOLVED]

Użytkowanie arkusza kalkulacyjnego

Kilka problemów z funkcjami [SOLVED]

Postprzez wierzba » Pn sie 06, 2018 2:10 pm

Cześć,
Mam kilka problemów, z którymi nie mogę sobie poradzić.
1) W komórce C19 mam wpisaną funkcję "=JEŻELI(A19=H19;"0.04";"0.043")" chciałbym, aby zamiast H19 było "styropian", ale jak tak zrobię to funkcja nie działa, muszę robić odwołąnie do innej komórki, w której mam napisane "styropian". Jest na to jakiś sposób?

2) W komórce B2 mam zrobioną listę rozwijaną, chciałbym aby po wyborze z listy obok w komórce C2 wyświetlała się wartość z zakładki "HDD(20)" odpowiednia do nazwy z komórki B2.

3) W zakładce "U" przy mnożeniu otrzymuje wynik #ARG, gdzie robie błąd?

Z góry dziękuję za pomoc.
Załączniki
NPV dla ścian.ods
(17.9 KiB) Pobrane 4 razy
Ostatnio edytowano Cz sie 09, 2018 11:46 am przez wierzba, łącznie edytowano 1 raz
OpenOffice 4.1.5 na Winows 8.1
wierzba
 
Posty: 3
Dołączył(a): Pn sie 06, 2018 1:57 pm

Re: Kilka problemów z funkcjami

Postprzez Jermor » Śr sie 08, 2018 4:29 pm

  • Jeżeli obiektem porównywania ma być tekst wpisany bezpośrednio do formuły to MUSI być ujęty w cudzysłowy a więc "styropian".
  • Wpisanie we formule =JEŻELI(A19=H19;"0.04";"0.043") wstawia w wyniku tego tekst, a nie liczbę. Zapis "0.44" i "0.043" nie jest liczbą.
  • Powinno raczej być tak: =JEŻELI(A19=H19;0,04;0,043) w polskich wersjach ułamek dziesiętny oddzielany jest przecinkiem.
  • Ustaliłeś listę rozwijaną wpisując wszystkie nazwy do okna dialogowego. Można tak zrobić, ale wszystkie nazwy już są wpisane do arkusza HDD(20), zatem zamiast listy wybierz Zakres komórek.
  • Aby w C2 dostać potrzebny kod wykorzystaj funkcję WYSZUKAJ.PIONOWO
Zmodyfikowany plik załączam
Załączniki
NPV dla ścian A.ods
(16.06 KiB) Pobrane 5 razy
AOO 4.1.5, LO 6.0.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że ktoś podał rozwiązanie.
Jermor
 
Posty: 500
Dołączył(a): So paź 12, 2013 11:09 am


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 13 gości