Strona 1 z 1

suma kwot do dnia dzisiejszego

PostNapisane: Cz maja 21, 2020 10:57 pm
przez dentopolis
w pierwszym wierszu mam daty (mm.yy), w drugim kwoty. jak wyświetlić kwotę zarobioną do dnia dzisiejszego?
=SUMA.JEŻELI(a1:Z1;<DZIŚ();B2:Z2)
to nie działa

Re: suma kwot do dnia dzisiejszego

PostNapisane: Cz maja 21, 2020 11:22 pm
przez Rafkus
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=SUMA.JEŻELI(A1:Z1;  "<" & DZIŚ();  B2:Z2)

kryterium musi być tekstem

Re: suma kwot do dnia dzisiejszego

PostNapisane: Pt maja 22, 2020 1:07 pm
przez Jermor
I co to znaczy mam daty? Zapis w postaci np 05.20 (maj 2020) albo 12.98 (grudzień 1998)? Bo jeśli tak, to ta formuła i tak nie pomoże.

Re: suma kwot do dnia dzisiejszego

PostNapisane: Pt maja 22, 2020 1:24 pm
przez dentopolis
przesyłam plik. 1 wiersz zawiera daty.faktycznie nie działa powyższa formuła mimo że próbowałem zamienić format daty na tekst.

Re: suma kwot do dnia dzisiejszego

PostNapisane: Pt maja 22, 2020 1:38 pm
przez Rafkus
Pobrałem plik testowy - według mnie działa. Co prawda pierwszy wiesz wyświetla tylko rok i miesiąc, ale komórki przechowują całą poprawną datę czyli pierwszy dzień miesiąca . Sumuje wartości od 1 stycznia do dzisiejszego maja (więc 1 maj też). Czerwca jeszcze nie ma, więc go nie liczy.

Re: suma kwot do dnia dzisiejszego

PostNapisane: Pt maja 22, 2020 2:05 pm
przez Jermor
Sumowanie będzie zależało od daty wpisanej do pierwszego wiersza. Wiersz wyświetla zgodnie z formatem miesiąc i rok, ale tak naprawdę zawiera liczbę daty wynikającą z pełnej daty. Jeżeli w pierwszym wierszu wpisywana będzie data ostatniego dnia miesiąca, to sumowanie nie obejmie miesiąca wynikającego z DZIŚ(). Warunek data w nagłówku < DZIŚ() spełniony zostanie dopiero w następnym miesiącu.
Jeśli do pierwszego wiersza wpisane będą daty pierwszego dnia miesiąca, to sumowanie nie obejmie miesiąca wynikającego z DZIŚ() w pierwszym dniu tego miesiąca. Chyba, że formuła zostanie zmieniona na
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=SUMA.JEŻELI(A1:Z1;  "<=" & DZIŚ();  B2:Z2)

Pierwsza data, B1, to 31 styczeń, pozostałe to już pierwsze dni kolejnych miesięcy.

Re: suma kwot do dnia dzisiejszego

PostNapisane: Pt maja 22, 2020 4:03 pm
przez dentopolis
bardzo dziękuję za pomoc!