Strona 1 z 1

Wyświetlenie sumy pól jeśli zaznaczone

PostNapisane: Pn maja 18, 2020 9:25 am
przez mazurek
Mam prostą funkcję liczącą sumę pól od A1 do A10.
Potrzebuję wstawić obok dla pól B1 do B10 ptaszek wyboru na zasadzie tak nie. Domyślnie byłoby tak lub 1. Po wyborze nie lub 0 funkcja nie zliczałaby pola dla rubryki A.
Przykładowo dla pól od A1 do A10 są liczby. Pola od B1 do B9 mają opcję tak/prawda ostatnie pole B10 ma fałsz/0 i funkcja nie zlicza sumy dla pola A10.

Stworzyłem funkcję:
=SUMA.JEŻELI(F37:F76;"=tak";G37:G76)
działa poprawnie. Chciałbym jednak by zamiast wpisywać w pola F wartość tak nie, był ptaszek wyboru. Czy w Calc można wstawić pole wyboru "ptaszek" ?

Re: Wyświetlenie sumy pól jeśli zaznaczone

PostNapisane: Pn maja 18, 2020 9:53 am
przez Jermor
To najpierwszy sposób
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=SUMA.JEŻELI(B1:B10;1;A1:A10)

Jeżeli chciałbyś otrzymać wynik sumy tych komórek, które obok, w kolumnie B, mają cokolwiek wpisane, formuła może być taka:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=SUMA(A1:A10)-SUMA.JEŻELI(B1:B10;"" ;$A$1:$A$10)

Re: Wyświetlenie sumy pól jeśli zaznaczone

PostNapisane: Pn maja 18, 2020 10:31 am
przez Jermor
mazurek napisał(a):Czy w Calc można wstawić pole wyboru "ptaszek" ?

Można. Jest to jednak robota dla każdej komórki.
  • Wstawiasz do komórki B1 formant "Pole wyboru"
  • We właściwościach formantu, w zakładce "Dane" ustalasz, że komórką połączoną z formantem jest B1. Przełączanie formantu wstawia do komórki wartości PRAWDA lub FAŁSZ.
  • Nie wiem co bedzie sie działo z wyglądem twojego arkusza, więc w tych samych właściwościach, w zakładce "Ogólne" ustaw opcję "Zakotwiczenie" na stan "Do komórki".
  • Tę czynność wykonujesz dla kolejnych komórek od B2 do B10.
  • Uwaga: nie można zmienić rozmiaru krateczki, w której stawia się "ptaszek". Rozmiar formantu nie jest tożsamy z rozmiarem tej kratki.
  • Położenie formantu wewnatrz komórki możesz regulować parametrami "PozycjaX" i "PozycjaY" w tej samej zakładce "Ogólne".
  • By korzystać z funkcjonalności formantu musisz wyłączyć "Tryb projektu".
  • Aby ukryć wyświetlanie wartości logicznych w obszarze B1:B10 przypisz czcionce kolor tła tej komórki.
jako sumę możesz wpisać pierwszą formułę z mojego poprzedniego postu albo skorzystać z formuły macierzowej w postaci
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=SUMA(A1:A10*B1:B10)

Formulę macierzową zatwierdza się skrótem klawiaturowym CTRL+SHIFT+ENTER

Re: Wyświetlenie sumy pól jeśli zaznaczone

PostNapisane: Pn maja 18, 2020 10:42 am
przez mazurek
W poradniku https://www.youtube.com/watch?v=CqS4DaZ7NSQ jest pokazane chceck box. Ja w swoim CALC nie mam takiego pola. Jak wstawić "pole wyboru" ?
Obrazek

Re: Wyświetlenie sumy pól jeśli zaznaczone

PostNapisane: Pn maja 18, 2020 10:56 am
przez mazurek
Poradziem sobie z dodaniem "pole wyboru" ale jest ono nieaktywne. Jak to uaktywnić? Włączy / wyłącz kreatory nic nie zmienia.

Re: Wyświetlenie sumy pól jeśli zaznaczone

PostNapisane: Pn maja 18, 2020 12:23 pm
przez Jermor
Napisałem ci. Musisz wyłączyć "Tryb projektu". Na twojej ilustracji, w okienku "Formanty", to jest druga ikonka od lewej strony, "ekierka z linijką".