obliczanie prawidłowego tętna dla wieku

Użytkowanie arkusza kalkulacyjnego

obliczanie prawidłowego tętna dla wieku

Postprzez dentopolis » N maja 16, 2021 7:38 pm

chciałbym w zaznaczonych na czerwono komórkach z arkusza dane, wypisać wartości prawidłowego tętna dla wieku podanego w komórce B2 z arkusza norma. jak to zrobić?
Załączniki
Pierwsza Pomoc.ods
(15.48 KiB) Pobrane 8 razy
LibreOffice 7.1
dentopolis
 
Posty: 189
Dołączył(a): Pn wrz 23, 2013 2:48 pm

Re: obliczanie prawidłowego tętna dla wieku

Postprzez Rafkus » N maja 16, 2021 9:01 pm

Do komórek C7 i D7 wklej poniższe formuły:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=WYSZUKAJ.PIONOWO($B$2;   norma.$A$2:$C$100;   2)
=WYSZUKAJ.PIONOWO($B$2;   norma.$A$2:$C$100;   3)
OpenOffice 4.1.6. oraz LibreOffice 6.4 Widows 10
OpenOffice 4.1.3. oraz Libre 4.2.5.2 Windows XP
Avatar użytkownika
Rafkus
 
Posty: 273
Dołączył(a): Cz kwi 12, 2018 10:26 pm

Re: obliczanie prawidłowego tętna dla wieku

Postprzez Jermor » N maja 16, 2021 9:35 pm

Jeśli twoje dane w arkuszu "norma" rzeczywiście są przypisane do kolejnych lat, od 1 do 99 możesz skorzystać z funkcji: INDEKS(). Wymaga ona trzech argumentów: zakresu obszaru, z którego dane mają zostać pobrane, numeru wiersza i numeru kolumny wskazujących położenie danych w obszarze.
Zatem tutaj:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=INDEKS(norma.$A$2:$G$100;B2;2)

B2 wskazuje numer wiersza w tym zestawieniu (wiersze i kolumny w obszarze są zawsze liczone od 1). A liczba 2, numer kolumny, w tym przypadku zawierającej "tętno od". Gdy trafi się jednak stulatek albo osoba jeszcze starsza, funkcja zwróci błąd, gdyż z jej punktu widzenia obszar zawiera tylko 99 wierszy.
Prawdopodobnie jednak te normy będą przypisane do przedziałów wiekowych. Co oznacza, że tabelka norm nie musi być tak rozbudowana. Np. parametry normy dotyczą przedziału wiekowego od 10 do 15 lat. Wystarczy wówczas pozostawić w zestawieniu wiersz z pozycją: 10 a kolejny będzie zawierał już liczbę 16. Do pobrania potrzebnych wartości z tak zorganizowanej tabeli norm można użyć funkcji: WYSZUKAJ.PIONOWO(). Znajduje ona poszukiwany wiek, a gdy go nie ma w wykazie, przyjmuje ten, który jest w wykazie, mniejszy od szukanego. Czyli dla wieku 10 lat znajdzie dane. Dla wieku 11, 12, 13, 14 i 15 lat przyjmie dane takie jak dla 10. latka. Ze względu na takie działanie funkcji nie pojawi się błąd, gdy osoba będzie miała więcej niż 99 lat, bo zostaną pobrane dane dla wieku 99. Dla wygody tworzenia formuł sugeruję nadać nazwy tym obszarom, które będą wykorzystywane w formułach. W twoim przypadku takim obszarem jest ten zawierający normy parametrów, dla każdego wieku. U ciebie jest to obszar A2:G100. Przynajmniej na razie, bo prawdopodobnie pojawią się jeszcze jakieś inne dane i kolumn może być więcej. Dzięki temu, zamiast wpisywać w formułach zakres adresowy i to najczęściej w postaci adresów bezwzględnych, czyli w postaci $A$2:$G$100, możesz wpisać nazwę takiego obszaru. Załóżmy, że taką przypisaną nazwą będzie: "normy". O nazwach możesz poczytać tu: https://yestok.pl/ooo/y43.php
W stosunku do twojego konkretnego pytania funkcja powinna wyglądać następująco:
Komórka C7:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=WYSZUKAJ.PIONOWO(B2;normy;2)
Komórka D7:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=WYSZUKAJ.PIONOWO(B2;normy;3)

Jak widzisz w funkcji podajesz z której kolumny obszaru "normy" należy zwrócić wartość. Wymagany wiersz wyznacza zawartość komórki B2.
Można oczywiście nie nadawać nazwy obszarowi, ale wówczas zamiast prostego wpisu "normy" musi znaleźć się zapis: norma.$A$2:$G$100
AOO 4.1.10, LO 7.0.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że istnieje jego rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 1488
Dołączył(a): So paź 12, 2013 11:09 am


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 4 gości