Wyciąganie powtarzanych danych z trzech arkuszy

Użytkowanie arkusza kalkulacyjnego

Wyciąganie powtarzanych danych z trzech arkuszy

Postprzez skinderunio95 » Cz maja 13, 2021 12:40 pm

Witam,
Mam arkusz z listą zleceń, którą muszę porównać z trzema innymi arkuszami, które mają dość sporo rekordów. Potrzebuję stworzyć formułę aby wyciągnąć z listy zleceń te, które się powtarzają, na którymś z innych arkuszy. Czy można wyciągnąć to formułą?
Open Office 3.1 na Windows 10
skinderunio95
 
Posty: 1
Dołączył(a): Cz maja 13, 2021 12:34 pm

Re: Wyciąganie powtarzanych danych z trzech arkuszy

Postprzez Jermor » Cz maja 13, 2021 9:02 pm

Można, lecz skoro o to pytasz, to masz prawdopodobnie słabe doświadczenie z arkuszami.
Założenie:
Arkusz "Zlecenia" zawiera symbole zleceń.
Chodzi o stwierdzenie czy pozycja z tego arkusza znajduje się na jakimkolwiek zestawieniu w arkuszach "Zlecenia1", "Zlecenia2" i "Zlecenia3".
Niech symbole zleceń znajdują się w arkuszu "Zlecenia" w obszarze od A2 do A3000
Symbole zleceń w arkuszach "Zlecenia1", "Zlecenia2" i "Zlecenia2" znajdują się także w kolumnie A, lecz w obszarach odpowiednio A2:A7200, A2:A600 i A2:A4300.
Od razu dodam, że najwygodniej jest to wykonać w Calcu LibreOffice. Dlatego jeśli nie jest to dla ciebie problemem, to zainstaluj tę wersję pakietu. Zawiera ona funkcję o nazwie JEŻELI.BŁĄD(), której nie ma w pakiecie Apache OpenOffice.
W komórce B2 arkusza "Zlecenia" wstawiam następującą formułę:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=JEŻELI.BŁĄD("Zlecenia1: "&PODAJ.POZYCJĘ(A2;$Zlecenia1.$A$2:$A$7200;0)+1&" ";"")&JEŻELI.BŁĄD("Zlecenia2:  "&PODAJ.POZYCJĘ(A2;$Zlecenia2.$A$2:$A$600;0)+1&" ";"")&JEŻELI.BŁĄD("Zlecenia3: "&PODAJ.POZYCJĘ(A2;$Zlecenia3.$A$2:$A$4300;0)+1;"")

Wynikiem formuły jest pusta komórka, jeżeli symbol zlecenia nie pojawi się w żadnym arkuszu, lub np. napis "Zlecenia1: 33 Zlecenia3: 456" informujący, że symbol zlecenia pojawił się w 33. wierszu w arkuszu "Zlecenia1" i 456. wierszu w arkuszu "Zlecenia3".
Teraz wystarczy skopiować tę formułę w dół.
Funkcja PODAJ.POZYCJĘ() wyznacza ją wg zakresu przeszukiwanego obszaru, od A2 do A ileś tam. Czyli dla tego przykładu powiększenie numeru pozycji o 1 wyznacza numer wiersza w tym arkuszu.
AOO 4.1.10, LO 7.0.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że istnieje jego rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 1487
Dołączył(a): So paź 12, 2013 11:09 am


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości