Problem z błędem #N/D w funkcji WYSZUKAJ.PIONOWO [SOLVED]

Użytkowanie arkusza kalkulacyjnego

Problem z błędem #N/D w funkcji WYSZUKAJ.PIONOWO [SOLVED]

Postprzez Pariasenator » Cz maja 06, 2021 3:02 pm

Witam,
Mam problem, otóż próbuję skorelować dwie bazy danych. Obie mają część wspólną - KOD EAN - liczbę 13 znaków.
Chodzi o porównanie stanów magazynowych z dwóch baz. Nie wiem jak to możliwe, ale w jednej karcie to działa, a w drugiej nie.
Formuła działająca to =WYSZUKAJ.PIONOWO($L3;$Q$3:$R$227;2)
Niedziałająca =WYSZUKAJ.PIONOWO($A3;$H$3:$K$327;2)

Sprawdziłem adresy i wszystko się zgadza. Nie mam pojęcia o co może chodzić. Może o to, że EAN to długi ciąg liczb?
Najlepsze jest to, że na przeszło 300 wierszy 3 działają i nie wiem dlaczego.

Jedna baza jest większa (więcej wierszy) a druga mniejsza. Gdy porównuję większą do mniejszej to działa, odwrotnie już nie.
Może podpowiecie na co zwrócić uwagę, dodam, że format EAN mam własny 13 x 0 - druga wartość wyszukiwana to także liczba w zakresie 0-15000 (stan magazynowy)
Ostatnio edytowano Pn maja 10, 2021 7:49 am przez Pariasenator, łącznie edytowano 1 raz
Apache Open Office 4.1.7
Windows 10
Pariasenator
 
Posty: 3
Dołączył(a): Pn gru 02, 2019 1:50 pm

Re: Problem z błędem #N/D w funkcji WYSZUKAJ.PIONOWO

Postprzez Jermor » Cz maja 06, 2021 5:15 pm

Przy takim zapisie funkcji WYSZUKAJ.PIONOWO() wyszukiwanie uznaje, że kody EAN są posortowane rosnąco. Wówczas jako odnaleziony zwracany albo dokładny element (gdy kod zostanie odnaleziony w pierwszej kolumnie) albo element odpowiadający znalezionemu najbliższemu, mniejszemu, kodowi poszukiwanej wartości.
Wynik #N/D pojawia się gdy poszukiwany kod jest mniejszy od pierwszego znajdującego się w wykazie.
Zatem wystarczy, że poszukiwana wartość jest krótsza niż 13 znaków, albo zaczyna się spacją, aby otrzymanym wynikiem było #N/D
Jeżeli przeszukiwany zakres nie jest posortowany wg. pierwszej kolumny, to musi wystąpić dokładne dopasowanie, gdyż w przeciwnym razie pojawi się także wynik #N/D. Lecz wówczas ostatnim, czwartym argumentem funkcji WYSZUKAJ.PIONOWO() musi byc 0.
AOO 4.1.10, LO 7.0.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że istnieje jego rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 1487
Dołączył(a): So paź 12, 2013 11:09 am


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 10 gości