Ostatnia wypełniona komórka i kopiowanie formatowania warunk

Użytkowanie arkusza kalkulacyjnego

Ostatnia wypełniona komórka i kopiowanie formatowania warunk

Postprzez Komórczak » N lis 05, 2017 9:49 pm

Witam,

Mam prośbę o pomoc w sformułowaniu formuły do załączonej tabeli, którą chcę wykorzystać w pracy.
Tabela ma za zadanie kontrolować czynności wykonywane w kolejnych latach w danej pozycji repertorium.
Chciałbym, aby w kolumnie "żżżż" w poszczególnych wierszach były wyświetlane ostatnie wypełnione komórki (będzie to wyłącznie tekst lub liczby w komórkach o kategorii tekst)
Znalazłem kilka rozwiązań, ale dla Excela np.
=WYSZUKAJ("żżżż";zakres) - Calc zwraca #N/D, chyba, że wpiszę w którejś z komórek żżżż, to zwróci wartość żżżż
=INDEKS(zakres;MAX(JEŻELI(CZY.PUSTA(zakres)0;NR.KOLUMNY(zakres)))–NR.KOLUMNY(zakres)+1) - Calc nie posiada funkcji MAX i NR.KOLUMNY, w ich miejsce wpisałem formuły MAKS i KOLUMNA. Formuła zwraca jedynie wartość ostatniej kolumny z zakresu.
Czy jest jakiś inny sposób na wyświetlenie ostatniej niepustej komórki w wierszu?

Przy okazji, w wierszu 4 stworzyłem formatowanie warunkowe podświetlające zakres od I.2015 do daty wpisanej w kolumnie Kop. W jaki sposób przeciągnąć lub skopiować to formatowanie warunkowe do kolejnych wierszy?
Załączniki
Arkusz z tabelą.ods
(24 KiB) Pobrane 9 razy
Libre Office 5.2.3.3 (x64) na Windows 8.1
Komórczak
 
Posty: 3
Dołączył(a): N lis 05, 2017 7:20 pm

Re: Ostatnia wypełniona komórka i kopiowanie formatowania wa

Postprzez belstar » Pn lis 06, 2017 8:59 pm

Spróbuj takiej formuły
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=INDEKS(A1:F1; ; MAKS((A1:F1<>"")*KOLUMNA(A1:F1)))

Formuła tablicowa, zatwierdź CTRL+SHIFT+ENTER

Co do drugiego pytania, zaznacz cały zakres a potem wstaw formatowanie warunkowe.
LibreOffice 5.1.2.2 Ubuntu 16 LTS
belstar
 
Posty: 625
Dołączył(a): Cz mar 17, 2011 9:08 am

Re: Ostatnia wypełniona komórka i kopiowanie formatowania wa

Postprzez Komórczak » Cz lis 09, 2017 7:48 pm

Hmm, niestety, zwraca błąd:502. Wpisuję:
=INDEKS(A1:F1;;MAKS((A1:F1<>"")*KOLUMNA(A1:F1))), czy tak proponowałeś?
Czy przed funkcją MAKS mają być dwa ;?
Libre Office 5.2.3.3 (x64) na Windows 8.1
Komórczak
 
Posty: 3
Dołączył(a): N lis 05, 2017 7:20 pm

Re: Ostatnia wypełniona komórka i kopiowanie formatowania wa

Postprzez Jan_J » Cz lis 09, 2017 9:28 pm

Komórczak napisał(a):Czy przed funkcją MAKS mają być dwa ;?
Tak, bo pierwszy indeks tablicy dotyczy wiersza, drugi kolumny.

Formuła tablicowa, zatwierdź CTRL+SHIFT+ENTER
Czyli tak: <Ctrl+Shift+Enter>. Samo <Enter> da błąd przy tej składni.
JJ
LO (5.3|5.4) ∙ AOO 4.1.3 ∙ Python (2.7|3.6) ∙ Unicode 10 ∙ LATEX 2ε ∙ XML ∙ Unix tools ∙ Linux 3.x ∙ Fedora ∙ CentOS ∙ SUSE
Jan_J
 
Posty: 3428
Dołączył(a): Pt maja 22, 2009 1:20 pm
Lokalizacja: Wrocław

Re: Ostatnia wypełniona komórka i kopiowanie formatowania wa

Postprzez Komórczak » N lis 12, 2017 11:41 am

:D Rzeczywiście działa.
Gdybym jednak chciał, aby wyszukiwanie następowało od kolumny innej niż A1, to jak trzeba zmodyfikować tę funkcję?
Libre Office 5.2.3.3 (x64) na Windows 8.1
Komórczak
 
Posty: 3
Dołączył(a): N lis 05, 2017 7:20 pm


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 3 gości

cron