brak aktualizacji DDE w wersji 7 LibreOffice

Użytkowanie edytora dokumentów

brak aktualizacji DDE w wersji 7 LibreOffice

Postprzez cemik1 » Pn lut 15, 2021 11:34 am

Od dłuższego czasu używam w LibreOffice łącz dde do przenoszenia danych pomiędzy calc i writer. Wszystko działało pięknie aż do aktualizacji do wersji 7. Obecnie dane nie są przenoszone. Załączam pliki demo. Zawartość tablicy z calc jest aktualizowana w dokumencie writer w wersji 6.4.7.2(x64) a w wersji 7.0.4.2(x64) już nie. Podobnie na innym komputerze z ubuntu. Łącza aktualizują się poprawnie też w OpenOffice. Czy może ktoś już się z tym zetknął i rozwiązał problem? Może od wersji 7 trzeba jakoś inaczej ustawić opcje np. bezpieczeństwa?
Załączniki
test11.odt
Plik tekstowy, do którego powinny się kopiować
(9.54 KiB) Pobrane 10 razy
test1.ods
Plik calc, z którego pobierane są dane
(9.19 KiB) Pobrane 7 razy
OpenOffice 4.1.3
LibreOffice 5.2.5.1 (x64)
Windows 7 Professional SP1
cemik1
 
Posty: 15
Dołączył(a): Cz lip 31, 2014 11:08 am

Re: brak aktualizacji DDE w wersji 7 LibreOffice

Postprzez Jermor » Pn lut 15, 2021 9:09 pm

Mnie się wydaje, że to jest coś źle zrobionego. Wygląda to tak, jakby wstawianie tabeli z danymi, za pomocą "Wklej specjalnie - DDE" wstawiało dane ale nie potrafiło ich zaktualizować realizując aktualizację łącza. Dane zaktualizują się natomiast po użyciu klawisza F9 ("Narzędzia -> Aktualizuj -> Pola") chociaż te dane nie są sygnalizowane jako pola
Wstawienie wprost łącza DDE za pomocą polecenia "Wstaw -> Pole -> Więcej pól" (CTRL+F2) a następnie wybór zakładki "Zmienne" a w niej "Pole DDE" wstawia odświeżone wartości przy ładowaniu a gdy dokument źródła jest równolegle otwarty, od razu po zmianie danych w tym źródle. Co ciekawe w wyświetlonych polach są już wpisy z oryginalnego łącza lecz te aktualizują się tylko przez F9.
Z twojego przykładu, pierwsze łącze, jako treść pola zatytułowanego "instrukcja DDE" ma wpis "soffice file:./test1.ods Arkusz1.A1:D1". Widzisz to w dokumencie jako tabelkę.
Jeśli ten sam wpis wstawisz w innym miejscu dokumentu (wskaż nowe miejsce, zaznacz w obszarze "Wybór potrzebne łącze, a następnie "Wstaw"), nie otrzymasz tabelki, tylko kolejne wartości z komórki oddzielone spacjami. Ale będą to już pola programu (standardowo zaciemnione, jeśli w poleceniu "Widok" zaznaczono "Cieniowanie pól").
AOO 4.1.9, LO 7.0.4 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że istnieje jego rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 1414
Dołączył(a): So paź 12, 2013 11:09 am


Powrót do Writer

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 8 gości