Ciągłe awarie OpenOffice 4.1.7 i 4.1.2

Użytkowanie edytora dokumentów

Ciągłe awarie OpenOffice 4.1.7 i 4.1.2

Postprzez Nika » Pt lis 08, 2019 10:21 am

Dzień dobry wszystkim,

Z góry przepraszam, jeśli piszę w złym miejscu, ale pilnie poszukuję pomocy dotyczącej ciągłego wyłączania się Writera OpenOffice. Zaznaczę również, że jestem 100% laikiem, który nie bardzo zna się na komputerach ;)

Ale od początku - trzy tygodnie temu zmieniłam komputer i przeniosłam się z Windowsa 7 do Windows 10, po czym od razu zainstalowałam OpenOffica, bo używam go już od bardzo dawna i wręcz wolę go, niż Worda. W tym tygodniu zaczęłam uzupełniać notatki ze studiów i niestety co chwilę pojawia się komunikat o błędzie i że program musi zostać wyłączony. Półtora tygodnia temu miałam dość dużą aktualizację i podejrzewam, że to może być przyczyna, bo wcześniej również intensywnie użytkowałam Writera, a problemów nie było. Odinstalowałam już OpenOffica 4.1.7 i zainstalowałam starszą wersję - 4.1.2, naiwnie myśląc, że może się poprawi, ale błąd występuje nadal. I nie tylko w tym jednym pliku, ale w innych również.

Obrazek
W załączonym screenie, błąd pojawił się po 4-krotnym naciśnięciu ENTER.

Ręce mi już opadają, a jutro znów mam zjazd, gdzie będziemy sporo pisać i chciałam zabrać komputer ze sobą, ale jak Writer będzie mi się ciągle wyłączał, to natychmiast wszystko stracę, i w efekcie będę musiała wszystko przepisywać drugi raz.

Będę wdzięczna za każdą pomoc lub radę ;)
OpenOffice 4.1.7 na Windows 10
Nika
 
Posty: 1
Dołączył(a): Pt lis 08, 2019 9:57 am

Re: Ciągłe awarie OpenOffice 4.1.7 i 4.1.2

Postprzez Jan_J » Pt lis 08, 2019 11:41 am

Problem dotyczy prawdopodobnie trybu wykonywania 32-bitowego kodu w 64-bitowym systemie albo związanego z tym trybem problemu w korzystaniu z bibliotek.

W https://www.openoffice.org/product/windows.html
The current Apache OpenOffice supports Microsoft Windows XP, Vista, Windows 7 and Windows 8.

Specific platform version notes:

Windows 2000: OpenOffice may work on Windows 2000, but we don't test or recommend it.
Windows XP: Tested, stable, no platform-specific problems known.
Windows Vista: Tested, stable, no platform-specific problems known.
Windows 7: Tested, stable.
Windows 8: We run as a "desktop application", not a Metro "App". Requires x86 or 64-bit Windows. We do not support Windows RT, the ARM-based version, intended for tablets.

Please note: Apache OpenOffice is distributed as a 32-bit application. It will run successfully in 32-bit mode on 64-bit versions of Windows 7 and Windows 8. But in those cases a 32-bit JVM is required for some functionality.

Z czego wynika, że W10 wciąż nie jest oficjalnie wspierany przez AOO (...!)

Natomiast wymagania systemowe LibreOffice (https://www.libreoffice.org/get-help/sy ... uirements/) są następujące:
Microsoft Windows

The software and hardware prerequisites for installing LibreOffice on a Windows system are as follows:

Microsoft Windows 7 SP1, Windows 8, Windows Server 2012, or Windows 10
Pentium-compatible PC (Pentium III, Athlon or more-recent system recommended)
256 MB RAM (512 MB RAM recommended)
Up to 1.5 GB available hard disk space
1024x768 resolution (higher resolution recommended), with at least 256 colors

Administrator rights are needed for the installation process. It is a recommended best practice to back up your system and data before you remove or install software.

For certain features of the software - but not most - Java is required. Java is notably required for Base.


Nie mam żadnych doświadczeń z Apache OpenOffice 4.x pod Windows 10. Mój kolega z sąsiedniego pokoju w pracy ma Apache OO pod W10; mogę go spytać o podobne zachowanie. Ale obawiam się, że dojście do źródeł problemu może być trudne.

Ja bym proponował zainstalować LibreOffice Still (obecnie 6.2.8) 64-bitowy. W 64-bitowym W10 mam zainstalowany 64-bitowy LibreOffice 6.2.x i nie mam z nim problemów.
JJ
LO Still (6.2) ∙ AOO 4.1.7 ∙ Python (3.7|2.7) ∙ Unicode 12 ∙ LATEX 2ε ∙ XML ∙ Unix tools ∙ Linux (Fedora|CentOS|SUSE)
Jan_J
 
Posty: 3992
Dołączył(a): Pt maja 22, 2009 1:20 pm
Lokalizacja: Wrocław

Re: Ciągłe awarie OpenOffice 4.1.7 i 4.1.2

Postprzez Jermor » Pt lis 08, 2019 2:31 pm

Z postu @Nika nie można wprost wywnioskować, że używa ona Windows 10 64 bitowego.
U siebie mam taki Windows (10 Pro, 64-bitowy, wersja 1903, kompilacja 18362.418) i zainstalowany zarówno Apache OpenOffice 4.1.7 jak i 64-bitowy LibreOffice 6.1.7. Oba systemy pracują prawidłowo. Jeśli system koleżanki jest rzeczywiście 64 bitowy to problemem może być także np. środowisko Javy. Gdyż Java musi być taka jak aplikacja, która ją wykorzystuje. Czyli 32 bitowa dla aplikacji 32 bitowych i 64 bitowa dla aplikacji 64 bitowych. Na komputerach z systemem 32 bitowym nie można zainstalować aplikacji 64 bitowej, więc jest tylko jedna wersja Javy, ta 32 bitowa. W komputerach z systemem 64 bitowym można zainstalować aplikacje zarówno 32- jak i 64-bitowe. Wówczas jednak trzeba także zainstalować dwie Javy.
Niezależnie od powyższego zachodzi podejrzenie, że problem znajduje się po stronie Windows. Może warto sprawdzić czy wersja systemu jest aktualna?
No i w końcu, chyba jednak warto przenieść się do LibreOffice, oczywiście na wersję Still jak wspomniał Jan_J. Strona pobierania https://www.libreoffice.org/download/download/ sama rozpozna wersję bitową systemu i zaproponuje właściwe moduły.
AOO 4.1.7, LO 6.2.7 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że ktoś podał rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 846
Dołączył(a): So paź 12, 2013 11:09 am


Powrót do Writer

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości