[SOLVED]problem z poprawnym odtworzeniem dokumentu

Użytkowanie edytora dokumentów

[SOLVED]problem z poprawnym odtworzeniem dokumentu

Postprzez m4tt » Cz sty 17, 2019 10:40 pm

Witam

Mam problem z poprawnym odtworzeniem dokumentu. W dokumencie o którym mówię piszę zaświadczenia dla kierowców na komputerze(z windowsem 10) i mam po przestawione część pisma na odwrót wraz z przestawionym szarym polem (w załączniku to widać - zaznaczyłem kółkiem niebieskim). Dokumentu niestety nie mogę edytować. Dodam że być może przyczyną przestawionego pisma jest to że program był pisany w starym programie i na nowych nie odtwarza go poprawnie bo na moim poprzednim komputerze gdzie miałem starego Microsoft Worda(bodajże Microsoft Word 2003) to problem nie występował(żadne litery nie były poprzestawiane). Obecnie używam programu Libre Office Writer Wersja: 6.1.4.2 i problem występuje. W załączniku wklejam screenshot by lepiej pokazać problem
Załączniki
dokument.jpg
Ostatnio edytowano Śr sty 23, 2019 1:40 am przez m4tt, łącznie edytowano 1 raz
LibreOffice Wersja: 6.1.4.2 na Windows 10
m4tt
 
Posty: 15
Dołączył(a): Pn gru 17, 2018 6:58 pm

Re: problem techniczny z poprawnym odtworzeniem dokumentu

Postprzez Jermor » Pt sty 18, 2019 2:41 pm

Analogiczny problem był już zgłaszany na naszym forum, zob. https://forum.openoffice.org/pl/forum/viewtopic.php?f=8&t=1527, ale nie został wyjaśniony.
Podobnie jak u ciebie oryginalny dokument został przygotowany w Wordzie.
Objaw jaki prezentujesz związany jest z tekstami tworzonymi w językach arabskich lub w hebrajskim. W nich rzeczywiście pisze się od strony prawej do lewej.
Chyba można to samodzielnie poprawić. Gdybyś załączył taki dokument niewypełniony, zobaczyłbym co można zrobić.
AOO 4.1.6, LO 6.1.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że ktoś podał rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 745
Dołączył(a): So paź 12, 2013 11:09 am

Re: problem techniczny z poprawnym odtworzeniem dokumentu

Postprzez m4tt » Wt sty 22, 2019 1:31 am

Oryginalny pusty formularz pochodzi z ec.europa.eu . Wpisując w google treść " ec.europa.eu zaświadczenie o działalności " od razu wyskoczy oryginalny pusty formularz i odtwarzając go w LibreOffice litery już nie są w odwrotnej kolejności natomiast szare pola są poprzestawiane. Dodam że mam dużo tych zaświadczeń pisanych i zauważyłem że w niektórych nie mam poprzestawianych liter tak jak nie ma poprzestawiany w oryginale więc może to wina jakiejś nie odpowiedniej edycji plików przez osobę piszącą zaświadczenia. Natomiast poprzestawiane szare pola to problem chyba nie zależny od tego. Po prostu może taki zbieg okoliczności(mogę się mylić - takie moje domysły)

W razie czego wklejam jeszcze w złączniku ten niewypełniony formularz

Z góry bardzo ci dziękuję Jermor za pomoc już wielokrotnie mi pomogłeś
Załączniki
attestation_of_activities_pl.doc
(62 KiB) Pobrane 18 razy
LibreOffice Wersja: 6.1.4.2 na Windows 10
m4tt
 
Posty: 15
Dołączył(a): Pn gru 17, 2018 6:58 pm

Re: problem techniczny z poprawnym odtworzeniem dokumentu

Postprzez m4tt » Wt sty 22, 2019 1:42 am

Własnie znalazłem to samo zaświadczenie na innej stronie wpisując w google frazę "wzór zaświadczenia o nieprowadzeniu pojazdu" i tu z kolei zarówno litery jak i pola są poprzestawiane także widać że problem chyba leży u samego źródła . Załączam plik
Załączniki
zaswiadczenie_561.doc
(40.5 KiB) Pobrane 20 razy
LibreOffice Wersja: 6.1.4.2 na Windows 10
m4tt
 
Posty: 15
Dołączył(a): Pn gru 17, 2018 6:58 pm

Re: problem techniczny z poprawnym odtworzeniem dokumentu

Postprzez Jan_J » Wt sty 22, 2019 1:45 pm

Pobrałem, odczytałem Wordem 2010 i zapisałem w formatach OO XML (docx), ODF (odt).
Wszystkie trzy odczytywane Writerem dają efekt odwrócenia kierunku w wybranych miejscach.

Dokumenty docx i odt są tekstowe (XML+ZIP), po rozpakowaniu z analizy znaczników i tak nie widzę, dlaczego akurat te miejsca miałyby zachowywać się odmiennie. Ale widocznie nieuważnie patrzę, bo MUSI być powód na poziomie znaczników.

Pliku doc tak łatwo zanalizować się nie da, ponieważ jest binarny.

Załączam oba, z zastrzeżeniem: oba są interpretowane WADLIWIE przez Writera, na dodatek odt wygenerowany przez Worda NIE JEST w pełni użytecznym dokumentem! ale mogą się przydać do analizy.
zaswiadczenie_561.odt
(18.03 KiB) Pobrane 13 razy
zaswiadczenie_561.docx
(24.94 KiB) Pobrane 15 razy
JJ
LO (6.1|6.2) ∙ AOO 4.1.6 ∙ Python (3.7|2.7) ∙ Unicode 12 ∙ LATEX 2ε ∙ XML ∙ Unix tools ∙ Linux (Fedora|CentOS|SUSE)
Jan_J
 
Posty: 3923
Dołączył(a): Pt maja 22, 2009 1:20 pm
Lokalizacja: Wrocław

Re: problem techniczny z poprawnym odtworzeniem dokumentu

Postprzez Jermor » Wt sty 22, 2019 11:05 pm

Mnie także nie udało się zlokalizować miejsc decydujących o wpisach. Niewątpliwie jednak pozycja 14-ta i 17-ta zapisane zostały w języku arabskim (Arabia Saudyjska) i to spowodowało, że cały zapis jest od prawej do lewej.
Poprawiłem to ręcznie. Odsyłam ci plik "wordowy", z rozszerzeniem doc. Ponadto przygotowałem ten sam dokument w formacie odt, czyli Writera. Zmieniłem w nim kontrolki zaznaczające oświadczenie o pracy. Z opisu wynika, że może być zaznaczona tylko jedna, więc tak zrobiłem. Zaznaczenie jednej wyłącza zaznaczenie inne jeśli było. Same kontrolki w dokumencie nie wyglądają imponująco, za to na wydruku jest zupełnie inaczej.
190122214217_1.jpg

Zmieniłem także pola wprowadzania na właściwe dla Writera. Wystarczy kliknąć dwukrotnie a otworzy się okienko do wpisania potrzebnej informacji. Po jej wpisaniu można zamiast "OK" kliknąć trójkątny wskaźnik przejścia do następnego pola. Wprowadzone dane zostaną zapisane w polu a okienko dialogowe otworzy się do nowego wpisu.
Plik doc
m4tt zaswiadczenie_561.doc
(47 KiB) Pobrane 19 razy

Plik odt
m4tt zaswiadczenie_561 k+pola.odt
(27.1 KiB) Pobrane 15 razy
AOO 4.1.6, LO 6.1.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że ktoś podał rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 745
Dołączył(a): So paź 12, 2013 11:09 am

Re: problem techniczny z poprawnym odtworzeniem dokumentu

Postprzez m4tt » Śr sty 23, 2019 1:39 am

Bardzo wam dziękuję pomoc.
LibreOffice Wersja: 6.1.4.2 na Windows 10
m4tt
 
Posty: 15
Dołączył(a): Pn gru 17, 2018 6:58 pm

Re: [SOLVED]problem z poprawnym odtworzeniem dokumentu

Postprzez Jermor » Cz sty 24, 2019 5:45 pm

Dotarłem do stron EU które zawierają ten załącznik. To strona https://ec.europa.eu/transport/modes/road/social_provisions/driving_time/form_attestation_activities_en
Są tam do pobrania dwa pliki. Jeden to DOC z Worda 2010 i ten zawiera błędny zapis dwóch wspomnianych wierszy. Drugi to DOC z Worda 2003 i ten jest poprawny.
Aby pobrać polską wersję dokumentu należy kliknąć symbol obok nazwy pliku i na nowej stronie wybrać język dokumentu. Plik jest chroniony hasłem więc w Wordzie nie można go poprawić. Da się w Writerze.
AOO 4.1.6, LO 6.1.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że ktoś podał rozwiązanie.
Avatar użytkownika
Jermor
 
Posty: 745
Dołączył(a): So paź 12, 2013 11:09 am


Powrót do Writer

Kto przegląda forum

Użytkownicy przeglądający ten dział: Google [Bot] i 7 gości