Strona 1 z 1

LibreOffice - Java

PostNapisane: So lip 14, 2012 10:49 pm
przez Vansen
Nie mogę zarejestrować nowego makra na LO 3.5.5. Pojawia się komunikat: Do wykonania tej operacji LO wymaga środowiska Java (JRE). Wykryte środowisko JRE jest niepoprawne. Wybierz inną wersję JRE lub zainstaluj nową wersję i wybierz jąklikając: Narzędzia - Opcje - LibreOffice - Java. Nie działa na wersjach Javy :7 Update 5 i 6 Update 33. Na OpenOffice 3.1 Portable działa dobrze.

Re: LibreOffice - Java

PostNapisane: Pn lip 16, 2012 6:55 pm
przez quest-88
LibreOffice nie jest kompatybilny z Javą 7. Instalacja Javy 6 rozwiąże ten problem.

Re: LibreOffice - Java

PostNapisane: Śr lip 18, 2012 9:38 pm
przez Vansen
Na Javie 6 update 33 też nie działa.

Re: LibreOffice - Java

PostNapisane: Śr lip 18, 2012 10:14 pm
przez Jan_J
??? z 6u32 i wcześniejszymi nie miałem nigdy problemów (oprócz bodajże 14). Co prawda 33 nie mam i nie sprawdzałem.

Re: LibreOffice - Java

PostNapisane: Wt lip 17, 2018 6:07 pm
przez lucgors
To jest najstarszy wątek na forum opisujący powtarzające się raz za razem nie rozpoznawanie środowiska Java przez Libre Office.
Problem jest ciągle aktualny.

Dzisiaj zainstalowałem LO 5.4.7.2.
Odinstalowałem poprzednią wersję, wyczyściłem ręcznie resztki w folderach.
Pobrałem najnowsze JRE 171, usunąłem poprzednie.

Wykonałem próbę pokazania w LO gdzie ma szukać Java - menu Narzędzia>Opcje>Zaawansowane.
LO nie rozpoznał w C:\Program Files (x86)\Java\jre1.8.0_171\, że tam jest Java dla niego.

Próbowałem też bezpośrednio podać ścieżkę dostępu parametrem -Dm yprop= podając różne wersje dostępu, bezpośrednio: -Dm yprop=c:\\Program Files (x86)\Java\jre1.8.0_171\bin\java.e albo pośrednio: -Dm yprop=\c:\ProgramData\Oracle\Java\javapath\.

Bez powodzenia.
Która wersja JRE będzie zaakceptowana przez LO 5.4.7.2?
Jaki folder wskazać w oknie Narzędzia>Opcje>Zaawansowane?

Re: LibreOffice - Java

PostNapisane: Cz sie 09, 2018 11:51 am
przez Jermor
LibreOffice funkcjonuje w dwóch wersjach 32- i 64-bitowej. I dla wersji należy pobrać Javę. Jeśli w systemie korzysta się także z aplikacji 32 bitowych trzeba zainstalować obie wersje Javy. Folderem dla aplikacji 64-bitowych jest w Windows "Program Files", dla aplikacji 32-bitowych "Program Files(x86)"