Word niepoprawnie widzi symbole

Użytkowanie edytora równań

Word niepoprawnie widzi symbole

Postprzez deveee » Wt maja 17, 2011 12:29 am

Witam.

Korzystam z najnowszej wersji Libreoffice (3.3) pod Linuksem.

Problem jest taki: tworzę formułę na Linuksie. On nie ma tam windowsowej czcionki "Symbol", tylko korzysta z własnej czcionki "OpenSymbol". Możliwe, że na windowsie też tak jest, nie wiem. Następnie wysyłam komuś dokument, on otwiera go w Wordzie. Na komputerze nie ma zainstalowanej czcionki "OpenSymbol" - bo i skąd, korzysta z Worda. Skutkiem tego jest to, że nie widzi niektórych znaków. Najbardziej upierdliwym zaś, że zamiast znaku mnożenia (cdot) jest kratka - brak znaku. Jeszcze inne drobiazgi, ale ten sam problem.

Trzeba by zmusić Openoffice'a do korzystania z czcionki "Symbol". Jednakże przekopałem konfigurację i nie widzę takiej możliwości. Nie ma problemu żeby wgrać sobie czcionkę Microsoftu, tyle tylko, że przydałoby się wejść w jakąś zaawansowaną konfigurację i mu tą czcionkę ustawić.

Jeśli pod windowsem on też korzysta z czcionki "OpenSymbol" to przypuszczam, że będzie dokładnie ten sam problem jak ktoś ma na komputerze tylko Worda.

Ewentualnie pomogłaby poprawka od strony programu - w samej czcionce "OpenSymbol" albo w konwersji na doc'a.

Jeśli ktoś rozwiązał ten problem to prosiłbym o informację. Choć trochę powątpiewam.
Załączniki
ZRZUT_EKRANU20.jpg
cdot w Word
ZRZUT_EKRANU10.jpg
cdot w Libreoffice
deveee
 
Posty: 3
Dołączył(a): Pn maja 16, 2011 11:35 pm

Re: Word niepoprawnie widzi symbole

Postprzez quest-88 » Wt maja 17, 2011 9:23 am

Trzeba by zmusić Openoffice'a do korzystania z czcionki "Symbol". Jednakże przekopałem konfigurację i nie widzę takiej możliwości.

Narzędzia > Opcje > LibreOffice > Czcionki > Zastosuj tabelę zmian > OpenSymbol na Symbol

ale nie wiem czy to coś da. Nie prościej byłoby namówić tę osobę do zainstalowania fontu OpenSymbol, albo Open/LibreOffice?
Standardowa diagnostyka · Co warto zmienić po świeżej instalacji? ·
Przepis na LibreOffice
GNU/Linux CentOS 6.5 · LO x.x (zawsze najświeższe)
Uzyskałeś pomoc? Poinformuj innych o sprawdzonym rozwiązaniu i podziękuj. Dodaj [SOLVED] w tytule.
Avatar użytkownika
quest-88
 
Posty: 944
Dołączył(a): N maja 24, 2009 8:12 pm
Lokalizacja: Zabrze

Re: Word niepoprawnie widzi symbole

Postprzez deveee » Śr maja 18, 2011 10:42 pm

Nic nie da, bo to podmienia czcionkę wyświetlaną u mnie w dokumencie. Zapisywana jest w pliku i tak OpenSymbol.

W przypadku jednej osoby faktycznie prościej podesłać jej czcionkę i święty spokój. Ale tak szerzej patrząc to problemu to nie rozwiązuje.

Będę z tym coś walczył, jak co to dam znać.
Openoffice 1.2.3 Windows
deveee
 
Posty: 3
Dołączył(a): Pn maja 16, 2011 11:35 pm

Re: Word niepoprawnie widzi symbole

Postprzez quest-88 » Śr maja 18, 2011 10:59 pm

Nie widzę innego wyjścia. Myślałem też o osadzaniu fontu wewnątrz dokumentu, ale to cecha Worda, a prośba o podobna funkcję wisi w IssueZilli od 2003 roku.

Bug 20370 - Q-PCD MSInteroperability-33: embedd fonts into the document
Standardowa diagnostyka · Co warto zmienić po świeżej instalacji? ·
Przepis na LibreOffice
GNU/Linux CentOS 6.5 · LO x.x (zawsze najświeższe)
Uzyskałeś pomoc? Poinformuj innych o sprawdzonym rozwiązaniu i podziękuj. Dodaj [SOLVED] w tytule.
Avatar użytkownika
quest-88
 
Posty: 944
Dołączył(a): N maja 24, 2009 8:12 pm
Lokalizacja: Zabrze

Re: Word niepoprawnie widzi symbole

Postprzez deveee » Cz maja 19, 2011 10:23 am

Znaczy można sobie zawsze samemu przekompilować program, podmienić mu tam czcionkę i przypisać odpowiednie kody dla znaków. Ale nie jestem na tyle biegły i sporo czasu by mi to zajęło.

Kurde, nie ma jakiejś takiej zaawansowanej konfiguracji jak np w firefoksie? Tam by można pozmieniać co trzeba.
Openoffice 1.2.3 Windows
deveee
 
Posty: 3
Dołączył(a): Pn maja 16, 2011 11:35 pm

Re: Word niepoprawnie widzi symbole

Postprzez dorotaW » Pn lis 24, 2014 9:27 am

Witam. Dziękuję bardzo. Ten temat mam akurat zrobić i omówić na zajęciach. Studiuję medycynę i informatyka daje wszystkim w "kość".

Wszystkim życzę wszystkiego najlepszego...
OpenOffice 3.1 na Windows Vista
dorotaW
 
Posty: 3
Dołączył(a): Pt lis 21, 2014 9:17 pm
Lokalizacja: Kraków

Re: Word niepoprawnie widzi symbole

Postprzez Astur » Wt lis 25, 2014 9:37 am

1. Ściągnij czcionkę Symbol. Oficjalny kanał http://www.ascenderfonts.com/font/symbol.aspx za $20
2. Po ściągnięciu wkopiuj plik(i) z rozszerzeniem ttf do katalogu ~\.fonts
3. Uruchom LibreOffice - czcionka już powinna być widoczna na liście czcionek.
LibreOffice 4.2.8.2

Zanim zastosujesz się do jakiejś rady, zrób kopię zapasową dokumentu, którego ona ma dotyczyć.
Avatar użytkownika
Astur
 
Posty: 228
Dołączył(a): Wt lip 13, 2010 9:11 am


Powrót do Math

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość