Strona 1 z 1

Wstawianie hiperłączy i niedziałający link u odbiorcy SOLVED

PostNapisane: So maja 02, 2020 7:32 am
przez krzysryt
Dzień dobry,
wstawiłem do prezentacji hiperłącze w slajdzie nr 22. Na moim komputerze przenosi mnie ładnie na żądaną stronę: http://www.amway.pl/user/rytczak. Hiperłącze jest jako tekst.
Niestety jak tylko prześlę go via email na inne urządzenie, hiperłącze przestaje działać. Zostaje tylko obiekt, ale znika przypisany adres URL. Widać po edytowaniu tego obiektu.

Nie mogę sobie z tym poradzić i zrozumieć, gdzie jest błąd. Na komputerze, na którym była prezentacja stworzona działa wszystko (nawet, jeśli odtworzę to z email przez przeglądarkę Chrome. Jak tylko uruchamiam na innym urządzeniu adres URL znika - jak by gdzieś na komputerze się zapisywał jakiś element, który nie przesyła się do innych urządzeń.

W załączeniu przesyłam tą prezentację do testów. Ten link znajduje się na slajdzie nr 22 pod tekstem "REJESTRACJA ONLINE".
Przepraszam, że załącznik jest z rozszerzeniem zip, ale nawet pojedynczy slajd miał 132 KB a max rozmiar na forum to 128 KB.

Dziękuję serdecznie za wskazówki. Bez dobrze działającego linku ta prezentacja przestaje mieć po prostu sens.

Re: Wstawianie hiperłączy i niedziałający link u odbiorcy

PostNapisane: So maja 02, 2020 12:00 pm
przez Jermor
Nie rozumiem tego fragmentu...
krzysryt napisał(a):Na komputerze, na którym była prezentacja stworzona działa wszystko (nawet, jeśli odtworzę to z email przez przeglądarkę Chrome.

Prezentację przeglądasz jak sądzę w programie PowerPoint lub odpowiadający mu w pakiecie OpenOffice Impress.
W moim przypadku wszystkie łącza działają, zarówno w PowerPoincie jak, w Apache OpenOffice Impress (także kliknięcie bez klawisza CTRL) oraz w LibreOffice Impress (tylko z przytrzymanym CTRL podczas kliknięcia)
Konieczność przytrzymania CTRL (przy klikaniu w link) jest deklarowane w ustawieniach programu "Narzędzia -> Opcje -> OpenOffice lub LibreOffice -> Bezpieczeństwo ->Opcje i ostrzeżenia dotyczące bezpieczeństwa.Opcje -> Opcje bezpieczeństwa ".
W LibreOffice jest dodatkowa opcja pozwalająca uruchamiać linki tylko z zaufanych lokalizacji.

Re: Wstawianie hiperłączy i niedziałający link u odbiorcy

PostNapisane: So maja 02, 2020 12:28 pm
przez krzysryt
Nie rozumiem tego fragmentu...
krzysryt napisał(a):
Na komputerze, na którym była prezentacja stworzona działa wszystko (nawet, jeśli odtworzę to z email przez przeglądarkę Chrome.


Stworzyłem prezentację w OpenOffice Impress wer. 4.1.7 na moim laptopie. Wysłałem plik via email z jednego adresu na drugi. Potem na tym samym laptopie włączyłem bezpośrednio z Gmail (ze strony internetowej w przeglądarce) i link działał bez problemów. Ale jak już uruchomiłem go na smartfonie lub w Open Office u koleżanki i PowerPoint u kolegi to niestety z obiektu znikał adres URL tego odnośnika. Zostawał tylko nieaktywny podkreślony tekst widoczny u odbiorcy jako obiekt. Ale jeśli się edytowało podkreślony tekst, nie było w nim adresu strony internetowej.

To właśnie miałem na myśli. Mam nadzieję, że teraz było bardziej zrozumiale :)

Re: Wstawianie hiperłączy i niedziałający link u odbiorcy

PostNapisane: So maja 02, 2020 2:50 pm
przez Jermor
To, czego nie rozumiem to otwieranie prezentacji w przeglądarce. Przeglądarki i programy pocztowe mają rożne dodatki pozwalające otwierać niektóre typy dokumentów bezpośrednio w nich. Pytanie, czy robią to z pełną funkcjonalnością tego dokumentu.
Formalnie twój plik powinien zostać otwarty w programie do tworzenia i przeglądania prezentacji.
Ponadto przy otwieraniu pliku ppt może on być otwierany jako plik do edycji, a w tym trybie mogą (choć nie muszą) nie działać wszystkie funkcjonalności. Uaktywnią się one prawdopodobnie dopiero po uruchomieniu prezentacji. Może zatem zapisz swój plik jako autoprezentację, czyli plik pps albo ppsx?
Jeszcze raz napiszę, że plik pobrany z forum (czyli taki jak przesłany np. w mailu) działa u mnie poprawnie, przy czym PowerPoint wymaga abym najpierw przeszedł do prezentacji, bo w trybie edycji slajd nie daje możliwości wykorzystania linku. W Impress, w obu wersjach, możliwe jest skorzystanie z linku już w trybie edycji.