Formule voor aantal karakters tellen per individuele regel

Bespreek het rekenblad
LadyoftheCave
Berichten: 6
Lid geworden op: wo jun 21, 2017 9:57 am

Formule voor aantal karakters tellen per individuele regel

Bericht door LadyoftheCave »

Hallo,
Ik moet voor een opdracht voor mijn studie in rijen alle 98 meldingen tellen. Hiervoor is de volgende code bijgeleverd: =AANTAL.ALS(B2:AS2;98) hierbij was gezegd dat als ik deze code kopieer, dat deze dan automatisch de rijnummers aanpast (dus bij rij 3 zou de code dan =AANTAL.ALS(B3:AS3;98) worden), maar dit is helaas niet zo, als ik ze naar alle rijen kopieer dan zijn de formules overal hetzelfde, waardoor ze overal het aantal keer dat 98 voorkomt in rij 2 weergeven. :(
Hoe kan ik dit aanpassen, dat ik dus per rij het aantal x dat 98 voorkomt kan tellen, zonder dit in 400 rijen handmatig aan te passen?
Alvast heel erg bedankt!! :D
OpenOffice 4.1 op Windows 10
RPG
Berichten: 4553
Lid geworden op: wo apr 15, 2009 1:01 am
Locatie: Apeldoorn, Nederland

Re: Formule voor aantal karakters tellen per individuele regel

Bericht door RPG »

Naar mijn idee moet je een draaitabel gebruiken. Het is niet zo gemakkelijk om dat te begrijpen maar veel gemakkelijker dan hoe je het nu wilt proberen. Bovendien laat zich dat toepassen op veel problemen.Zie:
Tutorial over draaitabellen

Het doel van computer gebruik is dat de computer voor ons werkt. Door een draaitabel te begrijpen leer je gemakkelijker met gegevens om te gaan. Vergeet niet dat een draaitabel ontworpen is voor mensen die niet allerlei formules willen leren en hoeven te leren.
LibreOffice 7.3.3.1 op openSUSE Leap 15.4
RPG
Berichten: 4553
Lid geworden op: wo apr 15, 2009 1:01 am
Locatie: Apeldoorn, Nederland

Re: Formule voor aantal karakters tellen per individuele regel

Bericht door RPG »

Ik heb de getoonde formule bij mezelf ingetypt en die kan ik zonder problemen naar beneden trekken. Als er het teken $ in voor komt wil dat niet.
LibreOffice 7.3.3.1 op openSUSE Leap 15.4
RPG
Berichten: 4553
Lid geworden op: wo apr 15, 2009 1:01 am
Locatie: Apeldoorn, Nederland

Re: Formule voor aantal karakters tellen per individuele regel

Bericht door RPG »

Als ik feitelijk het hele doel goed begrijp moet het voorkomen van een bepaalde letter geteld worden in een regel.

De uitwerking komt ook gedeeltelijk van het Engelse forum:
Apache OpenOffice Community Forum - [Solved] Find and count a character in a cell - (View topic)

De werking is eenvoudig
Tel eerst de lengte van de string .
Verwijder de gezochte letter en tel opnieuw de lengte van de string.
Het verschil is het aantal gezochte letters.

Dit principe kan op verschillende manieren worden toegepast.

Bijgevoegd een voorbeeld voor 1000 regels tekst.
Bijlagen
ZoekLetter.ods
Zoek een letter in een regel tekst
(11.65 KiB) 8 keer gedownload
LibreOffice 7.3.3.1 op openSUSE Leap 15.4
Plaats reactie