Zoek functie in ander veld bij factuur

Bespreek het rekenblad

Zoek functie in ander veld bij factuur

Berichtdoor Flexon » do nov 08, 2018 1:27 am

Ik heb een factuur/offerte in Calc en op "veld 1 KLANTEN" de namen en adressen staan
En in "veld2 FACTUUR " vul ik het bijpassende nummer in K2 in en worden de naam en adres gegevens automatisch ingevuld met =VERT.ZOEKEN(K2;Klanten.A2:E300;3;0)
Nu moet ik naar "veld 1 KLANTEN "om met de zoekfunctie van open office de naam te zoeken en dan terug naar "veld 2 FACTUUR "en daar vul ik het bijpassende cijfer in
Soms zijn er klanten aanwezig als ik voor hun een factuur maak, ik wil niet dat die klant inzage heeft in mijn klanten
Is er een mogelijkheid dat ik de naam zoek terwijl ik in "Veld 2 FACTUUR" blijf
Het resultaat zou dus moeten zijn: zoek op naam "naam" = cijfer bijvoorbeeld "248" in cel K2 waardoor de naam en adres gegevens worden ingevuld in cellen
open office 4.1.1 windows 7 home
Flexon
 
Berichten: 8
Geregistreerd: do sep 03, 2015 11:57 pm

Re: Zoek functie in ander veld bij factuur

Berichtdoor RPG » vr nov 09, 2018 10:33 am

Ik weet niet zo precies wat je wilt verbergen. Ik denk dat je toch iets moet veranderen aan je programma. Maak gebruik van geldigheid. Hier kun je een naam selecteren. Je kunt ook gebruik maken van een listbox(keuzelijst) of combobox(keuzelijst met invoervak). Bij deze twee heb je nog meer controle mogelijkheden.

Alle drie mogelijkheden plaatsen een waarde in een cel. De ver.zoeken moet dan gekoppeld worden aan deze cel

Romke
LibreOffice 6.3.3.2.0 op openSUSE Leap 15.1
RPG
 
Berichten: 4093
Geregistreerd: wo apr 15, 2009 1:01 am
Woonplaats: Apeldoorn, Nederland

Re: Zoek functie in ander veld bij factuur

Berichtdoor Flexon » vr nov 09, 2018 12:56 pm

Romke,

Een keuzelijst is niet wat ik wil.
Als ik dan door de lijst met namen blader, dan kan er alsnog mee gekeken worden door de klant die er op dat moment is
De functie [ TEKST ZOEKEN ] met de pijlen er naast die in de werkbalk staat, daar zoek ik nu mee naar een naam van de klant of de naam van het bedrijf
Dat zoeken doe ik nu in het "veld Klanten", naast die naam staat een opvolgend cijfer
Dit cijfer vul ik in op K2 in het "veld Factuur" in en komt de naam en adres gegevens op de juiste plek te staan

De vraag is of ik in het "veld Klanten" naar de naam kan zoeken, zonder dat ik schakel tussen Klanten en Factuur
open office 4.1.1 windows 7 home
Flexon
 
Berichten: 8
Geregistreerd: do sep 03, 2015 11:57 pm

Re: Zoek functie in ander veld bij factuur

Berichtdoor RPG » vr nov 09, 2018 1:41 pm

Flexon schreef:Een keuzelijst is niet wat ik wil.
Een listbox is zo klein te maken dat je maar een enkele naam ziet. Je moet de eigenschappen goed aanpassen anders heb je kans dat je ongewenst gegevens veranderd. Een keuzelijst is wat anders dan wat je krijgt met geldigheid.

Romke
LibreOffice 6.3.3.2.0 op openSUSE Leap 15.1
RPG
 
Berichten: 4093
Geregistreerd: wo apr 15, 2009 1:01 am
Woonplaats: Apeldoorn, Nederland


Keer terug naar Calc

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers. en 1 gast