Problem with Formulae

Bespreek het rekenblad

Problem with Formulae

Berichtdoor Mondriaan » do apr 21, 2016 1:14 pm

I am a big fan of the game morrowind and i make use of a map grid in OO Calc, the original grid is not mine but the original maker of the grid is Jonathan D. Wells
:bravo: . This grid is original made in xls format but i make a OO Calc from it. Now i will try to explain where i am struggeling with. I use in the horizontal row a formula =TEKST.SAMENVOEGEN(C1;",";$A2) (Dutch formula for CONCATENATE()), in the first row there are numbers in this case from -19 to 0 and then from 0 up =SOM(B1+1), downwards it goes with =SOM(A2-1), now for the Concatenate, when appying it on the horizontal row it works fine (-19,28) (-18,28) and so on but when using the TEKST.SAMENVOEGEN($B1;",";A2) formula on the vertical column i get in the first instance an correct value (in this case -20,28) but for all the other instances -20,28,27 and then -20,28,27,26. I have to add often a new column in front of it and then i get this problem.

Thanks You
Apache OpenOffice 4.1.2
Mondriaan
 
Berichten: 7
Geregistreerd: do apr 21, 2016 12:48 pm

Re: Problem with Formulae

Berichtdoor eremmel » do apr 21, 2016 3:32 pm

Mr Mondriaan,
Als u liever op het Engelse forum most mag dat. Maar ik neem aan dat Nederlands ook goed is. Er is een optie in AOO die aangeeft of referenties aangepast moeten worden als er aangrenzend een kolom of rij wordt toegevoegd. Deze kunt u vinden via Menu (Nu wel in Engels want ik heb geen NL-gebruikersinterface):
Tools (Extra) -> Options -> OpenOffice Calc -> General -> Checkbox 'Expand references when new col/rows are inserted'.
Door deze optie niet aan te zetten voorkomt u de problemen die u beschrijft (hoop ik).
W10: LO 7.0.0.3 (x64)
Het is Microsoft marketing die laat geloven dat computers geschikt zijn voor niet technici
eremmel
 
Berichten: 642
Geregistreerd: di sep 01, 2009 10:11 am
Woonplaats: Barneveld, Nederland

Re: Problem with Formulae

Berichtdoor Mondriaan » do apr 21, 2016 4:02 pm

Oke bedankt ik ga het direct toepassen.
Apache OpenOffice 4.1.2
Mondriaan
 
Berichten: 7
Geregistreerd: do apr 21, 2016 12:48 pm

Re: Problem with Formulae

Berichtdoor Mondriaan » do apr 21, 2016 4:17 pm

Bedankt voor de reactie maar het probleem blijft bestaan, tevens stond het vakje in de opties ook niet aangevinkt.
Apache OpenOffice 4.1.2
Mondriaan
 
Berichten: 7
Geregistreerd: do apr 21, 2016 12:48 pm

Re: Problem with Formulae

Berichtdoor eremmel » do apr 21, 2016 5:08 pm

Kun je een voorbeeld plaatsen en dan de sheet kopiëren en op de kopie de actie doen waarmee je problemen hebt.
Kunnen we e.e.a. beter bekijken.
W10: LO 7.0.0.3 (x64)
Het is Microsoft marketing die laat geloven dat computers geschikt zijn voor niet technici
eremmel
 
Berichten: 642
Geregistreerd: di sep 01, 2009 10:11 am
Woonplaats: Barneveld, Nederland

Re: Problem with Formulae

Berichtdoor Mondriaan » do apr 21, 2016 6:23 pm

Dit is het resultaat wat ik krijg, horizontaal geplakte formules werken goed maar de verticale niet :knock:
Bijlagen
Morrowind2.ods
(33.19 KiB) 51 keer gedownload
Morrowind6.jpg
Apache OpenOffice 4.1.2
Mondriaan
 
Berichten: 7
Geregistreerd: do apr 21, 2016 12:48 pm

Re: Problem with Formulae

Berichtdoor RPG » do apr 21, 2016 6:58 pm

Hallo

Ik weet niet of ik het probleem goed begrijp maar het lijkt goed te gaan als ik de volgende formule gebruik.
Code: Selecteer alles   UitklappenInklappen
=CONCATENATE(B$1&","&A2)
Je kunt natuurlijk ook overal B1 in typen in plaats van naar beneden trekken.

Lees in de help file over relatieve en absolute verwijzingen.

Romke
LibreOffice 6.4.4.2.0 op openSUSE Leap 15.1
RPG
 
Berichten: 4215
Geregistreerd: wo apr 15, 2009 1:01 am
Woonplaats: Apeldoorn, Nederland

Re: Problem with Formulae

Berichtdoor Mondriaan » do apr 21, 2016 7:34 pm

Super :bravo: dit werkt dankje Romke (en eremmel) voor jullie hulp, hier kan ik mee verder.
Apache OpenOffice 4.1.2
Mondriaan
 
Berichten: 7
Geregistreerd: do apr 21, 2016 12:48 pm

Re: Problem with Formulae

Berichtdoor Alex » do apr 21, 2016 11:48 pm

Als je de operator & gebruikt is TEKST.SAMENVOEGEN gebruiken dubbelop, net als bijvoorbeeld SOM(1+2)...
AOO 4.1.5 & LO 5.0.6 op Windows XP & 7
Alex
 
Berichten: 94
Geregistreerd: do feb 25, 2010 8:46 pm


Keer terug naar Calc

Wie is er online

Gebruikers op dit forum: Google [Bot] en 2 gasten