[Opgelost] Formules niet wijzigen

Bespreek het rekenblad

[Opgelost] Formules niet wijzigen

Berichtdoor Wim87 » do feb 01, 2018 4:23 pm

Beste,

Ik ga proberen om mijn probleem zo goed mogelijk uit te leggen.
Ik gebruik in Calc nu een kolom waarbij ik verwijs naar gegevens van een andere kolom (om een voorbeeld te geven: in kolom B is er een verwijzing naar gegevens van kolom D). Ik vul om de 2 weken een nieuw kolom aan met nieuwe gegevens. Ik zorg ervoor dat de nieuwe kolom telkens kolom D is.
Ik had graag gehad dat de nieuwe gegevens nu in kolom B getoond worden. (de formule in kolom B rij 1 is namelijk '=D1')

Echter, de formule in kolom B ('=D1') verandert mee als de kolom opschuift. (de verwijzing verandert dan naar '=E1'. Ik zou graag hebben dat de formule zich niet aanpast als de gegevens verplaatst worden. En dat de verwijzing ALTIJD naar kolom D gaat. Zodat ik telkens nieuwe gegevens kan toevoegen, terwijl de oudere gegevens mee opschuiven als ik een nieuwe rij invoer.

Hopelijk is het probleem een beetje duidelijk voor jullie.


groeten,
Wim
Laatst bijgewerkt door eremmel op vr feb 02, 2018 11:12 am, in totaal 2 keer bewerkt.
Reden: Verkeerd gekozen icoontje uitgezet.
Wim87
 
Berichten: 4
Geregistreerd: do feb 01, 2018 4:11 pm

Re: Formules niet wijzigen

Berichtdoor eremmel » do feb 01, 2018 5:05 pm

Ha Wim, welkom op het forum!

Je kunt dit oplossen door een indirecte verwijzing te maken.
Bijvoorbeeld in cel B2 gebruik de formule om naar D2 te verwijzen:
=VERSCHUIVING(B2;0;2)
Bovenstaande heeft de voorkeur. Deze formule kun je kopiëren naar B4 etc dan krijg je de waarde van D4 etc.

De volgende formule doet het zelfde:
=INDIRECT("D"&RIJ(B2))
Omdat ik RIJ(B2) heb gebruikt gaat het automatisch goed als je deze formule kopieert naar B3 etc.

TIP:
Als je meerdere keren van B2 naar D2 moet verwijzen in je formule is het nogal onoverzichtelijk. Dit kun je oplossen door een 'Naam' in te voeren:
1 Zorg ervoor dat in B2 staat.
2 menu -> Invoegen -> 'Namen' ->Definiëren (Ctrl-F3)
3 Kies als naam: vanD
4 Vervang toegewezen met: =VERSCHUIVING(B2;0;2)
5 Klik op toevoegen.
 Edit: fout aangepast in stap4 

I.p.v.
=ALS(VERSCHUIVING(B2;0;2)<3;VERSCHUIVING(B2;0;2)*10%;VERSCHUIVING(B2;0;2)+VERSCHUIVING(B2;0;2))
Kun je nu schrijven:
=ALS(vanD<3;vanD*10%;vanD+vanD)
Veel beter leesbaar.

Merk op dat de formule vanD altijd de waarde kiest van de cell die twee posities naar rechts staat.
Dus een betere naam zou zijn tweeVanRechts, maar die is weer zo lang.


Succes,
Erik

P.S.
Heb je Lees dit eerst gelezen?
Daar staat ook het gebruik uitgelegd van de icoontjes (daarom heb ik het door jou gekozen icoontje van je vraag verwijderd).
Is uw vraag beantwoord; pas uw initiële bericht aan: zet er [Opgelost] voor en vink de V aan
LO4.2.8.2 W10 vanwege ORB; AOO4.1.4, LO5.2.5.1,LO5.4.2.2 op W7ESP1 64
Het is Microsoft marketing die laat geloven dat computers geschikt zijn voor niet technici
eremmel
 
Berichten: 577
Geregistreerd: di sep 01, 2009 10:11 am
Woonplaats: Barneveld, Nederland

Re: Formules niet wijzigen

Berichtdoor Wim87 » do feb 01, 2018 5:54 pm

Bedankt voor de reactie. Helaas lost dit mijn probleem niet op. Bij het toevoegen van een volgende kolom verandert de formule. De verwijzing blijft altijd naar dezelfde gegevens gaan, waar ze ook staan. Ik zou echt een formule moeten hebben die ALTIJD een verwijzing maakt naar de inhoud in 'kolom D'. Ook al verplaatsen die gegevens zich naar een andere kolom. Anders gezegd: de verwijzing mag niet naar 'gegevens' gaan, maar naar de inhoud van een bepaalde cel in een kolom (kolom D in dit geval)

groeten,
Wim
Openoffice 4.1.3 Mac OS 10.4
Wim87
 
Berichten: 4
Geregistreerd: do feb 01, 2018 4:11 pm

Re: Formules niet wijzigen

Berichtdoor eremmel » do feb 01, 2018 6:56 pm

Ik neem aan dat je het hebt geprobeerd. Kun je een Calc document als bijlage toevoegen met 'demo' data en de preciese beschrijving geven hoe je alles een kolom opschuift?
Is uw vraag beantwoord; pas uw initiële bericht aan: zet er [Opgelost] voor en vink de V aan
LO4.2.8.2 W10 vanwege ORB; AOO4.1.4, LO5.2.5.1,LO5.4.2.2 op W7ESP1 64
Het is Microsoft marketing die laat geloven dat computers geschikt zijn voor niet technici
eremmel
 
Berichten: 577
Geregistreerd: di sep 01, 2009 10:11 am
Woonplaats: Barneveld, Nederland

Re: Formules niet wijzigen

Berichtdoor Wim87 » do feb 01, 2018 7:33 pm

In bijlage een voorbeeld. Uitleg staat in het werkblad.

Bedankt alvast.

groeten,
WIm
Bijlagen
Example_lijst.ods
(20.47 KiB) 9 keer gedownload
Openoffice 4.1.3 Mac OS 10.4
Wim87
 
Berichten: 4
Geregistreerd: do feb 01, 2018 4:11 pm

Re: Formules niet wijzigen

Berichtdoor eremmel » do feb 01, 2018 10:03 pm

Bedankt voor je goede voorbeeld en beschrijving. Het is nu makkelijk duidelijk te maken wat ik bedoel.
Door gebruik te maken van de functie VERSCHUIVING met een zelfreferentie als anker is het niet zo moeilijk, kijk maar in het document en in de help voor meer informatie over deze functie.
Bijlagen
Example_lijst2.ods
Verwijzing blijft op constant.
(16.26 KiB) 9 keer gedownload
Is uw vraag beantwoord; pas uw initiële bericht aan: zet er [Opgelost] voor en vink de V aan
LO4.2.8.2 W10 vanwege ORB; AOO4.1.4, LO5.2.5.1,LO5.4.2.2 op W7ESP1 64
Het is Microsoft marketing die laat geloven dat computers geschikt zijn voor niet technici
eremmel
 
Berichten: 577
Geregistreerd: di sep 01, 2009 10:11 am
Woonplaats: Barneveld, Nederland

Re: Formules niet wijzigen

Berichtdoor Wim87 » vr feb 02, 2018 9:32 am

Bedankt ! Dat was 'm.
Openoffice 4.1.3 Mac OS 10.4
Wim87
 
Berichten: 4
Geregistreerd: do feb 01, 2018 4:11 pm


Keer terug naar Calc

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers. en 2 gasten