Pagina 1 van 1

xmlhttp

BerichtGeplaatst: di mei 13, 2014 4:49 pm
door wouterm
Onderstaande functie doet her prima in vba onder excel, maar in OO Calc krijg ik er gemixte resultaten mee. Met http://www.google.nl als URL werkt het prima, met http://www.bol.com niet. Ik heb het vermoeden dat het iets te maken heeft met een redirect, maar zou niet weten waarom. Iemand een idee?

Code: Selecteer alles   UitklappenInklappen

Function GetHTML(URL As String) As String
       
    Set objHttp = CreateObject("MSXML2.XmlHttp")
    With objHttp
        .Open "GET", URL, true
        .Send
       
         While .readyState <> 4
            DoEvents
        Wend
       
       
    End With
    GetHTML = objHttp.responsetext
    Set objHttp = Nothing
End Function

Re: xmlhttp

BerichtGeplaatst: di mei 13, 2014 7:12 pm
door RPG
Hallo

Ik denk dat het beter is om op het Engelse forum te zoeken naar de term in createobject. Ik vond drie draden en misschien maakt dat wat duidelijk. Ik heb er geen kennis over.

Wat ik uit twee draden begreep is: Wat heeft dit nu met OOo te maken.

Romke

Re: xmlhttp

BerichtGeplaatst: di mei 13, 2014 7:18 pm
door wouterm
thanks, ik heb het nu ook daar geplaatst.

Wat heeft dit nu met OO te maken.


Als een functie het wel doet onder VBA/Excel, en niet onder OO, ben ik bang dat dat toch aan OO ligt.

Re: xmlhttp

BerichtGeplaatst: di mei 13, 2014 11:51 pm
door RPG
Hallo

wouterm schreef:thanks, ik heb het nu ook daar geplaatst.

Wat heeft dit nu met OO te maken.



Als een functie het wel doet onder VBA/Excel, en niet onder OO, ben ik bang dat dat toch aan OO ligt.
Als iets niet werkt onder OOo dan heeft dat te maken met OOo. Het onderwerp als totaal heeft waarschijnlijk weinig met OOo te maken.

https://forum.openoffice.org/en/forum/v ... 45&t=68374
Ik begrijp het gehele onderwerp niet maar op het Engelse forum wordt/werd er over geschreven.

Het is ook niet zo dat alles wat wel werkt met MSO kan werken met OOo.

Romke