Kleiner dan datum werkt niet in som.als

Weet je niet waar je je bericht moet zetten? Doe het hier

Kleiner dan datum werkt niet in som.als

Berichtdoor Wampie Beukies » ma jul 24, 2017 10:42 am

Hallo,

Bij de volgende formule krijg ik Fout 510: "=SOM.ALS((A3:A20);<$L$3;(C3:C20))"
Deze werkt echter wel goed: "=ALS(A3<$L$3;C3;"")"
en deze ook: "=SOM.ALS((A3:A20);$L$3;(C3:C20))"

Ergens in de combinatie van kleiner dan en som.als gaat er dus iets mis. Ik heb al wat geprobeerd met extra haakjes, maar ik kom er niet uit.

Kan iemand mij vertellen waar dit aan ligt en hoe ik het op kan lossen?

Groetjes,

Wampie
LibreOffice 5.2 op Windows 10
Wampie Beukies
 
Berichten: 1
Geregistreerd: ma jul 24, 2017 10:19 am

Re: Kleiner dan datum werkt niet in som.als

Berichtdoor RPG » ma jul 24, 2017 1:16 pm

Hallo

Persoonlijk heb ik bijna geen idee hoe zulke gecompliceerde functies zoals som.als gebruikt moeten worden. Ik heb mij altijd gericht op het feit hoe kan Calc mij simpel aan een antwoord helpen. Meestal helpt daarbij de pivot table of te wel draaitabel. Soms doe ik ook aan filteren in combinatie met de functie subtotaal. Een andere mogelijkheid zijn de dbase functies in een werkblad. Speciaal filteren of de dbase functies geven je inzicht hoe het filteren van grote hoeveelheden gegevens werken. Het is een manier van leren die veel kleine stapjes maakt en daardoor door beginners beter te begrijpen is.

Wanneer je toch gelijk met zoiets som.als wilt gaan werken zou ik de functie assistent gebruiken. Let er wel op dat de criteria parameter als een string gegeven moet worden. Ook als er gebruik gemaakt wordt van een cel. Op een of andere manier moet er een string van gemaakt worden.

Romke
LibreOffice 6.3.3.2.0 op openSUSE Leap 15.1
RPG
 
Berichten: 4074
Geregistreerd: wo apr 15, 2009 1:01 am
Woonplaats: Apeldoorn, Nederland

Re: Kleiner dan datum werkt niet in som.als

Berichtdoor eremmel » ma jul 24, 2017 4:38 pm

Ik heb even met de functie gespeeld. De conditie van kleiner dan vandaag kan ik zo ingeven: "<2017-7-24", maar als ik een cel referentie er in stop: "<$L$3" werkt het niet. Blijkbaar wordt de referentie binnen een string (de tekst tussen dubbele aanhalingstekens) niet opgelost.
De oplossing is redelijk eenvoudig: Gebruik als conditie "<"&$L$3 nu plak je de datum aan de operator vast.

De help is net even te simpel om je op dit idee te brengen helaas.
W10: LO 6.3.4.2 (x64)
Het is Microsoft marketing die laat geloven dat computers geschikt zijn voor niet technici
eremmel
 
Berichten: 634
Geregistreerd: di sep 01, 2009 10:11 am
Woonplaats: Barneveld, Nederland


Keer terug naar Beginners

Wie is er online

Gebruikers op dit forum: Google [Bot] en 1 gast