automatische backup van database odb wordt niet uitgevoerd

Bespreek het databaseprogramma

automatische backup van database odb wordt niet uitgevoerd

Berichtdoor jovan19 » di dec 27, 2016 12:30 pm

Hallo,
Niettegenstaande ik in Extra/Opties/ Laden/opslaan van Apache OpenOffice 4.1.3. aangevinkt heb dat er "automatisch een reservekopie" (.BAK) moet gemaakt worden lukt dit wel voor bv. een tekstdocument .odt maar niet voor een databasebestand .odb
In de map Johan/AppData/Roaming/OpenOffice/4/user/backup staat alleen een .BAK bestand van een tekstdocument.
Wat ik reeds gedaan heb: de "user"map gewijzigd van naam zodat een nieuw profiel bestand automatisch aangemaakt werd. Ik heb dan een kleine wijziging aangebracht in een tabel van de database en heb deze manueel opgeslaan. Na het sluiten van OpenOffice verschijnt er geen .BAK bestand in bovengenoemde map.
Ik moet er nog aan toevoegen dat bij het vorig profiel de backup's wel gemaakt werden en in die map stonden met als inhoud "0 Kb" ! Ook werden die backups niet overschreven maar stond ik reeds bij .Bak nr 800 en..... Ik heb de backupmap met die .bak dan maar leeggemaakt.
Kan er mij iemand helpen om dit probleem op te lossen ?

O.S.: win10
Apache OpenOffice 4.1.3
O.S.: WINDOWS 10
jovan19
 
Berichten: 4
Geregistreerd: di dec 27, 2016 11:58 am

Re: automatische backup van database odb wordt niet uitgevoe

Berichtdoor RPG » di dec 27, 2016 2:46 pm

Hallo

Uit een kleine test lijkt het inderdaad wel dat er geen backups gemaakt worden voor OpenOffice. Ik heb geen idee of dat een fout is of dat het ergens anders aan ligt. Ondanks het feit dat ik backups en ook de herstel informatie heb aanstaan vertrouw ik toch het meest op het zelf opslaan met control-s.

jovan19 schreef:k moet er nog aan toevoegen dat bij het vorig profiel de backup's wel gemaakt werden en in die map stonden met als inhoud "0 Kb" ! Ook werden die backups niet overschreven maar stond ik reeds bij .Bak nr 800 en..... Ik heb de backupmap met die .bak dan maar leeggemaakt.
Dit lijkt er op dat je LibreOffice gebruikt hebt. Op zich zelf is daar niets mis mee maar ik heb ook de ervaring dat er soms buiten gewoon veel backups gemaakt worden met LibreOffice.

Instellingen die gemaakt zijn voor OpenOffice hebben geen invloed op die van LibreOffice en om gekeerd. Misschien dat bij de eerste keer er wel wat van elkaar overgenomen wordt.

Romke
LibreOffice 6.2.5.2 op openSUSE Leap 15.1
RPG
 
Berichten: 3983
Geregistreerd: wo apr 15, 2009 1:01 am
Woonplaats: Apeldoorn, Nederland

Re: automatische backup van database odb wordt niet uitgevoe

Berichtdoor jovan19 » di dec 27, 2016 3:13 pm

Dag Romke,
Bedankt voor uw snelle reactie. Ik wil wel opmerken dat ik tot nu toe alleen OpenOffice gebruikt heb en geen LibreOffice. Ik heb ondertussen wat verder rondgekeken en heb een item gelezen waaruit ik mogelijk kan opmaken dat dit zou te wijten zijn aan het gebruik van een "embedded database" en verder dat het beter is de "split-database" te gebruiken maar dat begrijp ik voorlopig niet. Ik spit het later wat verder uit....
Johan
Apache OpenOffice 4.1.3
O.S.: WINDOWS 10
jovan19
 
Berichten: 4
Geregistreerd: di dec 27, 2016 11:58 am

Re: automatische backup van database odb wordt niet uitgevoe

Berichtdoor RPG » di dec 27, 2016 3:25 pm

Hallo

FreeHSQLDB v.0.3 (View topic) • Apache OpenOffice Community Forum is een goede beschrijving voor het zelfstandig maken van de database. Als je het doet zorg dat je een kopie hebt.

Ik had ook veel backup bestanden van een niet embedded-database, maar wel bij LibreOffice.

Romke
LibreOffice 6.2.5.2 op openSUSE Leap 15.1
RPG
 
Berichten: 3983
Geregistreerd: wo apr 15, 2009 1:01 am
Woonplaats: Apeldoorn, Nederland

Re: automatische backup van database odb wordt niet uitgevoe

Berichtdoor jovan19 » di dec 27, 2016 7:45 pm

Romke,
Ik ben geen echte I.C.T. 'er, ik zie de omschakeling voorlopig niet zitten....
Toch bedankt voor de tip.
Johan
Apache OpenOffice 4.1.3
O.S.: WINDOWS 10
jovan19
 
Berichten: 4
Geregistreerd: di dec 27, 2016 11:58 am

Re: automatische backup van database odb wordt niet uitgevoe

Berichtdoor RPG » do dec 29, 2016 1:31 am

Hallo

Ik ben ook maar een eenvoudige thuisgebruiker met misschien iets te veel aandacht voor een computer. Wanneer je de database blijft gebruiken als een embedded database dan is het verstandig om toch af en toe een kopie van het bestand te maken. Wat je ook doet het opschonen van de database is soms ook belangrijk.

Code: Selecteer alles   UitklappenInklappen
Checkpoint defrag
Bovenstaande ruimt overbodige rommel op. Het moet ingevoerd in de SQL tool van het databasedocument.

Romke
LibreOffice 6.2.5.2 op openSUSE Leap 15.1
RPG
 
Berichten: 3983
Geregistreerd: wo apr 15, 2009 1:01 am
Woonplaats: Apeldoorn, Nederland

Re: automatische backup van database odb wordt niet uitgevoe

Berichtdoor jovan19 » do dec 29, 2016 11:14 am

Romke,
Dank voor de reactie. Wat het computergebruik betreft is dat bij mij evenzo... Ik gebruik de database voor een kleine vereniging waarvoor ik wat administratie doe. Ik probeer wel zoveel mogelijk pc-problemen zelf op te lossen.
Ik neem af ten toe wel een kopie en dat doe ik dan zo: ik maak een kopie van " naamdb.odb". Is dat voldoende volgens jou ?
Ik probeer ook zeker uw tip voor het opschonen.
Prettig eindejaar !
Johan
Apache OpenOffice 4.1.3
O.S.: WINDOWS 10
jovan19
 
Berichten: 4
Geregistreerd: di dec 27, 2016 11:58 am

Re: automatische backup van database odb wordt niet uitgevoe

Berichtdoor RPG » do dec 29, 2016 12:30 pm

Hallo

Wanneer je het database-document opent en er staat dan "Embedded database" links onder in het venster dan staan alle gegevens in het document. Een kopie maken van dat document is dan voldoende om een volledige backup te hebben.

Romke
LibreOffice 6.2.5.2 op openSUSE Leap 15.1
RPG
 
Berichten: 3983
Geregistreerd: wo apr 15, 2009 1:01 am
Woonplaats: Apeldoorn, Nederland


Keer terug naar Base

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers. en 1 gast

cron