corrupte styles.xml herstellen

Bespreek het presentatieprogramma

corrupte styles.xml herstellen

Berichtdoor millybreak » do jul 01, 2010 11:42 pm

Ik heb een groot document (de wijkkrant) in Impress.
Gisteravond opgeslagen en vandaag willen openen.
Krijg nu melding: "fout in indeling in subdocument styles.xml op positie 2,16540 (rij, kolom)"
en kan het document niet openen.

Ik heb inmiddels de styles.xml kunnen extraheren, en als ik die in FireFox open, krijg ik:
XML-parsefout: dubbel attribuut
Locatie: file:///home/..................../styles.xml
Regelnummer 2, kolom 16541

maar heb geen idee hoe ik die kan corrigeren en vervolgens weer "inpakken" in het odp bestand.

Kan in de Nederlandse en Engelse OO-fora niets vinden. Hoop dat hier iemand me op weg kan helpen, want er voltrekt zich nu een klein drama (krant moet nog af en naar de drukker). :(

Ik gebruik Ubuntu 8.04 / AMD64 en OO 3.0
OpenOffice 3.0 op Ubuntu 8.04 / AMD64 / FireFox & Thunderbird
Avatar gebruiker
millybreak
 
Berichten: 5
Geregistreerd: ma aug 03, 2009 2:19 am

Re: corrupte styles.xml herstellen

Berichtdoor floris v » vr jul 02, 2010 8:51 am

Te late reactie natuurlijk, maar je kunt zo'n beschadigd bestand bewerken met een xml-editor en het dan gewoon weer terugzetten in het zip-bestand en dat dan weer de oorspronkelijke extensie geven. Ik heb wel discussies gezien over dit soort situaties. Soms is er gewoon een teken in het bestand geslopen dat daar niet mag staan omdat het deel uitmaakt van een xml-tag. Hoe dat kan gebeuren weet ik ook niet.
* LibreOffice 5.2.3.3; AOO 4.1.3 op Windows 10
* Heb je de survival guide voor het forum al gelezen?
Avatar gebruiker
floris v
 
Berichten: 1903
Geregistreerd: za apr 11, 2009 3:30 pm
Woonplaats: Apeldoorn, Nederland

Re: corrupte styles.xml herstellen

Berichtdoor millybreak » za jul 03, 2010 12:57 am

Merci.
Heb dat al geprobeerd, maar het bestand is kennelijk te groot voor mijn editors. Heb Bluefish, Screem en een gewone text-editor gebruikt. Hij doet er uren (echt) over om te bladeren, en toen ik eindelijk de juiste positie had bereikt, zag ik niet wat ik daar dan weg moest halen. Heb maar wat geprobeerd te deleten, maar kon toen niet opslaan. Heb het na 6 uur (!) afgebroken, want m'n hele computer bleef hangen.

Inmiddels heb ik de xml van een oude versie van de krant in de "zip" (is het bij mij op Linux niet) geplaatst, en toen kon ik het document weer opstarten, maar ben wel de hele formatting kwijt. Rampje wel wat kleiner geworden!! Maar nog veel werk te doen.

Ik vind dit echter wel een "bug" in Impress; het zou bij het opslaan een waarschuwing moeten geven voor ongeldige tekens in de opmaak of inhoud.
Bovendien weet ik dus nog steeds niet wat er nou niet goed was, en loop dus het risico dat ik het weer doe, bij het herstellen van de opmaak.

Bedankt voor het meedenken in ieder geval! :super:
OpenOffice 3.0 op Ubuntu 8.04 / AMD64 / FireFox & Thunderbird
Avatar gebruiker
millybreak
 
Berichten: 5
Geregistreerd: ma aug 03, 2009 2:19 am


Keer terug naar Impress

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers. en 1 gast