Baseが動きません

Windows

Baseが動きません

投稿記事by Ken-chan » 10月 21st, 2008, 12:37 pm

よろしくお願いします。

OSはWindows Vista SP1です。先日OOo3.0をインストールしました(OOo_3.0.0_Win32Intel_install_wJRE_ja.exe)。
他のアプリケーションは問題なく動作するのですが、Baseが使えません。最初に出るデータベースウィザードの「完了」を押しても何の反応もなく、先に進めないのです。
一度、アンインストール→インストールをしましたが、同じでした。
同じインストールファイルを別のPC(WindowsXP)にインストールしたものは、問題なく使えました。

VIstaをお使いの方、このような問題はありませんか? アドバイスなどありましたら、お願いします。
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 21st, 2008, 2:54 pm

Hi Ken-chan,

Ken-chan さんが書きました:OSはWindows Vista SP1です。先日OOo3.0をインストールしました(OOo_3.0.0_Win32Intel_install_wJRE_ja.exe)。
他のアプリケーションは問題なく動作するのですが、Baseが使えません。最初に出るデータベースウィザードの「完了」を押しても何の反応もなく、先に進めないのです。


Windows Vista, OpenOffice.org 3.0.0 で検証してみました。
以下のスクリーンショットが、「完了」を押しても何の反応もないウィザードのダイアログですか?

ooo300basewizard.jpg
データベースウィザード
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 21st, 2008, 3:06 pm

:P khiranoさん、返信ありがとうございます。

>>「完了」を押しても何の反応もないウィザードのダイアログ

そうです。ステップ2の「保存して続行」には進めますが、「完了」ボタンが反応しません。
「新規作成」、「開く」、「接続」、どれを選んでも反応なしです。
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 21st, 2008, 6:45 pm

Hi Ken-chan,

Ken-chan さんが書きました:ステップ2の「保存して続行」には進めますが、「完了」ボタンが反応しません。
「新規作成」、「開く」、「接続」、どれを選んでも反応なしです。

Javaをチェックしてみましょうか。

ツール-->オプション-->OpenOffice.org-->Java を選んでください。

Javaのオプション ダイアログはどのようになっていますか?
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 22nd, 2008, 10:25 am

おはようございます。 昨日はお返事できなくて、すみませんでした。

えっと、Javaですね…
「Java Runtime環境を使用」にチェックが入っていて、
Java Runtime環境(JRE)はすでにインストールされています: とあります。

その下のボックスは、

ベンダー   Sun Microsystems Inc.
バージョン  1.6.0_07
機能  (空欄)

です。
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 22nd, 2008, 11:24 am

Ken-chan さんが書きました:「Java Runtime環境を使用」にチェックが入っていて、
Java Runtime環境(JRE)はすでにインストールされています: とあります。

その下のボックスは、

ベンダー   Sun Microsystems Inc.
バージョン  1.6.0_07
機能  (空欄)


その左にある丸いラジオボタンにはチェックが入っていますか?

ooo3javaoptiondialog.jpg
Java オプション ダイアログ
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 22nd, 2008, 11:54 am

khirano さんが書きました:
その左にある丸いラジオボタンにはチェックが入っていますか?



はい、チェックは入っています。
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 22nd, 2008, 12:12 pm

Hi Ken-chan,

Ken-chan さんが書きました:はい、チェックは入っています。

Good! JavaはOKですね。

では、お手数ですが、「完了」ボタンが反応しないデータベースウィザードのスクリーンショットをいただけますか。

よろしくお願いいたします。
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 23rd, 2008, 10:20 am

おはようございます。
またまた、返事が遅くなりすみませんです。
なんか、他にも不調な所(OOo以外)が見つかって、ちょっと大変でした。

さて、ウィザードはこんな感じです。
「最近使用されたもの」の「biblio.odb」は、Calc→データソース で開いたものです。
添付ファイル
image003.JPG
image004.JPG
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 23rd, 2008, 12:09 pm

Hi Ken-chan,

スクリーンショットを見る限り「完了」ボタンはアクティブになっていますね。

その「完了」ボタンをクリックしても進まないということですね?
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 23rd, 2008, 12:28 pm

:P khiranoさん、ありがとうございます。

khirano さんが書きました:
その「完了」ボタンをクリックしても進まないということですね?


はい。クリックすると、ボタンが押されたときの反応はありますが、画面は変わらず進めません。何度押しても同じです。
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 23rd, 2008, 2:21 pm

Hi Ken-chan,

こまった Vista 君ですね。うちの Vista 君は、3.0.0 Base と相性がいいのか、動いています。
;)
さて、Ken-chan の Vista マシンについてうかがいます。

OpenOffice.org 3.0.0 をインストールする前に、3.0.0 ベータ版とかリリース候補をインストールされたことはありますか。

OpenOffice.org 2.x.x は使っていましたか。

OpenOffice.org 2 の Base は動いていましたか。
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 23rd, 2008, 2:43 pm

Vista君、2ヶ月前に買ったばかりなんですが…

問題のPCでは、OOo2は使っていません。
OOo3.0は、ここの掲示板にあったリリース候補1をインストールして使っていました。
そのときは、Baseも動いていました。

リリース候補を使い続けていてもいいんですかね?
正式発表のものと違いはあるのでしょうか?
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 23rd, 2008, 4:08 pm

Hi Ken-chan,

Ken-chan さんが書きました:「最近使用されたもの」の「biblio.odb」は、Calc→データソース で開いたものです。

これをどのようにやったのか詳しく教えていただけますか?
「Calc→データソース で開いた」というところをもう少し説明してください。
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 23rd, 2008, 5:56 pm

Calcの「編集」→「データソース」で、上部にデータベースが表示されますよね。

「Bibliography」というのがあったので、「テーブル」→「Biblio」と進んだら、データベースが表示されました。
さらに「Biblio」を右クリックして「データベースファイルを編集」を選ぶと、Baseが起動して編集可能な状態になるんです。

ただ、その画面の「ファイル」からでも、作成、保存等はできません。選ぶとOOo自体が終了してしまいます。
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 23rd, 2008, 8:41 pm

Calc --> データソースの件、了解しました。
ありがとうございます。

次のことを教えていただけますか。

C:\Program Files\ 以下にある、OpenOffice.org 関連のフォルダ名を教えてください。

C:\Users\ユーザー名\AppData\Roaming\ 以下にある、OpenOffice.org 関連のフォルダ名を教えてください。

また、エクスプローラで検索して biblio.* というファイルがどのフォルダのなかにあるか教えてください。
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 24th, 2008, 12:30 am

khiranoさん、貴重なお時間を割いていただいて、本当にありがとうございます。 :)

>>C:\Program Files\ 以下にある、OpenOffice.org 関連のフォルダ名
C:\Program Files\OpenOffice.org 3 と、
C:\Program Files\OpenOffice.org 3.0(ja) Installation Files があります。

>>C:\Users\ユーザー名\AppData\Roaming\ 以下にある、OpenOffice.org 関連のフォルダ名
C:\Users\ユーザー名\AppData\Roaming\OpenOffice.org と、
C:\Users\ユーザー名\AppData\Roaming\OpenOffice.org3 の2つです。

>>biblio.* というファイル
C:\Users\ユーザー名\AppData\Roaming\OpenOffice.org3\user\database\biblio.odb でした。
直接、ファイルを開けました。


もしかして…
セキュリティソフトの問題? と思ったので検証してみますが、可能性ありますか?
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by khirano » 10月 24th, 2008, 9:49 am

Hi Ken-chan, Good Morning!

では、OpenOffice.org 3.0.0 をアンインストールしてください。

アンインストール完了後、
Ken-chan さんが書きました:C:\Program Files\OpenOffice.org 3 と、
C:\Program Files\OpenOffice.org 3.0(ja) Installation Files があります。
C:\Users\ユーザー名\AppData\Roaming\OpenOffice.org と、
C:\Users\ユーザー名\AppData\Roaming\OpenOffice.org3 の2つです。

これらのフォルダがどうなったか教えてください。
Apache OpenOffice 4.0 on Windows Vista
アバター
khirano
 
記事: 685
登録日時: 5月 25th, 2008, 12:15 pm
お住まい: Doya-cho, Ichinoseki-shi, Iwate-ken, Japan

Re: Baseが動きません

投稿記事by Ken-chan » 10月 24th, 2008, 11:55 am

:P おはようございます。
セキュリティソフトですが、見てみたら一部制限がかかっているところがありました。
設定を変えましたが、まだ進展はありません。

アンインストールの件、やってみて後ほどご報告します。

なんか、
Windowsの「データ実行防止」が絡んでいる予感…
調査中です。
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm

Re: Baseが動きません

投稿記事by Ken-chan » 10月 26th, 2008, 12:48 pm

PCの設定に問題があったみたいで、いろいろ不調が出てきてしまいました。 :|
「システムの復元」をしてみましたが、直らないのでリカバリしました。

OOoはこれからインストールしますが、多分大丈夫。使えると思います。
khiranoさん、お手数をおかけして、申し訳ありませんでした。また、分からないことがあったら、質問させてください。

ありがとうございました。

Ken-chan
Ken-chan
 
記事: 12
登録日時: 10月 21st, 2008, 12:06 pm


Return to Windows

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]