MacOSX+OpenOffice.org3の不具合報告

Mac OSX

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by NakataMaho » 1月 7th, 2009, 6:24 pm

まつもとよしかず さんが書きました: NakataMaho さんの投稿を参考にして、Finder で default.css の入れ替え作業を行いましたが、どうもフォントの見映えが今一つなので、
http://ja.wikipedia.org/wiki/ヒラギノ
を参考にして、
OpenOffice.org.app/Contents/basis-link/help/ja/default.css
に記載されている Osaka を、「ヒラギノ角ゴ Pro W3」と「Osaka-等幅」に変更してみました。


ちょっと遅くなりましたが、vcl98には入らなかった...のです。残念です。我々が正しい、直し方を
知らなかっただけですが。とりあえず表示はされますので、とりあえずここまで。次回はよい実装を目指しましょう。
NakataMaho
 
記事: 177
登録日時: 6月 13th, 2008, 11:19 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by HPLovecraft » 1月 14th, 2009, 4:23 pm

はじめまして。
小説を書こうと思いOOを導入してみましたが、
縦書きの設定でルビを降ると行が膨らんでしまいます[*画像]。

それとファイル名に2バイト文字があると
「XXX(ファイル名).(拡張子)は、~/home/...(ファイルのあるはずのアドレス)にありません。」
と警告が出て展開出来ません。
ファイル名を半角英数字に変えると普通に展開出来ます。

前者は特に困っているので何とかならないでしょうか?
各使用Ver.は、OSは10.5.6(Intel)でOOはDEV300m38(Build:9377)です。
添付ファイル
ooo.jpg
ルビ
HPLovecraft
 
記事: 2
登録日時: 12月 14th, 2008, 3:30 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by まつもとよしかず » 1月 15th, 2009, 3:48 am

 少々面倒ですが、ルビの必要の無い文字に空白のルビを振ることにより解決出来ます。この仕様は是非改善してもらいたいと思います。NeoOffice-2.2.5-Patch-6-PowerPC でも同様の現象が発生します。
 ファイル名に 2 バイト文字があると警告が出て展開出来ない件は、OOo_3.0.0_MacOSXPPC_install_ja.dmg や NeoOffice-2.2.5-Patch-6-PowerPC で試してみましたが、こちらでは再現出来ませんでした。特に問題無く読み書き出来ます。
 Mac OS X 10.5.6 + Power Mac G5 の環境でテストしました。
アバター
まつもとよしかず
 
記事: 16
登録日時: 11月 6th, 2008, 7:01 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by NakataMaho » 1月 15th, 2009, 4:53 pm

HPLovecraft さんが書きました:
それとファイル名に2バイト文字があると
「XXX(ファイル名).(拡張子)は、~/home/...(ファイルのあるはずのアドレス)にありません。」
と警告が出て展開出来ません。
ファイル名を半角英数字に変えると普通に展開出来ます。

thanks!!
こちらでもやってみました。
http://ooopackages.good-day.net/pub/Ope ... all_ja.dmg
MacOSX Tiger PPC
です。
結果、再現できませんでした。
* インストール
* Writerを立ち上げる
* あいうえおと入力
* 名前をつけて保存、で、無題 1.odtとして(デフォルト)保存
* 無題 1.odtを右クリック、開く、とした。
開けました。
NakataMaho
 
記事: 177
登録日時: 6月 13th, 2008, 11:19 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by NakataMaho » 1月 17th, 2009, 9:09 am

imony さんが書きました:OOoをいつも使わせていただいております。
既に報告されているかもしれませんが、OOo3ではパス中に日本語が入ったファイルが認識されません。
ファイルを開こうとすると「ファイルが無い」とメッセージがでます。
この現象が見られる使用環境は
macbook air 1.86GHz
OS10.5.6
です。
海外のフォーラムでは中国語とドイツ語(ウムラウト)で同じ現象が報告されています。

よろしくお願いいたします。


二点。
* issueもありました。
http://www.openoffice.org/issues/show_bug.cgi?id=97664
scandinavianなんですがいまいち再現できてなさそうです。

* 具体的にどんなファイル名だと認識されないのか教えていただけますか。
NakataMaho
 
記事: 177
登録日時: 6月 13th, 2008, 11:19 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by HPLovecraft » 1月 17th, 2009, 3:56 pm

お返事ありがとうございます。
ルビの件に関しては目から鱗でした。
なるほど、ひとまずはこの方法で対処します。

ファイル名の方ですが、とりあえず文書ドキュメント(word)でいろいろ試してみました。
・適当な文章を 無題.odt で保存→ ??.odt となるが展開可。
・上記の ??.odt を 無題.odt に戻す→ /Users/〜/無題.odtは ありません。 の警告が出て展開不可。
 (他の2バイト文字を使用した名も同様に展開不可、ファイル名を半角英数字に戻すと展開可)
・他の2,3のファイル形式でも試してみましたが同様の結果。

このような感じでした。
しばらくはやはり半角英数字のみの使用で対処という感じですかね。
HPLovecraft
 
記事: 2
登録日時: 12月 14th, 2008, 3:30 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by yuko » 1月 19th, 2009, 12:00 pm

HPLovecraft さんが書きました:縦書きの設定でルビを降ると行が膨らんでしまいます[*画像]。


OOo 2.0 で、縦書きの原稿用紙の場合に、ルビがずれるというバグ (56820) が既に登録されていまして、
同様の問題かもしれませんが、バグを登録しました。ご確認くださいませ。
http://www.openoffice.org/issues/show_bug.cgi?id=98209

HPLovecraft さんが書きました:それとファイル名に2バイト文字があると
「XXX(ファイル名).(拡張子)は、~/home/...(ファイルのあるはずのアドレス)にありません。」
と警告が出て展開出来ません。
ファイル名を半角英数字に変えると普通に展開出来ます。


こちらは、私の環境 (Mac OS X 10.5.6) では再現しませんでした。
ファイルの保存時に問題があるのではないかと推測しているのですが...
実は、OOo 3.0 では発生せず、StarSuite 9 のみで発生する現象があります。
ファイル名がひらがなまたはカタカナで、濁点または半濁点が含まれていると、点または半濁点が
離れたファイル名でファイルが生成されます。たとえば、「が」だと「か゛」のようになります。
HPLovecraft さんの環境では、ひらがな、カタカナ、漢字も日本語がファイル名に入っていると
うまくいかないのでしょうか? ご不便かと思いますが、しばらくは半角英数字で回避していただくしかないと思います。
yuko
 
記事: 7
登録日時: 11月 4th, 2008, 3:56 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by NakataMaho » 1月 20th, 2009, 12:20 pm

HPLovecraft さんが書きました:ファイル名の方ですが、とりあえず文書ドキュメント(word)でいろいろ試してみました。
・適当な文章を 無題.odt で保存→ ??.odt となるが展開可。
・上記の ??.odt を 無題.odt に戻す→ /Users/〜/無題.odtは ありません。 の警告が出て展開不可。
 (他の2バイト文字を使用した名も同様に展開不可、ファイル名を半角英数字に戻すと展開可)
・他の2,3のファイル形式でも試してみましたが同様の結果。


どんなファイルシステムをつかっていらっしゃいますか。
つまり、HPLovecraftさんがMacでどんなディスクを保存用につかっていらっしゃるのか、です。
普通に買ってきたままですか。何か外付けですか。
HFS+? HFS? case sensitive?
またはネットワークごし?
そこらへんに原因があるのかもしれません。
NakataMaho
 
記事: 177
登録日時: 6月 13th, 2008, 11:19 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by NakataMaho » 1月 20th, 2009, 12:24 pm

yuko さんが書きました:こちらは、私の環境 (Mac OS X 10.5.6) では再現しませんでした。
ファイルの保存時に問題があるのではないかと推測しているのですが...
実は、OOo 3.0 では発生せず、StarSuite 9 のみで発生する現象があります。
ファイル名がひらがなまたはカタカナで、濁点または半濁点が含まれていると、点または半濁点が
離れたファイル名でファイルが生成されます。たとえば、「が」だと「か゛」のようになります。
HPLovecraft さんの環境では、ひらがな、カタカナ、漢字も日本語がファイル名に入っていると
うまくいかないのでしょうか? ご不便かと思いますが、しばらくは半角英数字で回避していただくしかないと思います。


UNICODEに対してはシロウトなのですが...
MacのUNICODEの取扱いの違いによるようです。「が」は「か」と「"」の合字で表されるということのようです。
これをNormalizationというようです。その取扱いの違いではないでしょうか。それにしてもOOo3.0とSS9での挙動の
違いは気になります。OOo3.0=OOO300_m9で、SS9はどれに相当するのでしょうかね。それでgsl/vclまわりが
書き換わっているのかもしれません。

http://d.hatena.ne.jp/KoshianX/20080731/1217519539
http://www.unicode.org/reports/tr15/
NakataMaho
 
記事: 177
登録日時: 6月 13th, 2008, 11:19 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by yuko » 1月 22nd, 2009, 7:59 pm

yuko さんが書きました:
HPLovecraft さんが書きました:縦書きの設定でルビを降ると行が膨らんでしまいます[*画像]。

OOo 2.0 で、縦書きの原稿用紙の場合に、ルビがずれるというバグ (56820) が既に登録されていまして、
同様の問題かもしれませんが、バグを登録しました。ご確認くださいませ。
http://www.openoffice.org/issues/show_bug.cgi?id=98209


登録したバグに対してコメントをいただきました。
表示を改善する方法があるそうで、以下に記載があります。

http://openoffice-ja.org/wiki/%E5%88%A9 ... Features/2
http://jsdp2007.net/wiki/%E7%B8%A6%E6%9 ... 9%E5%96%84

うまくいくようですので、是非試してみてください。

登録したバグ 98209 は、Issue 85422 の重複バグとしてクローズしました。
yuko
 
記事: 7
登録日時: 11月 4th, 2008, 3:56 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by まつもとよしかず » 1月 24th, 2009, 7:05 pm

IPA
国際標準文書フォーマットの日本語機能拡張
操作手順書_縦書き時における振り仮名

http://jsdp2007.net/mediawiki/images/b/bf/操作手順書_縦書き時における振り仮名.pdf

 この文書が非常に役に立ちます。
 但し、

OOo_3.0.1rc2_MacOSXPowerPC_install_ja.dmg
OOo_Dev_DEV300_m39_MacOSXPowerPC_install_ja.dmg

どちらも機能の実装が間に合っていない様で、文書に書かれている機能がそのまま実現出来れば、大変素晴しいものになると思います。
アバター
まつもとよしかず
 
記事: 16
登録日時: 11月 6th, 2008, 7:01 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by まつもとよしかず » 2月 3rd, 2009, 8:26 pm

OOo_Dev_DEV300_m40_MacOSXPowerPC_install_ja.dmg
OOo_Dev_DEV300_m41_MacOSXPowerPC_install_ja.dmg

 eMac + Mac OS X 10.4.11 の環境にインストールしてみましたが、どちらもヘルプが正常に表示されず、縦書き時における振り仮名機能も十分とは言えない状態です。

http://www.apple.com/jp/iwork/systemrequirements.html

 iWork ’09 システム条件を見ると、「iWork ’08と同様に、iWork ’09では中国語、日本語、韓国語の縦書き入力などには対応していません。」と記載されており、OpenOffice.org3 への期待が増々高まっていると思います。
アバター
まつもとよしかず
 
記事: 16
登録日時: 11月 6th, 2008, 7:01 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by まつもとよしかず » 2月 16th, 2009, 8:22 pm

OOo_3.0.1_MacOSXPPC_install_ja.dmg

 eMac + Mac OS X 10.4.11 の環境にインストールしてみましたが、ヘルプが正常に表示されず、縦書き時における振り仮名機能も十分とは言えない状態です。OpenOffice.org 3.1 日本語版リリースまでには何とか解決されることを希望します。
アバター
まつもとよしかず
 
記事: 16
登録日時: 11月 6th, 2008, 7:01 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by NakataMaho » 2月 17th, 2009, 11:42 am

まつもとよしかず さんが書きました:OOo_3.0.1_MacOSXPPC_install_ja.dmg

 eMac + Mac OS X 10.4.11 の環境にインストールしてみましたが、ヘルプが正常に表示されず、縦書き時における振り仮名機能も十分とは言えない状態です。OpenOffice.org 3.1 日本語版リリースまでには何とか解決されることを希望します。


まつもとさん、このスレッドにある私の記事を読んでいただけませんか。
ヘルプに付いてはすでに書きました。
NakataMaho
 
記事: 177
登録日時: 6月 13th, 2008, 11:19 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by iDefJP_96 » 2月 22nd, 2009, 7:50 pm

はじめまして。

以下の環境でOpenOffice.org 3.0.1 : Writerの原稿用紙スタイル(縦書き)を利用すると、
行の中心が著しくズレる模様です。

OS : MacOSX 10.4.11
Hardware : PowerPC
Software : OpenOffice.org 3.0.1 for PowerPC
使用フォント : ヒラギノ明朝 Pro W3(※ヒラギノであれば、明朝でもゴシック体でも状況が再現されました)

原稿用紙スタイルの設定は下記URLにおいて掲示されている手順通りに実施しています。
http://doudesyo.cocolog-nifty.com/blog/2008/09/openofficeosx-9.html

具体的な状況を以下のとおり図で示します。

ピクチャ 2.png
Openoffice.org : ver3.0.1における原稿用紙スタイル。
行の中心、特に句読点のズレが著しいのがお判りいただけますでしょうか。

ピクチャ 3.png
Openoffice.org : ver3.0.0における原稿用紙スタイルです。
このバージョンでは、ほとんど縦軸のズレは気になりません。


ごらんのとおり、原稿書きにはかなり厳しい状況です。
他の環境でも同様の現象が発生しているのでしょうか?
最後に編集したユーザー iDefJP_96 [ 5月 10th, 2009, 1:20 am ], 累計 2 回
iDefJP_96
 
記事: 6
登録日時: 2月 22nd, 2009, 6:55 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by まつもとよしかず » 2月 26th, 2009, 11:47 pm

OOo_Dev_OOO310_m1_MacOSXPowerPC_install_ja.dmg

 eMac + Mac OS X 10.4.11 の環境で実行してみましたが、私の願いは今回も満たされることはありませんでした。
 私としては、このコミュニティに少しでも貢献するために、自分なりに小さな努力を重ねているつもりなのですが、ひょっとして大迷惑をかけているのでしょうか。もしそうであれば、直ちにこのコミュニティから引退しますので、どうか子供でも分かりやすい表現で御指摘下さい。短い間でしたが御世話になりました。有難うございます。
アバター
まつもとよしかず
 
記事: 16
登録日時: 11月 6th, 2008, 7:01 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by iDefJP_96 » 2月 27th, 2009, 2:59 am

まつもとよしかず さんが書きました:OOo_Dev_OOO310_m1_MacOSXPowerPC_install_ja.dmg

 eMac + Mac OS X 10.4.11 の環境で実行してみましたが、私の願いは今回も満たされることはありませんでした。



まつもとよしかずさん、こんばんは。

よろしければ、まつもとさんが今回はどのような操作を実行されて、どのような結果となったのか、
もうすこしだけ、明確にご教示願えませんでしょうか :D
私の投稿の下にコメントをつけていらしているので、なんとなくコメントの流れを推測できるのですが
ひょっとしたら、他の閲覧されている方にはやや伝わりにくいかもしれません。
私もちょっと "?" でした。

せっかくコメントしていただいたのに、なんだかケチをつけるようで大変恐縮ですが、
もしご返信いただけるようでしたら、上記の旨ご一考いただけたらとても助かります。
よろしくおねがいいたします。

# どうか、まつもとさんがお気を悪くされませんように。
iDefJP_96
 
記事: 6
登録日時: 2月 22nd, 2009, 6:55 pm

Command + Spaceでの入力切り替えが動作しない (Dev_OOO310_m7_MacOSXIntel)

投稿記事by ymmt » 3月 27th, 2009, 2:34 am

OOo_Dev_OOO310_m7_MacOSXIntel_install_ja.dmg
Mac OS X 10.4.11
にて、

Command + Spaceでの入力切り替えが動作しない様です。
ymmt
 
記事: 2
登録日時: 6月 18th, 2008, 12:24 am

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by tomcat » 4月 3rd, 2009, 2:33 pm

お教え下さい。
DrawでA3の書類を作成したく、ページ設定で書式をA3サイズに設定し書類を作成しました。
しかし、いざA3でプリントしようとすると勝手に書類が縮小されてしまいます。これは、印刷プレビューでも確認出来、確かに書類サイズはA3になっているのですが、周囲のマージンが大きく取られ、書類内容は縮小されたようになっております。
これは、私の設定法が悪いのでしょうか?それとも、バグでしょうか?
因みに、NeoOfficeではDrawで同様の操作でA3出力が可能です。
よろしく、ご教授願います。
tomcat
 
記事: 7
登録日時: 4月 3rd, 2009, 12:53 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by TatsuoIshii » 4月 16th, 2009, 4:31 pm

バグではないでしょうか.こちらでは,
Mac OS 10.5.5 (Intel) OO3.0.1 Canon LBP870 or LBP5900
の環境で,Impress書類がA4の紙に対してB5位のサイズで印刷されます.
印刷プレビューで見てもそういう状態です.
仕方がないので,LinuxのOOに転送して印刷しています.
問題の解決にならなくて済みません.
TatsuoIshii
 
記事: 3
登録日時: 4月 10th, 2009, 1:14 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by iDefJP_96 » 5月 9th, 2009, 9:37 pm

iDefJP_96 さんが書きました:以下の環境でOpenOffice.org 3.0.1 : Writerの原稿用紙スタイル(縦書き)を利用すると、
行の中心が著しくズレる模様です。


先日リリースされたOOo3.1.0 [310m11(build 9399)]で、件の行の中心がズレる現象は修正された模様です。

よかったよかった :D

# 補記:この投稿や過去の投稿で、3.0.1のことを3.1と表現してしまっていたので修正しました。
最後に編集したユーザー iDefJP_96 [ 5月 10th, 2009, 1:23 am ], 累計 2 回
iDefJP_96
 
記事: 6
登録日時: 2月 22nd, 2009, 6:55 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by morich » 5月 10th, 2009, 1:10 am

OOo3.1リリースおめでとうございます。 :D

さて早速使わせていただきましたが、PDFエクスポートがうまくいかないようです。
PDF書類を作成して、開こうとすると文字や図もなにも表示されません。。。ただただ真っ白です。

(実は3.0.0のときは正常にエクスポートできましたが、3.0.1以降からうまくいきません。。。)


adobe readerの不具合かな?とも思いましたが、そうでもなさそうです。
同じ症状の方はいませんか?

私の環境は、MacBook 10.5.6

最後になりましたが、すでにこの手の報告がなされ、解決済みでしたら大変申し訳ございません。ご迷惑をお詫び致します。
morich
 
記事: 6
登録日時: 2月 7th, 2009, 3:13 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by tomcat » 5月 11th, 2009, 4:36 pm

OOo3.1を早速インストールしました。
文章ドキュメントで、縦書き書類作成時に文字の左側が削れたように表示されます。
先に示されている行の中心がずれている問題と同じかと思われますが、皆さんは如何でしょうか?
tomcat
 
記事: 7
登録日時: 4月 3rd, 2009, 12:53 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by iDefJP_96 » 5月 11th, 2009, 7:42 pm

tomcat さんが書きました:文章ドキュメントで、縦書き書類作成時に文字の左側が削れたように表示されます。
先に示されている行の中心がずれている問題と同じかと思われますが、皆さんは如何でしょうか?


tomcatさん、こんにちは。

件の問題は、当方の環境では再現しません。当方PowerPC向けのOOo.Ver3.1.0をOS10.4.11で利用しています。
tomcatさんがもしもintel版のOOo.Ver3.1.0を利用されているのであれば、intel版固有の問題かとも推測されますが…。それともOS10.5.xxだから、なのでしょうか…。

念のため画像をアップしておきます。拡大率は78%でスクリーンショットを撮りましたが、特に極小サイズにしないかぎり、やはり文字の欠けなどは発生しませんでした。また、ヒラギノフォントに限っての確認の結果ですが、明朝体でもゴシック体でも特に問題はなさそうです。
添付ファイル
ピクチャ 4.png
特に問題なさそうなんですが……。
iDefJP_96
 
記事: 6
登録日時: 2月 22nd, 2009, 6:55 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by tomcat » 5月 11th, 2009, 8:07 pm

iDefJP_96さん

ご返信頂き、有り難うございます。ご教授頂いた通り、原稿用紙の書式のように文字数行数を指定して縦書き入力をいたしますと、正常に表示されました。しかし、書類サイズは何れにおいても、標準の文字数を使って縦書き入力をすると、左側が欠けてしまいます。以前からこのような縦書き書類の表示のバグが有ったようなことも見ましたが、まだ修正されていないのでしょうか?因みに私の環境はintel Mac+OS10.5です。よろしくご教授願います。
tomcat
 
記事: 7
登録日時: 4月 3rd, 2009, 12:53 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by iDefJP_96 » 5月 11th, 2009, 8:31 pm

tomcat さんが書きました:標準の文字数を使って縦書き入力をすると、左側が欠けてしまいます。


添付画像A↓でいうところの、「標準の文字数を使う」を選んだ状態で問題が発生するとのことでしょうか。

ピクチャ 8.png
画像A:書式>ページ…>行数と文字数 の設定画面です。


うーん、それでもやはり当方では問題の再現はみられないようです(添付画像Bのとおりです)。
intel版、またはOS10.5環境のユーザの方々のご意見があがると良いのですが :(

ピクチャ 9.png
画像B:文字数の制限をせず表示させました。やはり問題無し、かな。
iDefJP_96
 
記事: 6
登録日時: 2月 22nd, 2009, 6:55 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by tomcat » 5月 11th, 2009, 8:44 pm

iDefJP_96さん

早々にご返信頂き、有り難うございます。
iDefJP_96さんの場合は、問題ないですね。羨ましい。
intel+OS10.5でお使いの方のご意見、是非お願いいたします。
tomcat
 
記事: 7
登録日時: 4月 3rd, 2009, 12:53 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by morich » 5月 15th, 2009, 3:24 am

tomcatさんはじめまして。

当方、MacBook OS X10.5.7(Intel)ですが、OOo3.1.0で特に問題なく表記されています。
『左側がかける』となると完全に読みにくいですね。
morich
 
記事: 6
登録日時: 2月 7th, 2009, 3:13 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by k-mmths03 » 5月 15th, 2009, 4:00 pm

うまい説明のしかたがわからないですが

1)
OpenOffiece.orgで、文章を作っているとき、時々…一行に入る文字数が、行によって異なってしまいます。
つまり、
”「」”を用いたときや、”、”を使った行になると、行の最後のところで、あと一文字入りそう…なのに、次の行に移ってしまいます。


2)
・B5サイズ
・縦書き
・余白設定を2cm
・行数と文字数を指定(25文字×26行)
もちろん、行数と文字数を設定するのに、ルビなどの設定も少しいじって。

それで、文章を作ると、縦書きとかじゃなく、斜めとか表示がおかしくなってしまいます。


いままで、ほかの文書ソフトウエアをまともに使っていなかったので、もしかすると、それについて気づいていなかっただけなのかもしれません。
もし、対処方法なんかあればうれしいのですが・・・・。それとも、不具合?よくわかりませんが、教えてください。
k-mmths03
 
記事: 2
登録日時: 5月 15th, 2009, 3:49 pm

Re: MacOSX+OpenOffice.org3の不具合報告

投稿記事by iDefJP_96 » 5月 19th, 2009, 8:18 pm

k-mmths03さん、こんにちは。

当方PowerPC向けのOpenOffice.orgをOS10.4.11で利用しています。
改善方法のアドバイスまでは判明しなかったのですが、とり急ぎ当方での問題の再現状況などをご報告いたします。

k-mmths03 さんが書きました:1)
OpenOffiece.orgで、文章を作っているとき、時々…一行に入る文字数が、行によって異なってしまいます。
つまり、
”「」”を用いたときや、”、”を使った行になると、行の最後のところで、あと一文字入りそう…なのに、次の行に移ってしまいます。


当方の環境でも、おそらくk-mmths03さんがご説明されていることじゃないかな〜、という状況が再現されます。以下に画像で示します。

ピクチャ 4.png
画像A:OpenOffice.org3.0.0(旧バージョン)の画面です。
4行目の「ぶら下がり」が正しく行われませんでした。

 
ピクチャ 1.png
画像B:OpenOffice.org3.1.0(現時点での最新版)の画面です。
3行目と4行目の「ぶら下がり」が正しく行われませんでした。


おおまかに言うと、『終わりかぎ括弧(」)』などの「ぶら下がり処理」が正しく行われないようです。回避できるような設定があるかどうか少し探ってみたのですが、いまのところよくわかりません。
(私も以前からちょこちょこ使っていて、なんか変だと思ってたんですが…)

2)
・B5サイズ
・縦書き
・余白設定を2cm
・行数と文字数を指定(25文字×26行)
もちろん、行数と文字数を設定するのに、ルビなどの設定も少しいじって。

それで、文章を作ると、縦書きとかじゃなく、斜めとか表示がおかしくなってしまいます。


失礼ながら、上記2)の問題の状況がよく理解できませんでした。具体的にどのようにおかしくなっているのでしょうか?
いや、わたしだけがわからないのかもしれませんが…、k-mmths03さんのご利用環境や、「ルビなどの設定」をどのように設定されたのか、またあわせて画面の表示結果などをご提示いただけると、他の方もより理解しやすいように思うのですが…。

スクリーンショットの撮り方↓
http://point-line.info/blog/archives/20 ... 8_0453.php
iDefJP_96
 
記事: 6
登録日時: 2月 22nd, 2009, 6:55 pm

1つ前へ次へ

Return to Mac OSX

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]