アニメーション不具合について

プレゼンテーション (Impress) について

アニメーション不具合について

投稿記事by nycity » 7月 23rd, 2010, 2:30 am

はじめまして、ご相談させていただきます。

Impressを利用したスライド資料を作っていて、アニメーションを使用すると表示がくるってしまう現象に悩まされています。

例えばサンプルスライドでは、紫色の棒グラフの上に、スライドインで白い四角をかぶせるアニメーションを
つけています。

実際に実行してみると、編集画面では左右どちらの四角もぴったりと紫の棒グラフと幅を合わせてあるにもかかわらず、
実行画面では右側四角の下にスキマができています。左側の四角も同様にスキマができますが、右よりは小さいです。
また、右側のスキマはアニメーションが進行するに従って微妙に広がったり狭まったりしています。

他の環境でも再現されておりますでしょうか、ご確認いただければ幸いです。

Impressのファイルと、私の環境での実行画面のハードコピーを添付しようと思ったのですが、いずれも上限容量を
超えてしまったため、外部のアップローダにパスワード付きでアップいたしましたのでそちらをご参照ください。

http://www1.axfc.net/uploader/H/so/111558.zip
キーワード: oooimpress

よろしくお願いいたします。
OpenOffice.org 3.2.1 + Windows7
nycity
 
記事: 2
登録日時: 7月 23rd, 2010, 2:07 am

Re: アニメーション不具合について

投稿記事by jo7ueb » 7月 23rd, 2010, 4:35 pm

qaメーリングリストとdiscussメーリングリストで検証を呼び掛けたところ、下記の通り報告がありましたので転載します。

/* 以下コピペ */
バグなのかと思い確認してみましたが、アニメーションのバグではないようです。

原因は、棒グラフの下にある括弧が棒グラフに重なって配置されている為に、括弧の背景が透明である事で白の四角が
オーバーライドされて最下部の棒グラフが表示されて見えてしまっているのです。
(これはこれでバグととらえられますが...)

括弧を重なって配置されないように移動することで、作成者の期待していると思われる状態になりました。

/* コピペ終わり */
原文は disscussメーリングリストのアーカイブでご覧いただけます。
OOO3.2.1 @ Windows XP Pro SP3
jo7ueb
 
記事: 2
登録日時: 7月 20th, 2010, 6:23 pm

Re: アニメーション不具合について

投稿記事by nycity » 7月 23rd, 2010, 11:11 pm

jo7uebさん、他検証にかかわって下さった皆様

早速レスポンスいただきありがとうございます。

ご指摘の通り、微妙に重なっている(編集画面上では一見そうは見えないのですが…)カッコを棒グラフから離したところ
解決しました。

どうやら透明エリアを含む図が重なった状態でアニメーションを作ると、陰線(面)処理に難があるようで、
「透明色」で上書きされてしまうのですね。

試しに、わざとカッコを棒グラフに重ね、さらにカッコを最背面に移動させた状態で試したところ、よりひどいことになってしまいました。

>(これはこれでバグととらえられますが...)
とありますが、個人的にはこれはバグではないかな…と感じます。
編集画面ではどんなに拡大してもぴったり合っているグラフの下側の線が、再生画面ではずれて太く見えるのも気になります。

当座の処置としては
     
  • 塗りが透明色であってもアニメーションを含む時は重ならないように注意する
     
  • やむなく重ねる場合は、後からアニメーションによって出現する図形を上層へ持ってくる
といったあたりに気をつけるのが良さそうです。

ありがとうございました。
OpenOffice.org 3.2.1 + Windows7
nycity
 
記事: 2
登録日時: 7月 23rd, 2010, 2:07 am


Return to Impress

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[2人]