Pannello di Controllo Moderatore ]

Macro per Confronto codici

Discussioni sull'applicazione per i fogli di calcolo

Macro per Confronto codici

Messaggioda gassosa » martedì 11 giugno 2019, 15:56

Un saluto a tutta la lista.
Mi servirebbe il vostro aiuto per risolvere un mio problema.
Ho a disposizione 2 tabelle contenente migliaia di prodotti. Vorrei poter sfruttare una macro che mi confrontasse i codici dei prodotti delle 2 tabelle, in modo da verificare se esiste lo stesso prodotto (e quindi lo stesso codice) in entrambe le tabelle.
Il risultato potrebbe essere inglobato in una delle 2 tabelle oppure in una nuova tabella.
In allegato invio un esempio delle 2 tabelle che contengono solamente una decina di prodotti (in realtà sono migliaia).
Ringrazio tutti coloro che volessero darmi una mano.
Allegati
Tab2.ods
(31 KiB) Scaricato 5 volte
Tab1.ods
(19.42 KiB) Scaricato 6 volte
OpenOffice 3.1 su Ubuntu 12.04
gassosa
 
Messaggi: 19
Iscritto il: mercoledì 13 marzo 2013, 17:56

Re: Macro per Confronto codici

Messaggioda patel » martedì 11 giugno 2019, 17:48

Sarebbe lo stesso per te se le 2 tabelle fossero in 2 fogli diversi dello stesso file ?
Hai allegato tabelle con codici tutti diversi, un file di esempio deve essere significativo
Comunque un sistema veloce e senza utilizzare macro che sarebbe lentissima potrebbe essere:

1 copi tutti i dati nello stesso foglio in modo da avere 2 sole colonne
2 ti posizioni in A1, Dati, Altri Filtri, Automatico
3 per la colonna A scegli <>, altre opzioni, elimina duplicati
4 copi il risultato su un altro foglio
Ultima modifica di patel il martedì 11 giugno 2019, 18:11, modificato 1 volta in totale.
-------------------
OpenOffice 4.1 e Libre Office 6.o.7.3 su Windows 10
allega un file di esempio, guadagnerai tempo tu e lo farai risparmiare a chi ti aiuta
patel
Volontario attivo
Volontario attivo
 
Messaggi: 3242
Iscritto il: venerdì 30 aprile 2010, 8:04
Località: Livorno

Re: Macro per Confronto codici

Messaggioda Gaetanopr » martedì 11 giugno 2019, 18:07

Puoi usare la funzione CONTA.SE senza ricorrere alle macro.
Esempio
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CONTA.SE('file:///D:/Users/Gaetano/Downloads/Tab2.ods'#$Foglio2.A$1:A$35;A2)
nel foglio Tab1 cell C2 con i giusti riferimenti, una volta verificato in una colonna quali codici sono presenti puoi crearti una lista
Openoffice 4.1 su windows xp
Gaetanopr
Volontario
Volontario
 
Messaggi: 2672
Iscritto il: mercoledì 21 novembre 2012, 21:07

Re: Macro per Confronto codici

Messaggioda gassosa » martedì 11 giugno 2019, 18:39

Grazie mille.
Stasera provo e vi faccio sapere.
OpenOffice 3.1 su Ubuntu 12.04
gassosa
 
Messaggi: 19
Iscritto il: mercoledì 13 marzo 2013, 17:56


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti