Pannello di Controllo Moderatore ]

[Risolto] Sincronizzazione celle con dati

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Sincronizzazione celle con dati

Messaggioda davipc » venerdì 11 gennaio 2019, 20:05

Ciao a tutti,
ho necessità di effettuare un'operazione con Calc ma non ho idea di come fare e faccio pure fatica a spiegarlo.....
Ci provo:
in sostanza date delle righe su fogli diversi che comincino con le medesime caselle alfanumeriche, cui seguono nelle celle adiacenti altre infromazioni, dovrei fare in modo di unire tali informazioni in un unico file. Normalmente se tutto è nel medesimo ordine basta fare un copia-incolla della colonna, ma nel caso in cui nel secondo foglio mancassero delle righe? Allego un'immagine perchè altrimenti si capisce poco.
Nell'esempio vorrei che in automatico venisse scritto nella colonna C ciò che è riportato nella colonna E ove corrispondano le colonne A e D. Per semplicità ho trascritto tutto in un unico foglio ma ho facoltà di eseguire l'operazionexome voglio, anche su files o fogli diversi. Andrebbe bene anche un'integrazione direttamente al primo file senza per forza generarne un terzo.
Spero di essere stato chiaro.
p.s.: io uso generalmente LibreOffice ma credo che la procedura sia la medesima, alla peggio installo anche OpenOffice
Grazie
Allegati
prova.jpg
Ultima modifica di davipc il lunedì 22 aprile 2019, 21:19, modificato 5 volte in totale.
LibreOffice 5.4.7.2
davipc
 
Messaggi: 5
Iscritto il: venerdì 11 gennaio 2019, 19:52

Re: Sincronizzazione celle con dati

Messaggioda patel » venerdì 11 gennaio 2019, 20:55

allega 2 file di esempio, se gli esperti di formule non riescono a risolvere proveremo con una macro
-------------------
OpenOffice 4.1 e Libre Office 6.o.7.3 su Windows 10
allega un file di esempio, guadagnerai tempo tu e lo farai risparmiare a chi ti aiuta
patel
Volontario attivo
Volontario attivo
 
Messaggi: 3242
Iscritto il: venerdì 30 aprile 2010, 8:04
Località: Livorno

Re: Sincronizzazione celle con dati

Messaggioda lucky63 » venerdì 11 gennaio 2019, 21:00

Per la prossima volta vedi questo link su come allegare file viewtopic.php?f=2&t=6261
Con riferimento all'immagine del tuo esempio ...
In cella C1 inserire la formula:
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(VAL.ERRORE(CERCA.VERT(A1;$D$1:$E$4;2;0));"";CERCA.VERT(A1;$D$1:$E$4;2;0))

Copiare poi cella C1 fino a cella C10
Ecco il risultato.
Test.png

Nota bene.
Se il range dati da cui estrarre le corrispondenze è maggiore dell'area azzurra rappresentata in immagine occorre adeguare la formula della cella C1 nella parte $D$1:$E$4 (notare che è riportata due volte) adeguandola al range dati da verificare. Poi ricopiarla in basso quanto serve in colonna C.
Allegati
Test .ods
(10.97 KiB) Scaricato 9 volte
Allegando al quesito un file di esempio si semplifica il lavoro di chi risponde.
Avatar utente
lucky63
Volontario
Volontario
 
Messaggi: 1874
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Sincronizzazione celle con dati

Messaggioda davipc » venerdì 11 gennaio 2019, 22:54

Funziona! Grazie mille! :bravo:
LibreOffice 5.4.7.2
davipc
 
Messaggi: 5
Iscritto il: venerdì 11 gennaio 2019, 19:52

Re: Sincronizzazione celle con dati

Messaggioda charlie » sabato 12 gennaio 2019, 12:36

Ciao @davipc e benvenuto sul forum.
Se ti vuoi presentare puoi farlo qui: https://forum.openoffice.org/it/forum/viewforum.php?f=16
Per una panoramica delle regole del forum puoi consultare il Manuale di sopravvivenza: http://forum.openoffice.org/it/forum/viewtopic.php?f=1&t=2
Buon proseguimento.
charlie
macOS 10.12 Sierra: Open Office 4.1.5 - LibreOffice 6.0.7
Windows 7 pro (VirtualBox): Open Office 4.1.5 - LibreOffice 5.4.4.2
Ubuntu 17.04 LTE (VirtualBox): LibreOffice 5.1.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 5874
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Sincronizzazione celle con dati

Messaggioda davipc » mercoledì 17 aprile 2019, 0:12

Ciao, la soluzione proposta funziona. Ho provato però ad inserire una variante ma senza successo. Volevo chiedere: se le celle in esame delle colonne D ed E da ridistribuire non fossero adiacenti, ma stessimo parlando ad esempio di colonne D ed L con quindi altri dati irrilevanti nel mezzo, come andrebbe modificata la formula? Grazie
LibreOffice 5.4.7.2
davipc
 
Messaggi: 5
Iscritto il: venerdì 11 gennaio 2019, 19:52

Re: Sincronizzazione celle con dati

Messaggioda lucky63 » mercoledì 17 aprile 2019, 9:39

charlie ha scritto:se le celle in esame delle colonne D ed E da ridistribuire non fossero adiacenti, ma stessimo parlando ad esempio di colonne D ed L

Formula cella C1:
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(VAL.ERRORE(CERCA.VERT(A1;$D$1:$L$4;9;0));"";CERCA.VERT(A1;$D$1:$L$4;9;0))

Copiare poi cella C1 fino a cella C10
Ecco il risultato.
01.png

Nota bene.
- Se il range dati da cui estrarre le corrispondenze è maggiore dell'area azzurra rappresentata in immagine occorre adeguare la formula della cella C1 nella parte $D$1:$L$4 (notare che è riportata due volte) adeguandola al range dati da verificare. Poi ricopiarla in basso quanto serve in colonna C;
- Per eventuali futuri cambiamenti considera che il valore 9 (notare che è riportato due volte) corrisponde al numero della colonna del range indicato (D = colonna 1, E = colonna 2, ..., L = colonna 9).
Allegati
Test -01.ods
(11.41 KiB) Scaricato 4 volte
Allegando al quesito un file di esempio si semplifica il lavoro di chi risponde.
Avatar utente
lucky63
Volontario
Volontario
 
Messaggi: 1874
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Sincronizzazione celle con dati

Messaggioda davipc » lunedì 22 aprile 2019, 21:16

Ok grazie mille! :super:
LibreOffice 5.4.7.2
davipc
 
Messaggi: 5
Iscritto il: venerdì 11 gennaio 2019, 19:52


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti