Pannello di Controllo Moderatore ]

Rintracciare valore minimo e data corrispondente.

Discussioni sull'applicazione per i fogli di calcolo

Rintracciare valore minimo e data corrispondente.

Messaggioda giulifulvi » giovedì 13 settembre 2018, 19:58

Buonasera a tutti.
Ho impostato con le varie formule, la mia raccolta dati meteo.
Prendendo come riferimento il file allegato, quale è la formula che su "C51" mi restituisca la data del valore minimo rintracciabile su "C5:C35".
Caso concreto:
il valore minimo compreso tra "C5:C35" è 3.2 (v. cella "C49"). Su "C51" deve risultarmi "30/01/18". Come posso fare?
Grazie in anticipo.
Buona serata.
Allegati
dati.ods
(18.39 KiB) Scaricato 2 volte
OpenOffice 3.1 su Windows Vista
giulifulvi
 
Messaggi: 7
Iscritto il: venerdì 10 agosto 2018, 17:07

Re: Rintracciare valore minimo e data corrispondente.

Messaggioda gioh66 » giovedì 13 settembre 2018, 20:56

Buonasera. Prova così, in C51
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(B5:B35;CONFRONTA(MIN(C5:C35);C5:C35;0))

Questa ti da la prima corrispondenza che trova, ma se il valore minimo si ripete più volte e vuoi conoscere tutte le date, allora prova questa formula matriciale da confermare con la combinazione di tasti ctrl+maiuscolo+invio (non con il solo invio) e da copiare in basso
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE.ERRORE(INDICE($B$5:$B$35;PICCOLO(SE($C$5:$C$35=MIN($C$5:$C$35);RIF.RIGA($C$5:$C$35)-4);RIF.RIGA($A1)));"")


o se hai Openoffice
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(VAL.ERRORE(INDICE($B$5:$B$35;PICCOLO(SE($C$5:$C$35=MIN($C$5:$C$35);RIF.RIGA($C$5:$C$35)-4);RIF.RIGA($A1))));"";INDICE($B$5:$B$35;PICCOLO(SE($C$5:$C$35=MIN($C$5:$C$35);RIF.RIGA($C$5:$C$35)-4);RIF.RIGA($A1)))

sempre matriciale
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 465
Iscritto il: lunedì 31 luglio 2017, 14:57


Torna a Calc

Chi c’è in linea

Visitano il forum: Google [Bot] e 8 ospiti