Pannello di Controllo Moderatore ]

[Risolto] SE nidificato o doppio SE

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] SE nidificato o doppio SE

Messaggioda skate2k5 » mercoledì 12 settembre 2018, 15:31

Buongiorno, dovrei impostare questa formula per il calcolo della differenza tra due date (in giorni).
con le seguenti variabili:

SE in F2 C'è Scritto SI deve calcolare la differenza tra E2-C2, altrimenti non deve calcolare nulla.
Ma se in F2 c'è scritto SI e G2 è vuoto (quindi non è indicata la data) deve considerare OGGI quindi fare OGGI-C2

allego file che forse è meglio.
Grazie
Allegati
doppio se.ods
(12.39 KiB) Scaricato 2 volte
Ultima modifica di charlie il sabato 15 settembre 2018, 14:37, modificato 3 volte in totale.
Motivazione: Normalizzato [Risolto] ed aggiunta spunta verde
Calc OpenOffice 3.1
skate2k5
 
Messaggi: 27
Iscritto il: mercoledì 5 aprile 2017, 9:32

Re: SE nidificato o doppio SE

Messaggioda skate2k5 » mercoledì 12 settembre 2018, 15:48

Mi rispondo da solo...forse è questa la formula corretta da inserire....=SE(F3="SI";SE(E3="";I1-C3;E3-C3); )
dove in I1 ho impostato la data odierna con =OGGI()

Giusto??
Calc OpenOffice 3.1
skate2k5
 
Messaggi: 27
Iscritto il: mercoledì 5 aprile 2017, 9:32

Re: SE nidificato o doppio SE

Messaggioda gioh66 » mercoledì 12 settembre 2018, 21:39

Buonasera, prova cosi
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(E(F2="SI";E2="");OGGI()-C2;SE(F2="SI";E2-C2;""))
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 463
Iscritto il: lunedì 31 luglio 2017, 14:57

Re: SE nidificato o doppio SE [RISOLTO]

Messaggioda skate2k5 » giovedì 13 settembre 2018, 8:13

Si, forse è più pulita questa e non utilizzo una cella con OGGI().
Grazie
Calc OpenOffice 3.1
skate2k5
 
Messaggi: 27
Iscritto il: mercoledì 5 aprile 2017, 9:32


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 27 ospiti