Pannello di Controllo Moderatore ]

Formula somma con matrice

Discussioni sull'applicazione per i fogli di calcolo

Formula somma con matrice

Messaggioda giulifulvi » venerdì 10 agosto 2018, 17:55

Buonasera.
Devo fare una somma con matrice, soltanto che mi funziona a metà.
Vi presento il mio caso:
Su D5 ho inserito la formula =MATR.SOMMA.PRODOTTO((RESTO(RIF.RIGA(D13:D10000);6)=0)*(D13:D10000)) per avere la somma di "D24+D30+D36+D42... fino a D100000". E fin quì, tutto funziona alla perfezione ed ottengo il risultato voluto.

La stessa formula la devo riportare su D6 e D7, muovendomi sempre di 6 celle e partendo rispettivamente da D14 e D15:
- D6 (che sarebbe la somma di "D25+D31+D37 fino a D10000")
- D7 ( " " " di "D26+D32 .... etc...)

Ma in questi ultimi due casi (D6 e D7), pur cambiando i riferimenti degli intervalli, mi riporta il risultato della formula della cella D5. E quindi , non va bene.

Sbaglio formula? Come posso risolvere il problema?

Vi allego screenshot per chiarire meglio la mia attuale situazione
Grazie mille.
OpenOffice 3.1 su Windows Vista
giulifulvi
 
Messaggi: 3
Iscritto il: venerdì 10 agosto 2018, 17:07

Re: Formula somma con matrice

Messaggioda charlie » venerdì 10 agosto 2018, 18:24

Ciao e benvenuto sul forum.
Se intanto ti vuoi presentare puoi farlo qui: https://forum.openoffice.org/it/forum/viewforum.php?f=16
Per una panoramica delle regole del forum consulta il Manuale di sopravvivenza: http://forum.openoffice.org/it/forum/viewtopic.php?f=1&t=2
Buon proseguimento.

Allega un file, non un'immagine. Non costringere chi ti aiuta a costruire da sè il file su cui fare le prove.
charlie
macOS 10.12 Sierra: Open Office 4.1.5 - LibreOffice 5.4.3.2
Windows 7 pro (VirtualBox): Open Office 4.1.5 - LibreOffice 5.4.4.2
Ubuntu 17.04 LTE (VirtualBox): LibreOffice 5.1.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 5199
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Formula somma con matrice

Messaggioda giulifulvi » venerdì 10 agosto 2018, 19:20

charlie ha scritto:Ciao e benvenuto sul forum.
Se intanto ti vuoi presentare puoi farlo qui: https://forum.openoffice.org/it/forum/viewforum.php?f=16
Per una panoramica delle regole del forum consulta il Manuale di sopravvivenza: http://forum.openoffice.org/it/forum/viewtopic.php?f=1&t=2
Buon proseguimento.

Allega un file, non un'immagine. Non costringere chi ti aiuta a costruire da sè il file su cui fare le prove.


Ciao e grazie per il benvenuto e grazie per i suggerimenti riguardanti il forum.
Ho anche provato a spulciare qualche info sulla vs piattaforma, ma il mio caso proprio non c'è :-(
Allego il file quì. Ho tentato di modificare il mio post, ma nel momento in cui provo a cambiare l'allegato, mi compare questa scritta "Errore Generale".

Buona serata.
Fulvio
Allegati
CONT.ods
(22.15 KiB) Scaricato 6 volte
OpenOffice 3.1 su Windows Vista
giulifulvi
 
Messaggi: 3
Iscritto il: venerdì 10 agosto 2018, 17:07

Re: Formula somma con matrice

Messaggioda gioh66 » sabato 11 agosto 2018, 9:41

Buondì, forse mi sfugge l'obiettivo che vuoi ottenere (molto probabile), ma vedendo il tuo file, non ti basta mettere queste 3 formule?
In E4 da trascinare a dx
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(D$18:D$10000;$C$18:$C$10000=$C$18)

in E5
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(D$18:D$10000;$C$18:$C$10000=$C$19)

e in E6
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(D$18:D$10000;$C$18:$C$10000=$C$20)
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 445
Iscritto il: lunedì 31 luglio 2017, 14:57

Re: Formula somma con matrice

Messaggioda giulifulvi » sabato 11 agosto 2018, 19:05

gioh66 ha scritto:Buondì, forse mi sfugge l'obiettivo che vuoi ottenere (molto probabile), ma vedendo il tuo file, non ti basta mettere queste 3 formule?
In E4 da trascinare a dx
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(D$18:D$10000;$C$18:$C$10000=$C$18)

in E5
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(D$18:D$10000;$C$18:$C$10000=$C$19)

e in E6
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(D$18:D$10000;$C$18:$C$10000=$C$20)


Ciao Gioh66.
Facendo il classico "copia/incolla" della formula (quindi copiavo la formula di "D5" e la incollavo in D6 affinchè io potessi ottenere il totale della somma di "D25+D31+D37 fino a D10000"), il risultato finale era tutt'altro (usciva una somma completamente sballata).
Comunque, ho applicato il tuo suggerimento ed adesso è tutto ok!
Grazie mille.
OpenOffice 3.1 su Windows Vista
giulifulvi
 
Messaggi: 3
Iscritto il: venerdì 10 agosto 2018, 17:07

Re: Formula somma con matrice

Messaggioda gioh66 » sabato 11 agosto 2018, 19:34

:super: Ottimo!
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 445
Iscritto il: lunedì 31 luglio 2017, 14:57


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite