Pannello di Controllo Moderatore ]

[Risolto] Complitamento autmatico riga e conversioe

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Complitamento autmatico riga e conversioe

Messaggioda momifriz » martedì 10 luglio 2018, 10:45

Buongiorno.
Vorrei riuscire a prelevare dei dati da un foglio excel immettendo solo il nome, e avere un completamento automatico delle righe successive, oltre a una conversione a seconda dei grammi inseriti. :crazy:


Esempio (come da file allegato).

1° richiesta
Nel foglio 1 inserisco “Cipolle”
In automatico completa le righe “Proteine”, “Lipidi”, “Glucidi” (prendendo i dati dal foglio 2, che conterrà tutti gli alimenti con i nutrienti relativi a 100 gr di prodotto”).

2° richiesta
Inoltre dopo averli prelevati vorrei poter selezionare la quantità nel foglio 1 (menu a tendina già inserito) e su quella avere una modifica automatica dei nutrienti.

Se 100 gr di cipolle contengono 0,7 proteine, 20 grammi ne conterranno 0,14 gr. (il calcolo sarebbe 0,7*0,2 in questo caso) e così via per gli altri parametri.


Chiedo troppo? Esiste qualche formula che permetta queste cose, anche perchè nel foglio 2 avrò circa 1000 alimenti e non posso inserire la singola formula di volta in volta.
Ultima modifica di momifriz il martedì 16 ottobre 2018, 8:17, modificato 3 volte in totale.
OpenOffice 4.1.5 su MacOS Yosemite 10.10.5
momifriz
 
Messaggi: 6
Iscritto il: martedì 10 luglio 2018, 10:41

Re: Completamento automatico riga e conversione

Messaggioda gioh66 » martedì 10 luglio 2018, 12:08

Buondì, prova così: in C4 metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT($A4;$'Table 1'.$A$2:$D$46;COLONNE($C$1:C$1)+1;0)*$B4/100

e trascini a destra e in basso.
Ti ri-allego il file
Allegati
Conversione in grammi(1).ods
(16.72 KiB) Scaricato 9 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 563
Iscritto il: lunedì 31 luglio 2017, 13:57

Re: Completamento automatico riga e conversione

Messaggioda momifriz » martedì 10 luglio 2018, 12:20

Questo codice prendi i valori dal foglio 2 e li converte in base ai grammi selezionati.

E per avere un completamento automatico delle righe? Cioè per intenderci. Questo codice sarebbe il secondo passaggio.
Il primo, se possibile, dovrebbe consistere in un completamento automatico della stringa all'inserimento dell'alimento.

Tipo inserisco solo cipolle e mi aggiunge i corrispettivi nutrienti.
Mi serve per elaborare una dieta quindi ci saranno alimenti differenti, con ordini differenti.
Esiste una soluzione per questo?
OpenOffice 4.1.5 su MacOS Yosemite 10.10.5
momifriz
 
Messaggi: 6
Iscritto il: martedì 10 luglio 2018, 10:41

Re: Completamento automatico riga e conversione

Messaggioda gioh66 » martedì 10 luglio 2018, 12:39

Ma hai visto il file? La formula fà proprio questo. Quando tu inserisci l'alimento nelle celle della colonna A del foglio2 e la quantità nella rispettiva cella della colonna B, dalla colonna C alla E le celle vengono compilate come chiedi.
Ti rimetto la formula da inserire nella cella C4 e da copiare a destra e in basso fin dove ti serve
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE($A4="";"";CERCA.VERT($A4;$'Table 1'.$A$2:$D$46;COLONNE($C$1:C$1)+1;0)*$B4/100)

Ho aggiunto un SE di modo che se la cella della colonna A è vuota non compaia niente nelle corrispettive celle della stessa riga.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 563
Iscritto il: lunedì 31 luglio 2017, 13:57

Re: Completamento automatico riga e conversione

Messaggioda momifriz » martedì 10 luglio 2018, 12:55

No vabbè....sei un genio!!!!!!
Mi spiegheresti le parti della formula così da poterla impiegare anche in altri file?

Grazieeee <3
OpenOffice 4.1.5 su MacOS Yosemite 10.10.5
momifriz
 
Messaggi: 6
Iscritto il: martedì 10 luglio 2018, 10:41

Re: Completamento automatico riga e conversione

Messaggioda momifriz » martedì 10 luglio 2018, 13:12

Ho capito la formula, non ho capito la dicitura
COLONNE($C$1:C$1)+1;0)*$B4/100)
Cosa sta a significare?

Comunque grazie grazie grazie ancora <3
OpenOffice 4.1.5 su MacOS Yosemite 10.10.5
momifriz
 
Messaggi: 6
Iscritto il: martedì 10 luglio 2018, 10:41

Re: Completamento automatico riga e conversione

Messaggioda gioh66 » martedì 10 luglio 2018, 13:24

Il cuore della formula è il CERCA.VERTICALE, che si compone di quattro argomenti: il criterio di ricerca, che è quello che scrivi nella celle della colonna A di Foglio 2
La matrice che indica che è la tabella che hai in Table1.
L'indice, che è un numero (1, 2, 3 e 4 nel tuo caso) che indica la colonna della tabella su cui fare la ricerca.
L'ordinato, che può essere 0 per una corrispondenza esatta, come nel tuo caso, o 1 se è approssimativa.

Nella tua formula per renderla un pò più dinamica ho usato la funzione COLONNE($C$1:C$1)+1 per l'indice, per creare un range espandibile che trascinando la formula a destra và a leggere i valori della seconda, terza e quarta colonna automaticamente.

La seconda parte *$B4/100 è solo matematica: non fa altro che moltiplicare il risultato del cerca verticale per il peso delle celle di colonna B diviso 100, dato che i valori della tabella sono riferiti a 100 gr, ma credo che questo tu lo sappia da te :D
La funzione SE è solo per l'estetica. Se non ci fosse, la formula funzionerebbe comunque ma la dove in colonna A non ci fosse un valore ti ritroveresti le celle piene di antipatici #N/D :lol:
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 563
Iscritto il: lunedì 31 luglio 2017, 13:57

Re: [RISOLTO] Completamento automatico riga e conversione

Messaggioda momifriz » martedì 10 luglio 2018, 13:27

Grazie gioh66, per l'ennesima volta.
Non sai quanto mi hai aiutato.
Buona giornata
OpenOffice 4.1.5 su MacOS Yosemite 10.10.5
momifriz
 
Messaggi: 6
Iscritto il: martedì 10 luglio 2018, 10:41

Re: [RISOLTO] Completamento automatico riga e conversione

Messaggioda gioh66 » martedì 10 luglio 2018, 13:30

Grazie a te del riscontro! Buona giornata anche a te!
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 563
Iscritto il: lunedì 31 luglio 2017, 13:57


Torna a Calc

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti

cron