Pannello di Controllo Moderatore ]

[Risolto] CERCA.VERT celle precedenti

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] CERCA.VERT celle precedenti

Messaggioda ghost38 » mercoledì 16 maggio 2018, 11:53

Ciao a tutti!
Ho un problema tecnicamente banale praticamente, per me, impossibile da risolvere.

Sto provando ad usare il cerca verticale con i dati delle celle precedenti al criterio di ricerca.

Esempio.
In E2
=CERCA.VERT(D2;A2:C2;-3) ho anche provato con =CERCA.VERT(D2;C2:A2;3)

In D2
CIAO

In C2
CIAO

IN B2
A TUTTO

IN A2
IL MONDO

Risultato desiderato in E2=
IL MONDO

Risultato ottenuto in E2=
#N/D

Help :(
Ultima modifica di ghost38 il mercoledì 16 maggio 2018, 12:15, modificato 1 volta in totale.
OpenOffice 3.1 su Windows Vista
ghost38
 
Messaggi: 13
Iscritto il: giovedì 6 aprile 2017, 16:46

Re: CERCA.VERT celle precedenti

Messaggioda gioh66 » mercoledì 16 maggio 2018, 12:00

Senza un file d'esempio, ti dico solo che il cerca verticale inizia a fare la ricerca dalla prima colonna a sinistra della matrice, colonna che serve a cercare il criterio. Se devi cercare un risultato partendo da una colonna che non è la prima a sx e andare in "dietro", allora devi orientarti sull'indice e confronta.
Libreoffice 6 / PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 379
Iscritto il: lunedì 31 luglio 2017, 14:57

Re: CERCA.VERT celle precedenti

Messaggioda ghost38 » mercoledì 16 maggio 2018, 12:14

Non conoscevo INDICE e CONFRONTA.
Ho risolto con la seguente formula:
=INDICE(A2:A100;CONFRONTA(C2;D2:D100;0))

Grazie mille @gioh66
OpenOffice 3.1 su Windows Vista
ghost38
 
Messaggi: 13
Iscritto il: giovedì 6 aprile 2017, 16:46

Re: CERCA.VERT celle precedenti

Messaggioda gioh66 » mercoledì 16 maggio 2018, 12:24

Bene, mi fa piacere. :super:
Libreoffice 6 / PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 379
Iscritto il: lunedì 31 luglio 2017, 14:57


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite