Pannello di Controllo Moderatore ]

[Risolto] Sempre gli ultimi 5!

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Sempre gli ultimi 5!

Messaggioda Kripsnark » venerdì 2 agosto 2019, 11:26

Salve a tutti,
sono ancora io che mi propongo una nuova ed entusiasmante situazione da risolvere.

Supponiamo di giocare al lotto, ipotizziamo che ci saranno 30 estrazioni e a noi interessi sapere la media aritmetica delle ultime 5 estrazioni fatte. Che funzione si può utilizzare per fare in modo che ad ogni nuovo numero estratto inserito nella tabella, automaticamente la media agisca prendendo in considerazione sempre gli ultimi 5?

Allego un file che potrebbe aiutare a capire,
Grazie
Allegati
Formula.ods
(11.04 KiB) Scaricato 10 volte
Ultima modifica di Kripsnark il venerdì 2 agosto 2019, 14:35, modificato 1 volta in totale.
Kripsnark
Windows 10 Home: OpenOffice 4.1.2
Kripsnark
 
Messaggi: 11
Iscritto il: giovedì 1 agosto 2019, 0:31

Re: Sempre gli ultimi 5!

Messaggioda lucky63 » venerdì 2 agosto 2019, 13:47

Formula Cella AI3:

Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(CONTA.NUMERI(D3:AG3)=0;"";SE(CONTA.NUMERI(D3:AG3)<6; MEDIA(INDIRETTO(INDIRIZZO(RIF.RIGA();29) & ":" &INDIRIZZO(RIF.RIGA();33)));MEDIA(INDIRETTO(INDIRIZZO(RIF.RIGA();34-CONTA.NUMERI(D3:AG3))&":"&INDIRIZZO(RIF.RIGA();38-CONTA.NUMERI(D3:AG3))))))


Replicabile in basso nella stessa colonna ove serve utilizzando copia/incolla.
Fai test
Allegati
Formula_01.ods
(11.59 KiB) Scaricato 9 volte
Allegando al quesito un file di esempio si semplifica il lavoro di chi risponde.
Avatar utente
lucky63
Volontario
Volontario
 
Messaggi: 1944
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Sempre gli ultimi 5!

Messaggioda gioh66 » venerdì 2 agosto 2019, 14:04

Buondì! Prova così
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA(SCARTO(D3;;CONTA.NUMERI(D1:AG1)-CONTA.NUMERI(D3:AG3);;5))/5

Io ho messo la formula nella colonna AL
Allegati
media ultimi 5.ods
(11.18 KiB) Scaricato 9 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 880
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Sempre gli ultimi 5!

Messaggioda Kripsnark » venerdì 2 agosto 2019, 14:34

grazie mille ad entrambi
Kripsnark
Windows 10 Home: OpenOffice 4.1.2
Kripsnark
 
Messaggi: 11
Iscritto il: giovedì 1 agosto 2019, 0:31

Re: [Risolto] Sempre gli ultimi 5!

Messaggioda gioh66 » venerdì 2 agosto 2019, 14:37

Giusto per gioco aggiungo un'altra formula con il sistema R1C1
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MEDIA(INDIRETTO("r3c"&CONTA.VUOTE(A3:AG3)+2&":r3c"&CONTA.VUOTE(A3:AG3)+6;0))


Ps.: per la seconda riga di estrazioni va sostituito r3 con r16.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 880
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti