Pannello di Controllo Moderatore ]

Trovare elementi da colonna e elencarli in un'altra

Discussioni sull'applicazione per i fogli di calcolo

Trovare elementi da colonna e elencarli in un'altra

Messaggioda stesf » sabato 13 luglio 2019, 16:53

Buongiorno a tutti.
E' da giorni che provo a risolvere questo problema:

ho una colonna che contiene delle formule per il richiamo di valori da altri fogli dello stesso documento Calc.
come da immagine allegata, questa colonna è la A.
In un'altra colonna (B da immagine) vorrei accorpare i risultati in modo da non avere le caselle (di A) che contengono la formula e che non hanno come risultato il richiamo di un valore; ovvero, vorrei quindi avere solo le caselle con il risultato elencate una sotto l'altra.

Sono riuscito ad avere come valore il primo risultato ("CIAO" da immagine) grazie alla formula
=SE(CODICE(A2)>0;A2;SE(CODICE(A3)>0;A3;SE....
ma non riesco a trovare la soluzione per le caselle sottostanti.

Vi ringrazio,
Stefano.
Allegati
PROBLEMA.jpg
Screenshot
OpenOffice 4.1.6 su Windows 10
stesf
 
Messaggi: 4
Iscritto il: sabato 13 luglio 2019, 14:57

Re: Trovare elementi da colonna e elencarli in un'altra

Messaggioda gioh66 » sabato 13 luglio 2019, 17:00

Ciao allega il file e non un'immagine con cui non ci si fa niente.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 878
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Trovare elementi da colonna e elencarli in un'altra

Messaggioda charlie » sabato 13 luglio 2019, 17:34

Ciao @stesf e benvenuto/a sul forum.
Se intanto ti vuoi presentare puoi farlo in questa sezione -> https://forum.openoffice.org/it/forum/viewforum.php?f=16
Per una panoramica delle regole del forum puoi consultare il Manuale di sopravvivenza -> http://forum.openoffice.org/it/forum/viewtopic.php?f=1&t=2

Buon proseguimento
charlie
macOS 10.12 Sierra: Open Office 4.1.7 - LibreOffice 6.2.7.1
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 6066
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Trovare elementi da colonna e elencarli in un'altra

Messaggioda stesf » sabato 13 luglio 2019, 18:03

gioh66 ha scritto:Ciao allega il file e non un'immagine con cui non ci si fa niente.


chiedo scusa, ecco il file
Allegati
PROBLEMA.ods
(10.69 KiB) Scaricato 15 volte
OpenOffice 4.1.6 su Windows 10
stesf
 
Messaggi: 4
Iscritto il: sabato 13 luglio 2019, 14:57

Re: Trovare elementi da colonna e elencarli in un'altra

Messaggioda gioh66 » sabato 13 luglio 2019, 22:03

Allora in B2 prova la seguente formula matriciale
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(VAL.ERRORE(INDICE($E$2:$E$18;PICCOLO(SE(($D$2:$D$18<0)*(VAL.TESTO($E$2:$E$18));RIF.RIGA($E$2:$E$18)-1);RIF.RIGA(A1))));"";INDICE($E$2:$E$18;PICCOLO(SE(($D$2:$D$18<0)*(VAL.TESTO($E$2:$E$18));RIF.RIGA($E$2:$E$18)-1);RIF.RIGA(A1))))

Se non lo sai, per inserire una formula matriciale, fai così: ti posizioni sulla cella, dai F2 per aprirla in modalità modifica incolli la formula, la confermi con la combinazione di tasti CTRL+MAIUSCOLO+INVIO (non con il solo invio) e la copi e incolli nelle celle sottostanti.
Allegati
trova elementi.ods
(11.69 KiB) Scaricato 15 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 878
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Trovare elementi da colonna e elencarli in un'altra

Messaggioda stesf » mercoledì 11 settembre 2019, 13:13

Scusate il ritardo, volevo ringraziarvi per le risposte: così, ho risolto il problema. Grazie!
OpenOffice 4.1.6 su Windows 10
stesf
 
Messaggi: 4
Iscritto il: sabato 13 luglio 2019, 14:57

Re: Trovare elementi da colonna e elencarli in un'altra

Messaggioda gioh66 » mercoledì 11 settembre 2019, 13:28

Grazie a te del riscontro! :super:
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 878
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite