Pagina 1 di 1

Somme e subtotali

MessaggioInviato: mercoledì 24 luglio 2019, 17:12
da diego68
ciao credo bisogni usare la funzione dei subtotali in quello di cui ho bisogno ma non sono risucro e non riesco a capire che formule usare.
Allego il foglio senza formule e vorrei che funzionasse in questo modo.
Nella Colonna E dove ci sono i totali da versare che sono i contanti e le fatture contanti o altro se devo aggiungerlo ma solamente il contante perché' le carte di credito sono gia' versate sul conto.
Nella colonna F segno quanto ho realmente versato e non sempre corrisponde con quanto devo versare
Nella colonna G invece vorrei che mi calcolasse quanto mi rimane da versare pero' per esempio se in E7 ed E8 c'e' un importo da versare che me lo riporti in G pero' se non verso me lo riporti nel giorno successivo e se il giorno successivo c'e' da versare ulteriore contante me lo aumentasse e se verso me lo diminuisse in modo automatico a secondo dell'importo in G
ad esempio in H8 e 9 l'importo e' uguale perché' non c'e' da versare niente poi in H10 aumenta di 10 perché' c'e' da versare 10 pe cosi' via. quindi mi deve aumentare se c'e' da versare e diminuire se verso riportando il totale in automatico

Re: Somme e subtotali

MessaggioInviato: mercoledì 24 luglio 2019, 20:48
da lucky63
Prova così:
In cella E6 inserisci la formula seguente:
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(A6="";"";A6)

In cella G6 inserisci la formula seguente:
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(E6="";SOMMA($G5:G5)-F6;SOMMA($G5:G5)+E6-F6)

Ricopia in basso le suddette celle nelle rispettive colonne fino alla riga che vuoi.
Le formule si adattano automaticamente all'esigenza.
Vedi esempio

Re: Somme e subtotali

MessaggioInviato: mercoledì 24 luglio 2019, 20:58
da diego68
ciao
grazie per la risposta
pero' in E6 ci arrivo con una formula di somma, se metto la formula che mi hai detto tu la somma sparisce perché' in E6 l'inserimento non e' manuale ma automatico con la somma E6+B6
si può aggiungere la somma e la formula che mi hai dato tu? perché' in E6 devo anche sommare anche D6 quando c'e' un valore infatti in G13 e G14 il totale che io ho scritto e' diverso dal tuo.
forse nella prima formula A6 si deve mettere anche D6 o sbaglio?
sto lavorando sul foglio che ti ho dato quindi sono un po cambiate le celle, ti do la formula che ho fatto da mettere in E6 =SOMMA(E8;P8)-SOMMA(D8;H8) perché' il totale e' dato dalla somma di due celle meno la somma di altre due celle. quindi il totale E6 e' cosi'. non so se mi sono spiegato bene ti ho riallungato il file guarda il foglio 2.
grazie

Re: Somme e subtotali

MessaggioInviato: mercoledì 24 luglio 2019, 22:03
da Attilafdd
Allego prima versione del file con formule.

Re: Somme e subtotali

MessaggioInviato: mercoledì 24 luglio 2019, 22:49
da gioh66
Ciao, se ho capito prova così: in E6 da tirare in basso metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA(A6;D6)

e in G6
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA(E$17:$E17)-SOMMA(F$17:$F17)

e tira in basso.

Re: Somme e subtotali

MessaggioInviato: giovedì 25 luglio 2019, 10:41
da diego68
Grazie e' perfetta la versione prova2 calcola come desidero.
Ho una domanda.
Alla fine della colonna G tiro il totale del mese con la funzione somma
Nel foglio 2 ricomincio per il mese successivo ma nella prima cella vorrei che facesse il riporto del totale di quanto devo ancora versare del mese precedente e lo sommasse quindi alla prima cella G25
esempio se chiudo il 31 che devo ancora versare 10 nel giorno 1 del mese successivo mi deve fare i conti considerando nella somma da versare nella casella E anche il riporto del totale del mese precedente. si può' fare?
grazie

Re: Somme e subtotali

MessaggioInviato: giovedì 25 luglio 2019, 18:37
da Attilafdd
diego68 ha scritto:...si può' fare?

Certo.
Predisponi il file con la struttura che vorresti (un mese su ogni foglio... ecc. ecc. come meglio credi), poi allega il file e vediamo come si può fare.
Se si parte dal tuo desiderata... è sempre meglio e più veloce.