Pannello di Controllo Moderatore ]

[Risolto] Allineare differenti colonne di dati

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Allineare differenti colonne di dati

Messaggioda Giaccio » giovedì 18 luglio 2019, 13:57

Buongiorno a tutti,
Avrei un problema apparentemente banale con un foglio di calcolo (in allegato, molto semplificato e anonimizzato) ma è da due giorni che non riesco a risolvere.
In una colonna (A2) ci sono dei valori testuali (con B2 C2 D2 alcune proprietà),
in un'altra colonna E2 (con F2-H2 altre proprietà) c'è un altro elenco con solo alcuni dei valori testuali presenti in A2.
Vorrei semplicemente ordinarli, allineando i dati delle colonne E2-H2 alle A2-D2 quando il valore A2=E2.
come posso risolvere?
Devo usare una macro?
Grazie
Allegati
EsempioF.ods
(16.05 KiB) Scaricato 6 volte
Ultima modifica di Giaccio il giovedì 18 luglio 2019, 17:18, modificato 1 volta in totale.
Open Office Versione: 5.1.6.2 su Ubuntu 14.04
Giaccio
 
Messaggi: 2
Iscritto il: giovedì 18 luglio 2019, 13:27

Re: Allineare differenti colonne di dati

Messaggioda charlie » giovedì 18 luglio 2019, 14:29

Ciao e benvenuto/a sul forum.
Se intanto ti vuoi presentare puoi farlo in questa sezione -> https://forum.openoffice.org/it/forum/viewforum.php?f=16
Per una panoramica delle regole del forum puoi consultare il Manuale di sopravvivenza -> http://forum.openoffice.org/it/forum/viewtopic.php?f=1&t=2

Buon proseguimento.
charlie
macOS 10.12 Sierra: Open Office 4.1.5 - LibreOffice 6.0.7
Windows 7 pro (VirtualBox): Open Office 4.1.5 - LibreOffice 5.4.4.2
Ubuntu 17.04 LTE (VirtualBox): LibreOffice 5.1.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 6008
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Allineare differenti colonne di dati

Messaggioda gioh66 » giovedì 18 luglio 2019, 14:37

Buondì. Una soluzione con formule (non so scrivere macro) potrebbe essere: in I1 da tirare a destra e in basso
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE.ERRORE(CERCA.VERT($A2;$E$2:$H$16;COLONNE($E$2:E2)+1;0);"")

e poi nascondere le colonne da E a H
Allegati
allineare dati.ods
(18.3 KiB) Scaricato 7 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Allineare differenti colonne di dati

Messaggioda ghost38 » giovedì 18 luglio 2019, 14:43

Condivido quello che dice gioh66, però forse meglio usare indice e confronta se hai tante righe.
OpenOffice 3.1 su Windows Vista
ghost38
 
Messaggi: 30
Iscritto il: giovedì 6 aprile 2017, 16:46

Re: Allineare differenti colonne di dati

Messaggioda Giaccio » giovedì 18 luglio 2019, 16:11

Sembra funzionare, ora vedo se riesco ad applicarla ai databases....
Grazie mille @gloh66 e @ghost 38, mi risparmiate ore di lavoro !
Open Office Versione: 5.1.6.2 su Ubuntu 14.04
Giaccio
 
Messaggi: 2
Iscritto il: giovedì 18 luglio 2019, 13:27


Torna a Calc

Chi c’è in linea

Visitano il forum: gioh66, lucky63 e 11 ospiti